LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   nfs permissions (http://www.linuxquestions.org/questions/slackware-14/nfs-permissions-506216/)

cuk 11-30-2006 09:26 AM

nfs permissions
 
Hello,
The files which I put on the nfs share are read only by default. How to change this? I tried umask=000 , but I am told "unknown nfs mount parameter: umask=0"
fstab>>
xx.x.x.x:/home/cuk/share /mnt/share nfs auto,users,rw,rsize=8192,wsize=8192,hard,intr 0 0

acid_kewpie 11-30-2006 10:17 AM

as nfs is a posix compliant unix filesystem it does not need to deal with permissions and rights fudging, unlike samba, in the main. the rights set on the files actually on the server are passed straight through, so you'd be looking at changing them on the server irrespective of NFS.

cuk 11-30-2006 05:08 PM

Thank you for the quick answer. But how to do it? I can easily change the permissions after the files are moved to the share, but this extra step is exactly what I am trying to eliminate. I'll try to explain it once more in detail. There is cuk's laptop and bok's desktop. cuk is sharing a directory in his home folder, permissions are 775. bok mounts it onto /mnt/cuks_shared , which is owned by him. The directory and all the files in it are 775. He copies a new document inside /mnt/cuks_shared, but this new document becomes read only. He has to change permissions to rw so cuk can start working with it. How do I enable that the new files copied into /mnt/cuks_shared are right away rw, without the extra step of chmodding them? Sorry if I am insulting your intelligence with this lenghty explanation, just trying to make sure there is no misunderstanding. Thanks again, best regards
cuk

justwantin 11-30-2006 09:07 PM

the nfs howto is very straight forward and easy to understand. I can't remember off to top of my head but I think you'd be looking at editing /etc/exports.conf. The howto explains the options

satish.lx 02-25-2009 09:42 AM

You can used ACL to ignore umask and you can use what ever permission need on NFS share

acid_kewpie 02-25-2009 09:50 AM

please don't drag up dead threads. 3 years down the road there is no point replying.

satish.lx 02-26-2009 07:08 PM

This post for not existing thread, its for who are looking solution related to this error one day i was also find solution on net related to this problem and i didn't got any solution related to this issue.


All times are GMT -5. The time now is 02:58 PM.