LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   nfs "ignoring line due to no section" (http://www.linuxquestions.org/questions/slackware-14/nfs-ignoring-line-due-to-no-section-872750/)

Woodsman 04-03-2011 05:07 PM

nfs "ignoring line due to no section"
 
I see this message in Current every time I mount some remote nfs v3 shares, whether manually or from fstab.

All I find on the web are multiple copies of a post when the patch was submitted containing that message.

I don't know C++ and don't know what the message means.

I don't see the message when booting 13.1 and connecting to the same remote nfs v3 shares.

Adding /etc/nfsmounts.conf and "nfsvers=3" in the mount parameters does not eliminate the message.

The message seems harmless. The shares get connected. Still, who likes superfluous messages during booting?

I'm grateful for help understanding what the messages mean and whether they can be quashed.

guanx 04-03-2011 08:19 PM

From the code in
"slackware-current/source/n/nfs-utils/nfs-utils-1.2.3.tar.xz#utar/nfs-utils-1.2.3/support/nfs/conffile.c", you are missing a "section" before the name/value pairs.

[section] <- missing
name=value
or
name value

Woodsman 04-03-2011 09:38 PM

Quote:

From the code in...
Oh. Okay. I had the following in nfsmount.conf:

Defaultvers=3

I added a section named [NFSMount_Global_Options] and placed Defaultvers=3 in that section.

Seems to have stopped the messages.

Thanks.


All times are GMT -5. The time now is 09:51 AM.