LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-24-2004, 02:38 PM   #1
xaos5
Member
 
Registered: Dec 2004
Distribution: debian and slackware
Posts: 217

Rep: Reputation: 31
nforce sound problem


just switched from mandrake to slackware and im having a problem setting up sound. I ran alsaconf and it worked fine i at least have a little bit of sound. I tryed installing the nforce drivers and it complained of the kernel not being compiled or something? the sound right now is giving static sounds and only kde can use the sound (xmms complains that the sound device is in use). and is there a way so that more than one program can use the sound? in mandrake I could use xmms, but gaim/kopete/kde wouldn't be able to play sounds and vise versa.

heres my modules.conf file:

alias char-major-195 nvidia

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.5 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

i've been trying to figure this out for a while and i read the alsa howto files but i don't understand them. Trying to switch from windows only been running linux for about a month.
 
Old 03-19-2007, 10:37 PM   #2
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 197

Rep: Reputation: 30
I am in a similar situation. Namely, I just installed the alsa drivers i found here:
Code:
ftp://61.56.69.18/pc/audio/realtek-linux-audiopack-4.05f.tar.bz2
There were no error messages when I executed the install script. KAAPA and Azzizz in ##slackware on freenode have pointed out that alsamixer starts muted, so i need to unmute somehowe.

Oh and for the record:
Code:
bash-3.1$ cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.11.
Compiled on Sep  1 2006 for kernel 2.4.33.3.
What does it mean to "load modules"?

edit:sp

Last edited by Drone4four; 05-14-2007 at 11:10 PM.
 
Old 03-19-2007, 10:43 PM   #3
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 197

Rep: Reputation: 30
This command autoconfigured everything for me:
Code:
alsaconf
problem solved.
 
Old 05-14-2007, 11:57 PM   #4
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 197

Rep: Reputation: 30
I am now on Slamd64 and the install script inside that bz2 source fails. Here is the tail end of the ./install code:
Code:
Making all in m4
make[1]: Entering directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-
1.0.9a/m4'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-1
.0.9a/m4'
make[1]: Entering directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-
1.0.9a'
make[1]: Nothing to be done for `all-am'.
make[1]: Leaving directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-1
.0.9a'
Making install in include
make[1]: Entering directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-
1.0.9a/include'
make[2]: Entering directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-
1.0.9a/include'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-1
.0.9a/include'
make[1]: Leaving directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-1
.0.9a/include'
Making install in alsactl
make[1]: Entering directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-
1.0.9a/alsactl'
make[2]: Entering directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-
1.0.9a/alsactl'
/bin/sh ../mkinstalldirs /usr/sbin
  /usr/bin/ginstall -c alsactl /usr/sbin/alsactl
/usr/bin/ginstall: cannot remove `/usr/sbin/alsactl': Permission denied
make[2]: *** [install-sbinPROGRAMS] Error 1
make[2]: Leaving directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-1
.0.9a/alsactl'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/tmp/apps/realtek-linux-audiopack-4.05f/alsa-utils-1
.0.9a/alsactl'
make: *** [install-recursive] Error 1
cp: cannot remove `/usr/lib64/libasound.so.2': Permission denied
cp: cannot remove `/usr/lib64/libasound.so.2.0.0': Permission denied
./install: line 72: ldconfig: command not found
ln: creating symbolic link `/dev/sndstat' to `/proc/asound/oss/sndstat': Permiss
ion denied
cp: cannot create regular file `/usr/share/sounds/alsa/test.wav': Permission den
ied
Remove Folder.....
./install: line 102: alsaconf: command not found
Workaround?
 
Old 05-15-2007, 12:07 AM   #5
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 197

Rep: Reputation: 30
nvm, thrice' on FreeNode suggested I just type alsamixer as root and that worked. I had to increase the PCM bar to 75% and master to 100%. There is, therefore, no need to install alsa drivers because they are already installed.

Last edited by Drone4four; 05-15-2007 at 12:08 AM.
 
Old 05-15-2007, 02:01 AM   #6
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Rep: Reputation: 15
Hang on Drone4four...
Make sure that after running alsamixer
and unmuting everything you need and added volume
you run alsactl store AS root to save
the changes or you will be reajusting
everytime after reboot.
 
Old 05-15-2007, 05:04 AM   #7
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
the sollution for xaos5 was to kill artsd. it makes sh*t as always. use better mixer,
 
Old 05-21-2007, 11:12 PM   #8
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 197

Rep: Reputation: 30
Quote:
Originally Posted by Drone4four
nvm, thrice' on FreeNode suggested I just type alsamixer as root and that worked. I had to increase the PCM bar to 75% and master to 100%. There is, therefore, no need to install alsa drivers because they are already installed.

I also need to press "m" to unmute PCM and Master!
 
Old 05-22-2007, 05:23 AM   #9
mrapathy
Member
 
Registered: Nov 2005
Distribution: debian/slackware
Posts: 90

Rep: Reputation: 17
no idea what you guys are talking about?

whats your hardware? bleeding edge is a pita
may try checking newer kernel and hardware support
post pci info
whats the OS? 64 or original slack?
lsmod what modules loaded?

lack of information never got anybody anywhere.

what kernel did you install? did you install the module files from testing/extra directory? try changing the kernel and making sure the module is available? reinstall modules.

boot with kernel off install cd use huge26.s or test26.s
Slax5 bootable cd slackware derivative has good hardware detection
huge26.s also did good for me.

boot to slackware root partition.

I have a Foxconn 6150K8MD-8EKRSH 6150/430 video/northbridge and ALC880 sound
snd_hda_intel also seen info saying intel8x0 yet my module when loaded is snd_hda_intel. tried intel8x0 and think it worked. using alsa modules.

try getting Slax 5 on bootable cd try booting it and go back to your slackware os and compare.

I have sound working had to redirect /dev/dsp. installed something that changed /dev/ director moved dsp files to subdir which screwed things up.
I have sound working but can only have one program working with sound. if I try running a video with youtube,xine whatever another program and it wont have audio might lose audio with other program having to restart programs if not kde.

check kde control panel->multimedia->sound and setup settings click tab on the right hardware go for alsa or oss.

toy with alsamixer unmute stuff. if using kde use kmix and check volumes and mutes. dont forget to use alsactl store after setting alsamixer

try alsaconf?

Last edited by mrapathy; 05-22-2007 at 05:47 AM.
 
Old 05-22-2007, 07:46 AM   #10
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
If you want to get sound at the same time from different apps, you need a mixer. There are 2 versions: hardware (not in cheap integrated cards) and software. Software mixers are these: artsd (kde), esd (gnome) and dmix(alsa < 1.0.9rc2). In addition, it is possible to mix sounds using SDL. If you have older than that alsa, you need to set up dmix. If newer, then dmix is already integrated. I suggest using alsa mixer, because I've experienced lots of bugs with artsd. There might an be oss mixer too, but I don't know about it.
 
Old 05-22-2007, 08:06 AM   #11
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
This is slam64 right?

If it is the drivers you compiled, they may not have worked unless you compiled them 32 bit and 32 bit compatibility into the kernel. Had some interesting problems with my network card and sound with Slam64, but worked after i compiled in 32 bit capability into the kernel. (flash driver also worked then)
 
Old 05-22-2007, 06:58 PM   #12
mrapathy
Member
 
Registered: Nov 2005
Distribution: debian/slackware
Posts: 90

Rep: Reputation: 17
thanks for the reply on on my sound issue. I had a tv tuner card installed and think that gave me a problem. loaded a alsa driver for the tuner and my problem is now gone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA MIDI: Sound fonts for NVIDIA/NForce Soundstorm on-board sound vharishankar Linux - Hardware 6 09-04-2007 01:37 PM
problems with nforce 2 sound z3rgl1ng Linux - Hardware 1 08-11-2005 04:23 AM
How to get nForce 2 sound working blood_omen *BSD 9 04-09-2005 06:53 PM
Mandrake 9.2 sound problem (5.1 Nforce) flesh99 Linux - Hardware 3 03-21-2004 09:22 AM
nForce, 2.6.3, Knoppix, and Sound Owen Glendower Linux - Hardware 2 03-11-2004 09:36 PM


All times are GMT -5. The time now is 12:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration