LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-01-2012, 05:05 AM   #1
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Rep: Reputation: 56
next kde 4.8.2 regression: firefox/thunderbird joined the all-blacks


This is a complex issue which i found only on one of my machines (unfortunately affecting 4 users):

The background and menus of firefox/thunderbird turned completely black. Together with the black font colour the apps are totally unusable. In the edit->preferences->content->colors dialog the entire colour palette appears to be black.

I found this only happens if the previous desktop session was a kde session. So if the current session is kde and the previous was xfce, the colours are fine.if the current is xfce and the previous was kde, the colours are black.

As I said, two machines are fine, the third one has this issue in all four user accounts.

Workaround is to roll out xfce to all users and dump kde at last. don't like the blue glow of the oxygen theme that seems to be unconfigurable in 4.8.2 anyway.

Has anyone seen such a thing? Google is remarkably quiet on this one.
 
Old 05-01-2012, 05:52 AM   #2
phi11ip
Member
 
Registered: Jul 2007
Location: Nottingham, UK
Distribution: Slackware64-current
Posts: 51

Rep: Reputation: 14
I have something similar on my desktop machine, but it's when I change the KDE splash screen Firefox goes all black. A reboot seems to cure it. As I only change splash screen when I upgrade to a newer version of KDE it is no great hassle. I wonder, is it something to do with Nvidia drivers? I have got an Nvidia GTX220 graphics card with propriety 64-295.33 driver.
 
1 members found this post helpful.
Old 05-01-2012, 07:36 AM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,431

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Yes, I have seen this. I isolated the problem to occurring after I had booted into an X session, then logged out, then logged back in. If I do a cold boot after logging out then the problem does not occur. I have only seen this occurring an a machine with nVidia graphics using the proprietary driver. I have not tried this, but a possible fix could be to uncomment "#TerminateServer=true" in /etc/kde/kdm/kdmrc.
 
1 members found this post helpful.
Old 05-01-2012, 08:17 AM   #4
bosth
Member
 
Registered: Apr 2011
Posts: 222

Rep: Reputation: 68
Does this affect all Gtk applications or just FF and TB? Do you have any of gtk-kde, QtCurve-Gtk, gtk-qt-engine or similar SBo packages installed that might be interfering with the standard KDE colours for Gtk applications?
 
1 members found this post helpful.
Old 05-01-2012, 10:08 AM   #5
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Original Poster
Rep: Reputation: 56
thx to all who replied. yes, the machine has a GeForce GT 240 card and uses the proprietary driver, currently 295.40.

Quote:
Originally Posted by bosth View Post
Does this affect all Gtk applications or just FF and TB? Do you have any of gtk-kde, QtCurve-Gtk, gtk-qt-engine or similar SBo packages installed that might be interfering with the standard KDE colours for Gtk applications?
You're defintely on to something. Upon further checking it affects all Gtk applications (like Gimp and some xfce apps). The machine has qtcurce-gtk2, qtcurve-kde4 and gtkglex installed. I have just upgraded to the latest available qtcurve-gtk2-1.8.15, qtcurve-kde4-1.8.12 but the issue persists.

The funny thing is, another machine with basically the same software installation (and Geforce GTX 560 Ti hardware) has no such problem...
 
Old 05-01-2012, 11:09 AM   #6
bosth
Member
 
Registered: Apr 2011
Posts: 222

Rep: Reputation: 68
I use qtcurve and have never encountered the problem you are describing. However, some of the other packages that attempt to make Qt and Gtk applications look the same have caused issues for me in the past.

You could try uninstalling these packages and/or create a new user with a clean home directory to see if the problem is related to an old config file somewhere.

I also recall manually setting up a symlink for a Gtk config file somewhere in my home directory at one point. I'll try to remember to check what is was this evening.
 
1 members found this post helpful.
Old 05-01-2012, 01:30 PM   #7
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 50
I think I can help here. I had this very same problem.
The fix is in /etc/kde/kdm/kdmrc

at line 509

uncomment #TerminateServer=true (ie remove the #, ok you knew that)

regards
tobyl

Last edited by tobyl; 05-01-2012 at 01:31 PM. Reason: spelling
 
1 members found this post helpful.
Old 05-01-2012, 03:13 PM   #8
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Original Poster
Rep: Reputation: 56
thanks allend & tobyl. While hunting for the right section i noticed there are a few references to this issue on the intarwebz. I found out the line goes into section [X-:*-Core]. Looks promising. I will wait for user feedback and - if all goes well - set this thread to closed.

MB: Afterwards I noticed there was a kdmrc.new waiting, which indeed has the required comment in line 509.
 
Old 05-02-2012, 02:13 AM   #9
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Original Poster
Rep: Reputation: 56
marking the thread as solved (although quite frankly the solution is just a workaround for some unidentified software issue)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox and Thunderbird - KDE thinks same application. Jyde Linux - Desktop 0 06-17-2007 05:23 PM
Links in Thunderbird do not open Firefox on KDE chakatz Linux - Software 4 01-08-2006 09:31 AM
Mozilla,Firefox,Thunderbird shuts down KDE mickeyboa Fedora 1 03-19-2005 05:02 PM
KDE Default Browser Problems with firefox and thunderbird gnat79 Linux - Software 3 02-16-2005 02:10 PM
Firefox/Thunderbird install and KDE how-to? Slovak Slackware 9 11-16-2004 12:50 PM


All times are GMT -5. The time now is 08:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration