LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2004, 01:40 PM   #1
jsfour
Member
 
Registered: Dec 2003
Posts: 32

Rep: Reputation: 15
newest kernel is solid!!!but no sound


hey i just updated my kernel but the only problem is i couldnt get the sound to work so here is what i did. I changed it so it included only moular sound (alsa) and then i updated alsa to the most current...when i ran thoes modules (modprobe snd-cs46xx) it finally worked. But that is only for that session. When i restart or switch users the sound goes away. How can i fix this. I am runnins slack9.0 on an ibm thinkpad 21m usingg the most current kernel and the dropline interface (login manager) the sound drivers i need to run are the cs46xx drivers.... HELP because ive got everything else running solid as hell besides this.
 
Old 03-24-2004, 02:14 PM   #2
bhaskie
Member
 
Registered: Jan 2004
Location: New Delhi, India
Distribution: L.F.S 5.0 | FreeBSD 5.2 | Debian sid | Gentoo 2004.0 | Slackware 9.1
Posts: 78

Rep: Reputation: 15
Your sound channels get muted (that happens a lot with ALSA). Use a script to unmute the audio channels when a user logs on. Search google for the script. Else you can save audio mixer settings in KDE if you use it.
 
Old 03-24-2004, 02:47 PM   #3
flyfishin
Member
 
Registered: Aug 2003
Location: KC, MO
Distribution: CentOS, RHEL, SuSE, Fedora
Posts: 243

Rep: Reputation: 30
Use the command 'alsamixer' to set volume levels then use the command 'alsactl store' to save the settings and all should be well on a reboot.
 
Old 03-24-2004, 05:23 PM   #4
jsfour
Member
 
Registered: Dec 2003
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by bhaskie
Your sound channels get muted (that happens a lot with ALSA). Use a script to unmute the audio channels when a user logs on. Search google for the script. Else you can save audio mixer settings in KDE if you use it.
ok then how can i run this on startup?
 
Old 03-24-2004, 06:08 PM   #5
bhaskie
Member
 
Registered: Jan 2004
Location: New Delhi, India
Distribution: L.F.S 5.0 | FreeBSD 5.2 | Debian sid | Gentoo 2004.0 | Slackware 9.1
Posts: 78

Rep: Reputation: 15
Quote:
Originally posted by flyfishin
Use the command 'alsamixer' to set volume levels then use the command 'alsactl store' to save the settings and all should be well on a reboot.
Running this once should solve your sound problem. If it doesnt, open the KDE control center, browse down to
Sound & Multimedia -> Sound System

in aRTs tab, enable "Start aRts soundserver....."
in SOund I/O , select autodetect
in mixer, select "load volumes on login."
remember to set the volumes first, test the sound, save current volumes before performing the last step.

For xmms, you can use libartsout.so output plugin for sound output.


Last edited by bhaskie; 03-24-2004 at 06:23 PM.
 
Old 04-01-2004, 05:05 AM   #6
jsfour
Member
 
Registered: Dec 2003
Posts: 32

Original Poster
Rep: Reputation: 15
but i am using dropline
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New install with the newest kernel? anti.corp Slackware 3 11-23-2005 01:40 PM
FC3 newest kernel! bluknight43 Linux - Software 0 02-15-2005 05:46 PM
What, no Gr-security in the newest kernel? subzero0 Linux - General 1 02-19-2004 02:34 PM
The Linux Kernel (What's the newest version?) jlacroix Fedora 6 01-25-2004 01:54 AM
debian not using newest kernel... closet geek Linux - Software 4 05-28-2003 02:06 PM


All times are GMT -5. The time now is 04:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration