LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2012, 11:53 AM   #16
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,380

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840

Quote:
Originally Posted by arubin View Post
He really needs to get startx working before going into runlevel 4 or he will find himself stranded. If startx does not work there is something wrong - likely do be the video driver.
yes, that's why I advised him to try disable compositing in the first place.
 
Old 11-21-2012, 05:36 AM   #17
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 324

Rep: Reputation: 49
have a look here too - should help you get started with Slackware.


docs.slackware.com/slackware:beginners_guide
 
Old 11-21-2012, 02:11 PM   #18
qweasd
Member
 
Registered: May 2010
Posts: 436

Rep: Reputation: Disabled
Quote:
Originally Posted by nando321 View Post
Greetings folks. I have just finished installing my Slackware system but I have found this far that I cannot login into the Kde desktop it just shows the first icon on the animation of the login screen of kde and immediately takes me back to the user and password screen.
I've seen this behavior with incomplete graphics support. If going from kdm, try logging into a failsafe KDE session. If it works, then disable desktop effects and log in normally.
 
Old 11-21-2012, 02:26 PM   #19
qweasd
Member
 
Registered: May 2010
Posts: 436

Rep: Reputation: Disabled
Quote:
Originally Posted by nando321 View Post
Thank you for aiding me. This is what I have done this far, su - then type password then vi /etc/inittab but I cannot delete any digit or write anything.
Using vi is too hard. Let the computer edit the file for you The following will change the default runlevel and kdm will start on boot:
Code:
sed -i.bak s/^id:3:initdefault:/id:4:initdefault:/ /etc/inittab
 
Old 11-21-2012, 02:29 PM   #20
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by qweasd View Post
Using vi is too hard. Let the computer edit the file for you The following will change the default runlevel and kdm will start on boot:
Code:
sed -i.bak s/^id:3:initdefault:/id:4:initdefault:/ /etc/inittab
But using sed without knowing exactly what it does is dangerous (in my opinion). But both vi and sed are worth learning and therefore should be used.

Markus
 
Old 11-21-2012, 04:53 PM   #21
Dman58
Member
 
Registered: Nov 2010
Location: The Danger Zone
Distribution: Slackware, Mint, & random selection for VM
Posts: 213

Rep: Reputation: 26
As root Try:

nano /etc/inittab

Nano should open a window

Then hit the down arrow on the keyboard and go to the line with the default set to 3. Change it to 4 and hit Ctrl x on the keyboard. Then follow the prompts to save it. Its pretty self explanitory from their. After exiting the editor use the

startx command

Does your DE start?

Reboot your system & it should login
 
Old 11-21-2012, 09:03 PM   #22
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,331

Rep: Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381Reputation: 1381
I agree that the init level in inittab has nothing to do with this. Don't waste your time with it. The issue is not the init level--it's the failure of the GUI to start.

I would suggest this as another possible test, in addition to the other excellent suggestions you've gotten:

After logging in at the command line and before running startx, run xwmconfig as user and change your default window manager to something other than KDE. I would suggest Fluxbox or Blackbox or one of the other lightweight window managers.

Run startx and see if the GUI starts.

If it does, it indicates that the problem is something to do with KDE specifically. If it doesn't, you have a larger issue.

Note any error messages that come to the screen when you run startx (you may want to take a digital picture for convenience--if you do, turn off the flash and, if possible, set the camera to "S" or "shutter-priority" mode).

You could also log directly into the box as root (Slackware allows that) and try startx to test whether the GUI starts correctly.

Good luck.

Last edited by frankbell; 11-21-2012 at 09:05 PM.
 
Old 11-22-2012, 07:31 AM   #23
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 324

Rep: Reputation: 49
I don't use a graphical log-in manager but wonder if you need to specify the session type you want to use?

Have you tried using SLIM to determine whether it's a KDE or KDM problem?

Apologies if this ground's already been covered.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slack64 -current can't log into KDE 4.5.4 with desktop effects enabled rpedrica Slackware 3 12-21-2010 06:56 AM
Ubuntu and the KDE desktop install shows xterm in the sessions box, wont log me in/ sandago Linux - Desktop 4 04-01-2010 09:57 PM
KDE Remote Desktop Server log files BillyGalbreath Linux - Networking 3 03-12-2006 05:24 PM
Can't log off KDE in Slackware rrsc16954 Slackware 9 12-12-2003 06:10 PM


All times are GMT -5. The time now is 03:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration