LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2012, 09:02 AM   #1
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Rep: Reputation: 1
Newbie to Slackware. Cannot log in to KDE desktop


Greetings folks. I have just finished installing my Slackware system but I have found this far that I cannot login into the Kde desktop it just shows the first icon on the animation of the login screen of kde and immediately takes me back to the user and password screen. Also before I can reach the login screen I must login as root and start kdm manually by typing kdm.

Please, any help will be very appreciated. Thank you.
 
Old 11-20-2012, 09:09 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Did you edit /etc/inittab and set the default run level to 4 ?
 
Old 11-20-2012, 09:10 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
well if you just run the login manager and nothing else, that I'd imagine that's all it should do. If you're not booting to runlevel 4 in /etc/inittab then you'd normally run "startx" as the user you want, you wouldn't lof in graphically.
 
Old 11-20-2012, 09:35 AM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
Dangerous thing IMHO to change the run level to 4 before checking that everything is working Ok with startx from run level 3.
 
Old 11-20-2012, 09:41 AM   #5
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
Hey guys! Excuse me for my ignorance I didn't figure that was really so important but how can I do it? (I am a mess I know...)
I mean I cannot use nano (it is installed tho..), it says command not found. I cannot use kate, it won't allow me to save it or open it if I login to the console. What's up next?
I hope to don't bother you asking for some further helping.
 
Old 11-20-2012, 09:56 AM   #6
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
You don't have to do anything with a text editor just yet. First see if you can log into kde by running startx.
 
Old 11-20-2012, 10:10 AM   #7
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
@arubin Just as I suspected I cant do startx the same thing happens. Also I have found that in /etc/inittab I dont have any lines such as id.4............... or id.3.................

Thanks again.
 
Old 11-20-2012, 10:16 AM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hi,

does kdm give you an option for a "console" or "shell" login as root? if yes, login as root and execute
Code:
telinit 3
which brings you back to runlevel 3.

Testing the setup for kdm (before making runlevel 4 the default!) can be done from runlevel 3 as root with
Code:
telinit 4
if it doesn't work, you'll be back to runlevel 3 after rebooting.

Markus

Last edited by markush; 11-20-2012 at 10:20 AM.
 
Old 11-20-2012, 10:18 AM   #9
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
If you do not change anything in inittab, there will be a 3 instead of the 4 you see in mine. Does your file not look like this? Are you sure you are looking at /etc/inittab?
 
Old 11-20-2012, 10:26 AM   #10
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
@camorri Yes, now I know what I should change thanks to your explanation. In the last line I have id.3.initdefault

Now I would like to know how to edit /etc/sudoers to make my user belong to sudoers, what commands use to edit that and also /etc/inittab
 
Old 11-20-2012, 10:26 AM   #11
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
nando, have a look at CHANGES_AND_HINTS.TXT

Code:
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects).  Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
  Option "Composite" "Disable"
EndSection
to edit files become root
Code:
su -
(the "-" at the end is mandatory to have a proper environment)
then use vi (or pico or what you prefeer).
It's much better for you to operate in a root shell (with the proper environment) than to use sudo (I'll avoid that).

Last edited by ponce; 11-20-2012 at 10:33 AM.
 
Old 11-20-2012, 10:30 AM   #12
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
Now I would like to know how to edit /etc/sudoers to make my user belong to sudoers, what commands use to edit that and also /etc/inittab
I have never user sudoers, although I know it is possible. I simply use 'su' and switch to root. You do have to enter the root password. Then you can edit any file that is owned by root.
 
Old 11-20-2012, 10:38 AM   #13
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
Thank you for aiding me. This is what I have done this far, su - then type password then vi /etc/inittab but I cannot delete any digit or write anything.
 
Old 11-20-2012, 10:39 AM   #14
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
http://acms.ucsd.edu/info/vi_tutorial.html

(to exit use the esc key, followed by :q!)

try pico instead of vi, you may find it easier, but in the long term you may want to use vi, it will be available pretty much on every unix machine you will use.

Last edited by ponce; 11-20-2012 at 11:41 AM.
 
Old 11-20-2012, 11:48 AM   #15
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
He really needs to get startx working before going into runlevel 4 or he will find himself stranded. If startx does not work there is something wrong - likely do be the video driver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slack64 -current can't log into KDE 4.5.4 with desktop effects enabled rpedrica Slackware 3 12-21-2010 06:56 AM
Ubuntu and the KDE desktop install shows xterm in the sessions box, wont log me in/ sandago Linux - Desktop 4 04-01-2010 09:57 PM
KDE Remote Desktop Server log files BillyGalbreath Linux - Networking 3 03-12-2006 05:24 PM
Can't log off KDE in Slackware rrsc16954 Slackware 9 12-12-2003 06:10 PM


All times are GMT -5. The time now is 11:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration