LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Newbie questions of post-installation of Slackware (http://www.linuxquestions.org/questions/slackware-14/newbie-questions-of-post-installation-of-slackware-128522/)

ICO 12-23-2003 08:28 PM

Newbie questions of post-installation of Slackware
 
Please help me out about this.

1. During installation, I have three errors says the following file may be corrupted, how can I fix it after installation:
/var/log/mount/slackware/l/db3-3.3.11-i386-3.tgz
/var/log/mount/slackware/l/glibc-i18n-2.3.2-noarch-1.tgz
/var/log/mount/slackware/x/xfree86-fonts-100dpi-4.3.0-noarch-2.tgz

2. In the desktop preferences panel, I click the screen resolution option, I don't have option to choose my monitor can run on 85 mhz refresh rate. When I used RedHat 9, I can do it. How can I fix this.
Code:

I fixed this problem already.
I edit the /etc/X11/XF86Config configuration file and make it work.

3. Now when I boot the system, I don't have option for booting windows xp, and I want to boot into x, at the moment, I only can boot into the console.

4. When the system, boot to the console, I have a logo on the top of the screen, how can I get rip of that.

5. I can't use the wheel in the middle of my mouse, how can I set it up?

Thank you for help deeply.

320mb 12-23-2003 09:04 PM

what kind of mouse do you have??
http://www.linuxquestions.org/questi...der=descending

Protex 12-23-2003 09:22 PM

Well, I can help with a couple of the problems.

To add windows xp:
1) open a console
2) su
3) pico /etc/lilo.conf
4) now add this at the end of the file:
other=/dev/hda1
label=Windows
boot-as=0x80
5) save by ctrl-x
6)now type 'lilo' (without the quotes) in your console

For the mouse scroll:
1) open a console
2) su
3) pico /etc/X11/XF86Config
4) page down till you find your mouse section it should be under 'Identifier "Mouse1" '
5) add Option "ZAxismapping""4 5"
6) ctrl-x to exit and save
7) quit X
8) startx

To reinstall those packages:
1) go to a mirror and download them again
2) open a console
3) cd to the directory where you put those files
4) su
5) pkgtool
6) select current directory
7) say yes to all those packages needed

Hope this helps

ICO 12-23-2003 10:51 PM

Thanks for help.
I can boot my windows now. But the mouse is still not working.

Also, anyone tells me that what package I should reinstall for those three error files I listed on top the this thread?

Thanks.

ICO 12-23-2003 11:11 PM

And how can I create a new user account in Slackware?
Thanks

coldAndUgly 12-23-2003 11:15 PM

Try changing the mouse protocol line to,
Code:

Option "Protocol"    "IMPS/2"
even if you don't have an Intellimouse, that works for me.
Also try,
Code:

Option "ZAxisMapping" "4 5"
I'm not sure if the capital M makes any difference or not, but worth a try.

Bruce Hill 12-23-2003 11:45 PM

Quote:

Originally posted by ICO
And how can I create a new user account in Slackware?
Thanks

as root ->
# adduser <username>

ICO 12-24-2003 12:48 AM

Thank you guys.
My mosue is working now, I forgot to comment out the Option "Protocol" "PS/2" line.
And I add a new user already.
Thanks

Bruce Hill 12-24-2003 02:28 AM

Quote:

Originally posted by ICO
Thank you guys.
My mosue is working now, I forgot to comment out the Option "Protocol" "PS/2" line.
And I add a new user already.
Thanks

Cool, man! Are you ready to format c:/q Windoze XP and fix the problems with it, yet? Just kidding! ;)

:cool:

Netizen 12-24-2003 09:41 AM

If you haven't configured your system to go straight into X on boot, edit /etc/inittab .

Change the run level to 4 instead of 3. Save and exit and reboot.

Netizen

fang0654 12-24-2003 10:59 AM

With the logo on top deal, that's a kernel option I'm pretty sure (at least it is for 2.6).. You can get rid of it by recompiling the kernel :)

ICO 12-24-2003 04:04 PM

cheers.

ICO 12-24-2003 04:50 PM

Just before, I try to install those three error files, and it gives me error again.

for
/var/log/mount/slackware/l/db3-3.3.11-i386-3.tgz

it says:
Unable to install db3-3.3.11-i386-3.tgz: tar archive is corrupt (tar returned error code 2)

for
/var/log/mount/slackware/l/glibc-i18n-2.3.2-noarch-1.tgz
/var/log/mount/slackware/x/xfree86-fonts-100dpi-4.3.0-noarch-2.tgz

it gives me these:
/sbin/ldconfig: /usr/lib/libquicklounge-applet.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /usr/lib/libquicklounge-applet.so.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /usr/lib/libquicklounge-applet.so is not an ELF file - it has the wrong magic bytes at the start.


Any idea?

MobyTurbo 12-24-2003 06:40 PM

These files are available at ftp.slackware.com and mirrors, go to the version number you're using and the directory similar to what your CD has and ftp uncorrupted archives from there.

ICO 12-24-2003 06:45 PM

Quote:

Originally posted by MobyTurbo
These files are available at ftp.slackware.com and mirrors, go to the version number you're using and the directory similar to what your CD has and ftp uncorrupted archives from there.
yes, I go and download it again, it gives the errors message when I install them.
Code:

for
/var/log/mount/slackware/l/db3-3.3.11-i386-3.tgz

it says:
Unable to install db3-3.3.11-i386-3.tgz: tar archive is corrupt (tar returned error code 2)

for
/var/log/mount/slackware/l/glibc-i18n-2.3.2-noarch-1.tgz
/var/log/mount/slackware/x/xfree86-fonts-100dpi-4.3.0-noarch-2.tgz

it gives me these:
/sbin/ldconfig: /usr/lib/libquicklounge-applet.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /usr/lib/libquicklounge-applet.so.0 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /usr/lib/libquicklounge-applet.so is not an ELF file - it has the wrong magic bytes at the start.



All times are GMT -5. The time now is 12:22 AM.