LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2013, 08:24 PM   #61
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59

Try to add nomodeset in lilo.conf

Open lilo.conf, find that line in lilo
Code:
append="vt.defaullt_utf=0"
change it to
Code:
append="vt.defaullt_utf=0 nomodeset"
What drivers are you using, slackbuild or Nvidia "run"
 
Old 05-30-2013, 08:34 PM   #62
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Nikosis View Post
Try to add nomodeset in lilo.conf

Open lilo.conf, find that line in lilo
Code:
append="vt.defaullt_utf=0"
change it to
Code:
append="vt.defaullt_utf=0 nomodeset"
What drivers are you using, slackbuild or Nvidia "run"
nvidia run

Didn't work, should i reinstall slackware again :s

Last edited by SwoleGeek; 05-30-2013 at 08:49 PM.
 
Old 05-30-2013, 09:34 PM   #63
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
I just reinstalled for the 5th time.
 
Old 05-30-2013, 09:50 PM   #64
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,415
Blog Entries: 15

Rep: Reputation: 965Reputation: 965Reputation: 965Reputation: 965Reputation: 965Reputation: 965Reputation: 965Reputation: 965
When it comes to Nvidia drivers the best option is to use the SlackBuilds, and the Nouveau Blacklist package really.
 
Old 05-30-2013, 10:18 PM   #65
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Nikosis View Post
Just create a file BLACKLIST-nouveau.conf in /etc/modprobe.d, because that's what that package does

Code:
cd /etc/modprobe.d/

echo blacklist nouveau > BLACKLIST-nouveau.conf
for nvidia
download your dirver for your arch
Code:
chmod + x Nvidiaxxxxxxxxx.run
./Nvidiaxxxxxxxxx.run
Not sure how I missed this post but I am trying to do this now. I am on chmod part and don't understand what to put for x??. When I type it the way you have it says "x" is no file or directory??
 
Old 05-30-2013, 10:42 PM   #66
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
oh great, just reinstalled the drivers. Restarted the PC, type in startx and black screen. WoW
 
Old 05-31-2013, 02:01 AM   #67
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
Can you post output of your xorg.conf
Code:
cat /etc/X11/xorg.conf
 
Old 05-31-2013, 08:05 AM   #68
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
http://i.imgur.com/uvdne70.jpg
http://i.imgur.com/K7mHheB.jpg

Also I should mention when I type startx, my monitor turns black and the button starts blinking.

and the video card i have is gtx 680

Last edited by SwoleGeek; 05-31-2013 at 08:08 AM.
 
Old 05-31-2013, 10:10 AM   #69
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
Quote:
Originally Posted by Nikosis View Post
Code:
chmod + x Nvidiaxxxxxxxxx.run
./Nvidiaxxxxxxxxx.run
Quote:
Originally Posted by SwoleGeek View Post
I am on chmod part and don't understand what to put for x??. When I type it the way you have it says "x" is no file or directory??
That's because Nikosis made a "typo". There should be no space between the plus sign and "x" character, e.g. like this:
Code:
chmod +x NVIDIA-Linux-x86_64-310.32.run
Of course the exact file name will most likely be different due to other version number (310.32) or architechture (x86_64)

Let me quickly explain what that command does, because typing stuff and not knowing what should happen, may lead to such issues, if the person trying to help or the person getting that help made a tiny mistake.

chmod (means change mode) is a command most often used to change user/group privileges of a file. In this case we're trying to give the nvidia driver installer a permission to execute (+x means add execute) so that we can run it.
 
Old 05-31-2013, 11:26 AM   #70
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
Thanks for the explanation but unfortunately I still have that black screen error. I listed the images above from xorg.conf
 
Old 05-31-2013, 12:25 PM   #71
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
I'm weak when it comes to checking if xorg.conf is configured correctly, but the line
Code:
Driver "nvidia"
looks good.

Let's see if nouveau has been really blacklisted. What's the output of
Code:
lsmod | grep nouv
Learning time:
  • lsmod = lists kernel modules (fun fact: my forum name has origin in this command)
  • | = pipe, it's a vertical line, a shifted backslash, it's used to combine 2 commands
  • grep = this program does a gazzilion of things, we're using it to filter the output of lsmod to show only the lines containing the word "nouv" (because we're looking for nouveau, and typing nouv is faster and less prone to typos )

If the output shows nothing, then nouveau has been blacklisted correctly, and I don't know how to help, you'll have to wait for others to respond.

Last edited by elesmod; 05-31-2013 at 12:28 PM.
 
Old 05-31-2013, 12:45 PM   #72
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by elesmod View Post
I'm weak when it comes to checking if xorg.conf is configured correctly, but the line
Code:
Driver "nvidia"
looks good.

Let's see if nouveau has been really blacklisted. What's the output of
Code:
lsmod | grep nouv
Learning time:
  • lsmod = lists kernel modules (fun fact: my forum name has origin in this command)
  • | = pipe, it's a vertical line, a shifted backslash, it's used to combine 2 commands
  • grep = this program does a gazzilion of things, we're using it to filter the output of lsmod to show only the lines containing the word "nouv" (because we're looking for nouveau, and typing nouv is faster and less prone to typos )

If the output shows nothing, then nouveau has been blacklisted correctly, and I don't know how to help, you'll have to wait for others to respond.

Thanks for the detailed explanations and no nothing printed out.
 
Old 05-31-2013, 12:57 PM   #73
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
At the end of nvidia installation, did you allow nvidia installer to change xorg.conf for you?
Is your monitor connected with hdmi or dvi?
What is your monitor make and model?
Did you install Slackware 64 or 32bit?
Did you upgrade your kernel to 3.2.45?
The only thing I think is missing in your xorg.conf is this
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24

    Option         "metamodes" "DFP: 1280x1024_60 +0+0"
    
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
It should not cause the problem though.
 
Old 05-31-2013, 01:09 PM   #74
SwoleGeek
Member
 
Registered: May 2013
Location: In the gym
Distribution: Slackwarew 14 64x
Posts: 40

Original Poster
Rep: Reputation: Disabled
At the end of nvidia installation, did you allow nvidia installer to change xorg.conf for you?

Yes.

Is your monitor connected with hdmi or dvi?

dvi

What is your monitor make and model?

YAMAKASI CATLEAP Q270 SE 27" LED 2560X1440 WQHD DVI-D (sorry caps, copied it from spec sheet)

Did you install Slackware 64 or 32bit?

Slackware 64

Did you upgrade your kernel to 3.2.45?

I presume the update happened when I ran # slackpkg update?


Edit:

So I found this guy with the same problem on ubuntu, I know ubuntu is different but I will try what he posted:

http://ubuntuforums.org/showthread.php?t=2038997

Last edited by SwoleGeek; 05-31-2013 at 01:15 PM.
 
Old 05-31-2013, 01:11 PM   #75
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
Quote:
Originally Posted by SwoleGeek View Post

Did you upgrade your kernel to 3.2.45?

I presume the update happened when I ran # slackpkg update?
You can check it with
Code:
uname -r
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Newbie to Slackware questions TigerLinux Slackware 96 01-16-2011 04:40 PM
newbie slackware questions slinky2004 Slackware - Installation 5 10-05-2004 02:57 PM
Interested in switching to linux, some questions. blackflare Linux - Newbie 10 10-01-2004 10:11 AM
A few Slackware questions (I'm a newbie) Trust Slackware 25 03-21-2004 02:40 AM
newbie/ssh/slackware - questions renato167 Slackware 14 12-16-2003 07:31 PM


All times are GMT -5. The time now is 06:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration