LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2009, 03:59 AM   #1
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Rep: Reputation: 15
New to Slackware~Wireless setup!


Hi. I yesterday installed Slackware and I am quite impressed. I have been using Ubuntu for a year and decided to move on. My wireless worked fine in Ubuntu but it seems that it needs some configuration for Slackware...

Output of the lspci command:
Code:
01:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01
So I did some little search on the web, and found this: >Click me<

I followed the instructions and now:
ifconfig:
Code:
wlan0     Link encap:Ethernet  HWaddr 00:1f:e2:c1:93:32
          inet addr:169.254.48.23  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
iwconfig:
Code:
wlan0     IEEE 802.11bg  ESSID:"BARRIER05"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm                                                   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B             
          Encryption key:off                                                
          Power Management:off                                              
          Link Quality:0  Signal level:0  Noise level:0                     
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0          
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Note that my home network WiFi has no password or whatever. I still can't find any networks with my wireless even after the configuration. I fire up wpa_gui and it can't spot anything... Any suggestions?
Cheers

Last edited by suChris; 11-30-2009 at 04:00 AM.
 
Old 11-30-2009, 04:47 AM   #2
kite
Member
 
Registered: Aug 2003
Location: Shenzhen, China
Distribution: Slackware
Posts: 301

Rep: Reputation: 47
HI, I normally suggest using wicd to configure and connect to wireless networks. It is very easy, but do not forget to clear all your own setting in /etc/rc.d/rc.inet1.conf . It is included in the extra directory of slackware install disc (there is an updated version in slackware-current which is recommended due to a bug in previous version)
 
Old 11-30-2009, 05:33 AM   #3
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Wink

http://alien.slackbook.org/dokuwiki/...ckware:network

Enjoy!
 
Old 11-30-2009, 06:37 AM   #4
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Rep: Reputation: 32
Wireless problems are the only reason i'm not using slack 100% of the time. I just can't get it to work properly.

If you do install WICD, then somewhere there;s an option to add a "hidden network". Try typing your ESSID into here. My network is not hidden in the slightest but after i typed it into this I could see my network.

mute

Last edited by mutexe; 11-30-2009 at 06:40 AM. Reason: typo
 
Old 11-30-2009, 07:48 AM   #5
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Original Poster
Rep: Reputation: 15
Cheers.I will try this stuff and keep you posted.

Last edited by suChris; 11-30-2009 at 10:29 AM.
 
Old 11-30-2009, 12:45 PM   #6
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Original Poster
Rep: Reputation: 15
Ok first of all, I downloaded wicd. I ran it, and at the first screen it tells me that it can't see any wireless networks. And when I select to look for a hidden network, and enter my SSID name, it can't find a thing.

So I moved on to the link slackd proposed.
I edited the rc.inet1.conf and the part I edited looks like this:
Code:
# Config information for wlan0 (using dhcp):
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
WLAN_MODE[4]=Managed
DHCP_HOSTNAME[4]="ThomsonB27795"
WLAN_ESSID[4]=ThomsonB27795
HWADDR[4]="00:1f:e2:c1:93:32" 
WLAN_RATE[4]="54M auto" 
WLAN_CHANNEL[4]="auto"
ThomsonB27795 is the SSID.

So I run these commands:
Code:
/etc/rc.d/rc.inet1 wlan0_stop
And this is what happens when I move one step forward (for a strange reason, I just can't get wpa_supplicant to work*)
Code:
root@cb:/home/chris# /etc/rc.d/rc.inet1 wlan0_start
SIOCSIFHWADDR: Device or resource busy - you may need to down the interface
/etc/rc.d/rc.inet1:  wlan0 information: 'Fill with your own settings...'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
err, wlan0: timed out
warn, wlan0: using IPV4LL address 169.254.225.242
I also provide you with the output of iwconfig...
Code:
wlan0     IEEE 802.11bg  ESSID:"ThomsonB27795"
          Mode:Managed  Frequency:2.422 GHz  Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Now what? I feel like I am going somewhere...but I need some guidance.

P.S. Here is some more I just got from my terminal.
Code:
root@cb:/home/chris# wpa_cli status
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
*This is why I can't use wpa_supplicant:
Code:
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
Line 24: WPA-PSK accepted for key management, but no PSK configured.
Line 24: failed to parse network block.
Failed to read or parse configuration '/etc/wpa_supplicant.conf'
Finally this is what my wpa_supplicant.conf looks like:
Code:
# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=wheel
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=1
  ssid="ThompsonB27795"
  proto=WPA
  key_mgmt=NONE
  pairwise=CCMP TKIP
  #group=CCMP TKIP WEP104 WEP40
  #psk=your_64_char_psk_here
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
I hope this info is enough

Last edited by suChris; 11-30-2009 at 01:26 PM.
 
Old 11-30-2009, 04:10 PM   #7
agentdcooper
Member
 
Registered: Aug 2005
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
suChris, sounds like you are saying you use NO encryption on your home network according to your first post ::
Quote:
Note that my home network WiFi has no password or whatever.
also according to your earlier lspci output, your network card appears to be an ;;
Quote:
Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
I will try to help you by example :: as luck would have it I have a VERY SIMILAR network card on my slackware 13.0 x86 box so I can tell you what I have and we can go from there.

I am though asking myself why you are using WPA with NO PASSWORD? honestly I'd use (as I do) WPA2 + AES wih a strong password... but thats me, you on the other hand are using NO password, and honestly I have never used WPA with NO password (and never knew it was even possible - someone please correct me if I am wrong/elaborate). so, my thought is you actually have your WAN router configured with the wireless security options DISABLED (or some such equivalent).
^^^^ I'm hoping you can clairify the above :: specifically, please reply with your exact wireless settings on your access point router.

[*] my "lspci -vv" output
Quote:
01:01.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
Subsystem: D-Link System Inc D-Link AirPlus DWL-G520 Wireless PCI Adapter(rev.B)
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 22
Region 0: Memory at fe5e0000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [44] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
Kernel driver in use: ath5k
Kernel modules: ath5k
from the above output we can tell that I am using an atheros AR5001X+ 802.11b/g wireless card, which IIRC the model# of my card = D-Link DWL-G520. overall it's a really great wireless b/g card that supports mac address changing, packet injection, and others. also my card uses the ath5k kernel module.

[*] /var/log/dmesg output ::
Quote:
cfg80211: Using static regulatory domain info
cfg80211: Regulatory domain: US
(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
(2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
(5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
cfg80211: Calling CRDA for country: US[.....] [.....] [.....]
ath5k 0000:01:01.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ath5k 0000:01:01.0: registered as 'phy0'
ath: EEPROM regdomain: 0x10
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: CO
ath: Regpair used: 0x10
phy0: Selected rate control algorithm 'minstrel'
ath5k phy0: Atheros AR2414 chip found (MAC: 0x79, PHY: 0x45)
cfg80211: Calling CRDA for country: CO
on with the help....
personally I use the following script called "/usr/sbin/linksys-dhcp.sh" to connect to a local cafe which has a non-encrypted wifi setup ::
Code:
#!/bin/bash
#make sure to run this script with root privledges
rmmod ath5k
sleep 3
modprobe ath5k
sleep 3
/sbin/ifconfig wlan0 down
#macchanger allows you to spoof your mac address! -A set's a random VALID vendor MAC
#macchanger is freely available for download via slackbuilds.org
/usr/local/bin/macchanger -A wlan0
#
#if far from AP, or troubleshooting speed issues, change "54M" to another bitrate
#iwconfig [interface] mode {managed|ad-hoc|master|monitor} rate {auto|1|2|5.5|6|9|11|12|18|24|36|48|54} key {off|password} essid {ESSID/network_name}
/sbin/iwconfig wlan0 mode managed rate 54M key off essid "linksys"
#run "iwlist wlan0 scan" as root to identify AP MAC address u want to connect to
#enter the AP MAC address u want to connect to instead of "00:11:11:00:00:11"
/sbin/iwconfig wlan0 ap 00:11:11:00:00:11
/sbin/dhcpcd wlan0
#to enable openDNS do the following
echo "nameserver 208.67.222.222
nameserver 208.67.220.220" > /etc/resolv.conf
I use this one for static IP configurations "/usr/sbin/linksys-sta.sh", change IPs as needed.
Code:
#!/bin/bash
#make sure to run this script with root privledges
rmmod ath5k
sleep 3
modprobe ath5k
sleep 3
/sbin/ifconfig wlan0 down
#macchanger allows you to spoof your mac address! -A set's a random VALID vendor MAC
#macchanger is freely available for download via slackbuilds.org
/usr/local/bin/macchanger -A wlan0
#
#if far from AP, or troubleshooting speed issues, change "54M" to another bitrate
#iwconfig [interface] mode {managed|ad-hoc|master|monitor} rate {auto|1|2|5.5|6|9|11|12|18|24|36|48|54} key {off|password} essid {ESSID/network_name}
/sbin/iwconfig wlan0 mode managed rate 54M key off essid "linksys"
#run "iwlist wlan0 scan" as root to identify AP MAC address u want to connect to
#enter the AP MAC address u want to connect to instead of "00:11:11:00:00:11"
/sbin/iwconfig wlan0 ap 00:11:11:00:00:11
/sbin/ifconfig wlan0 192.168.1.254 netmask 255.255.255.0 broadcast 192.168.1.255
/sbin/route add default gw 192.168.1.1 wlan0
/etc/firewall/fnord-NAT.fw
#to enable openDNS do the following
echo "nameserver 208.67.222.222
nameserver 208.67.220.220" > /etc/resolv.conf
let us know if you need any further assistance...

my suggestions here should GET YOU ONLINE, but reading that link from slackd @ http://alien.slackbook.org/dokuwiki/...ckware:network appears to be THE way to go for doing it the slackware way. (( I need to setup /etc/rc.d/rc.wireless.conf, and /etc/rc.d/rc.inet1.conf properly, and I suggest you do the same going forward! ))

peace

Last edited by agentdcooper; 11-30-2009 at 04:38 PM.
 
Old 11-30-2009, 04:55 PM   #8
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Original Poster
Rep: Reputation: 15
Here is the output of lspci -vv:
Code:
01:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
        Subsystem: Hewlett-Packard Company Device 137b                                           
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx- 
        Latency: 0, Cache Line Size: 128 bytes                                                               
        Interrupt: pin A routed to IRQ 16                                                                    
        Region 0: Memory at d1300000 (64-bit, non-prefetchable) [size=64K]                                   
        Capabilities: [40] Power Management version 2                                                        
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)                 
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-                                       
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-                                           
                Address: 00000000  Data: 0000                                                                
        Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00                                              
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us                      
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-                                      
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-                           
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-                                         
                        MaxPayload 128 bytes, MaxReadReq 512 bytes                                           
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-                          
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us           
                        ClockPM- Surprise- LLActRep- BwNot-                                                  
                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk-                             
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-                                       
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-           
        Capabilities: [90] MSI-X: Enable- Count=1 Masked-                                                    
                Vector table: BAR=0 offset=00000000                                                          
                PBA: BAR=0 offset=00000000                                                                   
        Capabilities: [100] Advanced Error Reporting                                                         
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-                                                                                                            
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-                                                                                                            
                UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-                                                                                                            
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-                                
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-                                
                AERCap: First Error Pointer: 14, GenCap+ CGenEn- ChkCap+ ChkEn-                                
        Capabilities: [140] Virtual Channel <?>                                                                
        Kernel driver in use: ath5k                                                                            
        Kernel modules: ath5k
I tried to do your commands from your script. I installed macchanger. 00:1F:9F:EB:5C:9F is the physical address of my WAP. Here are the results:
Code:
root@cb:/home/chris# rmmod ath5k
root@cb:/home/chris# sleep3
bash: sleep3: command not found
root@cb:/home/chris# sleep 3
root@cb:/home/chris# modprobe ath5k
root@cb:/home/chris# sleep 3
root@cb:/home/chris# /sbin/ifconfig wlan0 down
root@cb:/home/chris# /usr/local/bin/macchanger -A wlan0 down
bash: /usr/local/bin/macchanger: No such file or directory
root@cb:/home/chris# /usr/local/bin/macchanger -A wlan0 down
Current MAC: 00:1f:e2:c1:93:32 (unknown)
Faked MAC:   00:01:e1:02:e5:f9 (Kinpo Electronics, Inc.)
root@cb:/home/chris# /sbin/iwconfig wlan0 mode managed rate 54M key off essid "linksys"
root@cb:/home/chris# /sbin/iwconfig wlan0 mode managed rate 54M key off essid "ThomsonB27795"
root@cb:/home/chris# iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Network is down

root@cb:/home/chris# /sbin/ifconfig wlan0 up
root@cb:/home/chris# iwlist wlan0 scan
wlan0     No scan results

root@cb:/home/chris# /sbin/iwconfig wlan0 ap 00:1F:9F:EB:5C:9F
root@cb:/home/chris# sbin/dhcpcd wlan0
bash: sbin/dhcpcd: No such file or directory
root@cb:/home/chris# /sbin/dhcpcd wlan0
err, wlan0: timed out
warn, wlan0: using IPV4LL address 169.254.93.11
Also, bear in mind that I use these rc.inet1.conf now: (changed it after some sniffing around google and the .conf files themselves)
Code:
# Config information for wlan0 (using dhcp):
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
WLAN_MODE[4]=Managed
DHCP_HOSTNAME[4]="ThomsonB27795"
WLAN_ESSID[4]=ThomsonB27795
HWADDR[4]="00:1f:e2:c1:93:32" 
WLAN_RATE[4]="54M auto" 
WLAN_CHANNEL[4]="auto"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="ndiswrapper"
And my wpa_supplicant.conf:
Code:
# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="ThompsonB27795"
  proto=WPA
  key_mgmt=NONE
  pairwise=CCMP TKIP
  #group=CCMP TKIP WEP104 WEP40
  #psk=your_64_char_psk_here
  priority=10
So what is wrong now? I feel that I am doing something really stupid here. Please help me though...I am really enthusiastic about this OS and I can't really work with it w/out WiFi...
Cheers.
 
Old 11-30-2009, 05:38 PM   #9
agentdcooper
Member
 
Registered: Aug 2005
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
cool - it looks like you are very close!
your network card does indeed use ath5k kernel module
for now I'd forget about macchanger, that can come in handy later

mainly that code is to be used in a script - in my case I just put it in a script named linksys-dhcp.sh, and made it executable. that too can be dealt with later.

lets focus on getting you UP, and then deal with the other later... is my thought.

so it looks like you should be able to do this to get online ;
Code:
rmmod ath5k
sleep 3
modprobe ath5k
sleep 3
/sbin/iwconfig wlan0 mode managed rate 54M key off essid "ThomsonB27795"
/sbin/iwconfig wlan0 ap 00:1F:9F:EB:5C:9F
/sbin/dhcpcd wlan0
echo "nameserver 208.67.222.222
nameserver 208.67.220.220" > /etc/resolv.conf
let me know how that works, also type "iwconfig" and put the output here. try to ping your ETHERNET IP address of the wireless access-point to see if at least that works, and report back. hope this help!

PS: what is the exect configuration of the wireless AP - specifically are you using encryption (WEP/WPA 1/2, etc??)
 
Old 12-01-2009, 05:36 PM   #10
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Original Poster
Rep: Reputation: 15
Oh God...
Code:
chris@cb:~$ su
Password:     
root@cb:/home/chris# rmmod ath5k
root@cb:/home/chris# sleep 3    
root@cb:/home/chris# modprobe ath5k
root@cb:/home/chris# sleep 3       
root@cb:/home/chris# /sbin/iwconfig wlan0 mode managed rate 54M key off essid "ThomsonB27795"
Error for wireless request "Set Mode" (8B06) :                                               
    SET failed on device wlan0 ; Device or resource busy.                                    
root@cb:/home/chris# ifconfig wlan0 down                                                     
root@cb:/home/chris# /sbin/iwconfig wlan0 mode managed rate 54M key off essid "ThomsonB27795"
root@cb:/home/chris# /sbin/iwconfig wlan0 ap 00:1F:9F:EB:5C:9F                               
root@cb:/home/chris# ifconfig wlan0 up  
root@cb:/home/chris# /sbin/dhcpcd wlan0
err, wlan0: timed out
warn, wlan0: using IPV4LL address 169.254.241.196
root@cb:/home/chris# echo "nameserver 192.168.1.67
> /etc/resolv.conf
> nameserver 192.168.1.67"
nameserver 192.168.1.67
/etc/resolv.conf
nameserver 192.168.1.67
root@cb:/home/chris# echo "nameserver 192.168.1.67
> nameserver 192.168.1.67" > /etc/resolv.conf
root@cb:/home/chris# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"ThomsonB27795"
          Mode:Managed  Frequency:2.417 GHz  Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Code:
root@cb:/home/chris# /etc/rc.d/rc.inet1 wlan0_stop
info, wlan0: exiting
root@cb:/home/chris# /etc/rc.d/rc.inet1 wlan0_start
/etc/rc.d/rc.inet1:  wlan0 information: 'Fill with your own settings...'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
err, wlan0: timed out
err, wlan0: lease information file `/etc/dhcpc/dhcpcd-wlan0.info' does not exist
warn, wlan0: using IPV4LL address 169.254.15.102
I think that this is the main prob...Error for wireless request "Set Nickname" (8B1C) :
SET failed on device wlan0 ; Operation not supported.


But how do I fix it...?

EDIT:
Code:
Wireless Access Point - ThomsonB27795	

	Configuration
			
Interface Enabled:	Yes
Physical Address:	00:1F:9F:EB:5C:9F
Network Name (SSID):	ThomsonB27795
Interface Type:	802.11b/g
Actual Speed:	54 Mbps
Band:	2.4G Hz
Channel Selection:	Auto
Region:	Europe
Channel:	1
Allow multicast from Broadband Network:	Yes

	Security
			
Broadcast Network Name:	Yes
Allow New Devices:	New stations are allowed (automatically)
Security Mode:	none
Here is the configuration of my WAP as you requested.

Last edited by suChris; 12-02-2009 at 01:25 AM.
 
Old 12-02-2009, 03:11 AM   #11
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
As far as I'm concerned, "if wireless then wicd" no questions asked.

Personally, I use the slackware 'netconfig' tool to make sure the box has it's hostname setup right.

Install wicd

Then I remove the tweaks the 'netconfig' tool does to rc.inet1.conf

I use wicd to setup the hidden, but it wont connect yet.

Now kill all wicd processes.

For hidden ssid, you'll need to go into the config file in /etc/wicd and change the "hidden_network" or however it's worded (can't recall the exact spelling) and physically type in the name of the essid of the router. save the config. then fire up the wicd daemon and you should be able to connect.

Wicd works *awesome* here. If I boot up with the wire in, I'm on wired, if I yank the wire, it automagically goes to my wireless. You gotta love it.
 
Old 12-02-2009, 03:20 AM   #12
uppman
Member
 
Registered: Jul 2008
Location: Stockholm, Sweden
Distribution: Slackware 13.1 32-bit
Posts: 145

Rep: Reputation: 24
There is no need for rc.inet1.conf if you use Wicd!

Wicd takes care of everything but the coffee..

/Magnus
 
Old 12-02-2009, 03:22 AM   #13
kite
Member
 
Registered: Aug 2003
Location: Shenzhen, China
Distribution: Slackware
Posts: 301

Rep: Reputation: 47
Yes WICD does not require /etc/rc.d/rc.inet1.cof, but the settings inside must be cleared to avoid conflicts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.0 setup cannot find linux partitions to install too after fdisk setup . TDurden1937 Slackware - Installation 1 10-25-2008 08:18 PM
Slackware Linksys wireless setup davimint Linux - Wireless Networking 5 07-03-2007 02:37 PM
slackware wireless setup hosler Linux - Wireless Networking 8 10-16-2006 09:52 PM
Slackware - Eth1 Setup and Port Setup help girlsmakegraves Linux - Networking 3 12-16-2005 11:11 AM
d-link wireless router setup on slackware kodon Slackware 2 07-31-2004 04:53 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration