LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-26-2006, 11:37 AM   #1
swooshonln
LQ Newbie
 
Registered: Apr 2006
Location: USA
Distribution: 2006.0 Gentoo Linux (gentoo-sources-2.6.15-r1)
Posts: 23

Rep: Reputation: 15
new to slackware, help with ati drivers


Hello. I have just set up myself a new slackware box to play around with. I am comming over from my Genntoo system. I am not really a newbie anymore, but I still find out something new to learn every day. But heres my problem:

I cannot get the OpenGL performance that I am looking for. I have installed the ati drivers from teh website (with sh ./ati-drivers.run). I then copied my old X11/xorg.conf file from gentoo (configured to work with the ati-drivers) to my slackware box, and started up x. X works fine, I just am having horrible perfomance when it comes to openGL programs (not games, but more like the screensavers). How can I fix my OpenGL perfomance? Im not sure what the "necessary" measures are to set up the ati stuff on slackware, but I am assuming that its generally the same throughout each distro. Another thing I noticed, is on gentoo to get your opengl working with the ati drivers you would run "eselect opengl set ati", which would swich the opelgl drivers to the ati ones, however, there is no "eslect" commmand with the ati drivers that were installed. Any ideas?

I read somewhere about linking somthign with the Xfree86 conf to the xorg.conf, which I havent done, is that necessary?
 
Old 04-26-2006, 12:24 PM   #2
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 231
Blog Entries: 1

Rep: Reputation: 34
I did it like this...

1. Download the .run driver package from ATI's website.
2. Install it.
3. As root, run aticonfig --initial.
4. Edit your /etc/X11/xorg.conf and add the following section:

Section "DRI"
Mode 0666
EndSection

Afterwards, I still had horrible performance with xine. (Running xine-check told me to upgrade to an accelerated X server.) Adding the following lines to xorg.conf in the "Device" section fixed the problem.

Option "UseInternalAGPGART" "no"
Option "RenderAccel" "true"
Option "VideoOverlay" "on"
 
Old 04-26-2006, 12:27 PM   #3
swooshonln
LQ Newbie
 
Registered: Apr 2006
Location: USA
Distribution: 2006.0 Gentoo Linux (gentoo-sources-2.6.15-r1)
Posts: 23

Original Poster
Rep: Reputation: 15
I already have all those set.... do I not have to swich the opengl enterface over?
 
Old 04-26-2006, 01:18 PM   #4
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Slackware uses Xorg, not Xfree. So the config file in Slackware is /etc/X11/xorg.conf.

Also, read my post in my sig about DRI. Has a large section on ATI.
 
Old 04-26-2006, 02:03 PM   #5
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 231
Blog Entries: 1

Rep: Reputation: 34
If you run fglrxinfo, does it report ATI as the vendor?

If you run fgl_glxgears, what kind of frame rates do you get?
 
Old 04-27-2006, 07:56 AM   #6
komuthan
Member
 
Registered: Sep 2005
Distribution: Slackware 10.2
Posts: 58

Rep: Reputation: 15
POSIX Shared Memory (/dev/shm) support is required for 3D applications (from release notes on ati web page)
 
Old 04-27-2006, 09:59 AM   #7
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 231
Blog Entries: 1

Rep: Reputation: 34
Yep. I was trying to get at that by seeing what kind of message we got with fgl_glxgears.


To fix shared memory:
Add the following line to /etc/fstab:
tmpfs /dev/shm tmpfs defaults 0 0

Then, mount /dev/shm by typing:
mount /dev/shm


Now run fgl_glxgears again and see if things are better.
 
Old 04-27-2006, 11:27 AM   #8
syvy
Member
 
Registered: Sep 2005
Location: Germany
Distribution: slackware64
Posts: 110

Rep: Reputation: 16
Copying a working xorg.conf isnīt a bad idea.

I saved the one the fglrxconfig-script of the driver version 8.20.8 made.
It works fine with newer versions. fglrxconfig is like xorgconfig. No more manually editing nessesary.
I donīt understand why it isnīt part of the package anymore.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2 and fglrx (ATI Drivers) cythrawll Slackware 7 10-18-2005 05:44 PM
ATI Drivers and Slackware 10.2 Question zeroz52 Slackware 2 09-19-2005 07:29 AM
ATI drivers on Slackware c_olin3404 Linux - Software 17 05-23-2005 03:05 PM
How to install ATI drivers in Slackware 10.1 kizuna Slackware 4 03-25-2005 03:22 PM
ATi Radeon drivers in Slackware 10 Neorio Slackware 1 07-11-2004 10:15 AM


All times are GMT -5. The time now is 01:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration