LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   new to slackware, help with ati drivers (http://www.linuxquestions.org/questions/slackware-14/new-to-slackware-help-with-ati-drivers-439034/)

swooshonln 04-26-2006 12:37 PM

new to slackware, help with ati drivers
 
Hello. I have just set up myself a new slackware box to play around with. I am comming over from my Genntoo system. I am not really a newbie anymore, but I still find out something new to learn every day. But heres my problem:

I cannot get the OpenGL performance that I am looking for. I have installed the ati drivers from teh website (with sh ./ati-drivers.run). I then copied my old X11/xorg.conf file from gentoo (configured to work with the ati-drivers) to my slackware box, and started up x. X works fine, I just am having horrible perfomance when it comes to openGL programs (not games, but more like the screensavers). How can I fix my OpenGL perfomance? Im not sure what the "necessary" measures are to set up the ati stuff on slackware, but I am assuming that its generally the same throughout each distro. Another thing I noticed, is on gentoo to get your opengl working with the ati drivers you would run "eselect opengl set ati", which would swich the opelgl drivers to the ati ones, however, there is no "eslect" commmand with the ati drivers that were installed. Any ideas?

I read somewhere about linking somthign with the Xfree86 conf to the xorg.conf, which I havent done, is that necessary?

jimX86 04-26-2006 01:24 PM

I did it like this...

1. Download the .run driver package from ATI's website.
2. Install it.
3. As root, run aticonfig --initial.
4. Edit your /etc/X11/xorg.conf and add the following section:

Section "DRI"
Mode 0666
EndSection

Afterwards, I still had horrible performance with xine. (Running xine-check told me to upgrade to an accelerated X server.) Adding the following lines to xorg.conf in the "Device" section fixed the problem.

Option "UseInternalAGPGART" "no"
Option "RenderAccel" "true"
Option "VideoOverlay" "on"

swooshonln 04-26-2006 01:27 PM

I already have all those set.... do I not have to swich the opengl enterface over?

cwwilson721 04-26-2006 02:18 PM

Slackware uses Xorg, not Xfree. So the config file in Slackware is /etc/X11/xorg.conf.

Also, read my post in my sig about DRI. Has a large section on ATI.

jimX86 04-26-2006 03:03 PM

If you run fglrxinfo, does it report ATI as the vendor?

If you run fgl_glxgears, what kind of frame rates do you get?

komuthan 04-27-2006 08:56 AM

POSIX Shared Memory (/dev/shm) support is required for 3D applications (from release notes on ati web page)

jimX86 04-27-2006 10:59 AM

Yep. I was trying to get at that by seeing what kind of message we got with fgl_glxgears.


To fix shared memory:
Add the following line to /etc/fstab:
tmpfs /dev/shm tmpfs defaults 0 0

Then, mount /dev/shm by typing:
mount /dev/shm


Now run fgl_glxgears again and see if things are better.

syvy 04-27-2006 12:27 PM

Copying a working xorg.conf isnīt a bad idea.

I saved the one the fglrxconfig-script of the driver version 8.20.8 made.
It works fine with newer versions. fglrxconfig is like xorgconfig. No more manually editing nessesary.
I donīt understand why it isnīt part of the package anymore.


All times are GMT -5. The time now is 11:02 PM.