LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2013, 11:13 AM   #1
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,512

Rep: Reputation: 699Reputation: 699Reputation: 699Reputation: 699Reputation: 699Reputation: 699
New soundcard: jitter problems


Hi,

I tried to solve the problem of rather crappy sound on my workhorse PC, so I bought a low-profile PCI soundcard:

Code:
$ /sbin/lspci | grep -i audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
04:01.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
I blacklisted the onboard soundcard like this:

Code:
# echo "blacklist snd_hda_intel" > /lib/modprobe.d/onboard-sound.conf
The new card works in the sense that I have sound all right. But when I play back some music in Audacious, I have some unnerving jitter. Every five to ten seconds, every song on my playlist has a little "hiccup".

Now what can I do to get rid of that?
 
Old 01-22-2013, 01:17 PM   #2
Einars
LQ Newbie
 
Registered: May 2009
Distribution: Slackware 14.1
Posts: 24

Rep: Reputation: 2
Could you try go to audacious settings->plugins->effects-> select sample rate converter and click its settings button and in dialog window there enter "48000" in every box. Additionally, select "linear interpolator" at bottom for lowest cpu usage. This helped me with my onboard soundcard (since it only supports 48000 Hz sampling frequency).
 
1 members found this post helpful.
Old 01-22-2013, 01:54 PM   #3
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 181
Blog Entries: 1

Rep: Reputation: 38
http://www.alsa-project.org/main/ind...for_snd-cmipci

software mixer isn't necessary but I like to customized my software mixer, you can adjust your rates in there. When I mixed up 32 bits drivers with 64 bits libraries, then my wine only had crappy sound.
 
Old 01-26-2013, 08:04 AM   #4
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 343

Rep: Reputation: 56
me thinks the term for what you experiencing is sound skipping, not jitter. Sound skipping is caused by latencies, jitter refers to the variance of the latter.

if you feel game you can try a cpu scheduler designed for desktop work and low latency (bfs). Maybe you need to tweak some process priorities on top of that.
 
Old 01-26-2013, 09:27 AM   #5
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,512

Original Poster
Rep: Reputation: 699Reputation: 699Reputation: 699Reputation: 699Reputation: 699Reputation: 699
Quote:
Originally Posted by Einars View Post
Could you try go to audacious settings->plugins->effects-> select sample rate converter and click its settings button and in dialog window there enter "48000" in every box. Additionally, select "linear interpolator" at bottom for lowest cpu usage. This helped me with my onboard soundcard (since it only supports 48000 Hz sampling frequency).
Yep, that worked. Thanks !
 
Old 01-26-2013, 05:16 PM   #6
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 194

Rep: Reputation: 26
For the record, I had the exact same problem as you. My solution was to buy a new soundcard. I bought a Soundblaster Audigy SE (was only about $25).

But I had problems with other applications as well (Audacity and Flash video, in particular) so for me an Audacious-only solution wouldn't be enough. Are you not having the hiccup issue with other apps too?
 
Old 01-27-2013, 01:35 AM   #7
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,512

Original Poster
Rep: Reputation: 699Reputation: 699Reputation: 699Reputation: 699Reputation: 699Reputation: 699
Quote:
Originally Posted by Poprocks View Post
For the record, I had the exact same problem as you. My solution was to buy a new soundcard. I bought a Soundblaster Audigy SE (was only about $25).

But I had problems with other applications as well (Audacity and Flash video, in particular) so for me an Audacious-only solution wouldn't be enough. Are you not having the hiccup issue with other apps too?
In fact shortly after that I found out that my workhorse PC only "works" in the sense that horses swim and chickens fly. So I replaced it by a slighly more powerful Lenovo Core 2, and now everything is running fine without any hiccups. Except my server, all machines in my office are "refurbished" PCs from the french administration.
 
  


Reply

Tags
audio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: JITter Bug LXer Syndicated Linux News 0 07-17-2009 12:14 AM
dvd jitter correction linuxmandrake Linux - Software 0 09-29-2006 12:22 PM
Tools for determinig Jitter bzlaskar Linux - Networking 0 06-30-2006 11:50 PM
LCD screen jitter jonfa Linux - Hardware 6 05-27-2005 02:32 PM
Problems, problems, problems. Lets start with the soundcard Kre8ive Linux - Newbie 5 08-07-2003 01:20 AM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration