LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   New soundcard: jitter problems (http://www.linuxquestions.org/questions/slackware-14/new-soundcard-jitter-problems-4175446764/)

kikinovak 01-22-2013 11:13 AM

New soundcard: jitter problems
 
Hi,

I tried to solve the problem of rather crappy sound on my workhorse PC, so I bought a low-profile PCI soundcard:

Code:

$ /sbin/lspci | grep -i audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
04:01.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)

I blacklisted the onboard soundcard like this:

Code:

# echo "blacklist snd_hda_intel" > /lib/modprobe.d/onboard-sound.conf
The new card works in the sense that I have sound all right. But when I play back some music in Audacious, I have some unnerving jitter. Every five to ten seconds, every song on my playlist has a little "hiccup".

Now what can I do to get rid of that?

Einars 01-22-2013 01:17 PM

Could you try go to audacious settings->plugins->effects-> select sample rate converter and click its settings button and in dialog window there enter "48000" in every box. Additionally, select "linear interpolator" at bottom for lowest cpu usage. This helped me with my onboard soundcard (since it only supports 48000 Hz sampling frequency).

number22 01-22-2013 01:54 PM

http://www.alsa-project.org/main/ind...for_snd-cmipci

software mixer isn't necessary but I like to customized my software mixer, you can adjust your rates in there. When I mixed up 32 bits drivers with 64 bits libraries, then my wine only had crappy sound.

Martinus2u 01-26-2013 08:04 AM

me thinks the term for what you experiencing is sound skipping, not jitter. Sound skipping is caused by latencies, jitter refers to the variance of the latter.

if you feel game you can try a cpu scheduler designed for desktop work and low latency (bfs). Maybe you need to tweak some process priorities on top of that.

kikinovak 01-26-2013 09:27 AM

Quote:

Originally Posted by Einars (Post 4875609)
Could you try go to audacious settings->plugins->effects-> select sample rate converter and click its settings button and in dialog window there enter "48000" in every box. Additionally, select "linear interpolator" at bottom for lowest cpu usage. This helped me with my onboard soundcard (since it only supports 48000 Hz sampling frequency).

Yep, that worked. Thanks !

Poprocks 01-26-2013 05:16 PM

For the record, I had the exact same problem as you. My solution was to buy a new soundcard. I bought a Soundblaster Audigy SE (was only about $25).

But I had problems with other applications as well (Audacity and Flash video, in particular) so for me an Audacious-only solution wouldn't be enough. Are you not having the hiccup issue with other apps too?

kikinovak 01-27-2013 01:35 AM

Quote:

Originally Posted by Poprocks (Post 4878208)
For the record, I had the exact same problem as you. My solution was to buy a new soundcard. I bought a Soundblaster Audigy SE (was only about $25).

But I had problems with other applications as well (Audacity and Flash video, in particular) so for me an Audacious-only solution wouldn't be enough. Are you not having the hiccup issue with other apps too?

In fact shortly after that I found out that my workhorse PC only "works" in the sense that horses swim and chickens fly. So I replaced it by a slighly more powerful Lenovo Core 2, and now everything is running fine without any hiccups. Except my server, all machines in my office are "refurbished" PCs from the french administration.


All times are GMT -5. The time now is 07:14 AM.