LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-31-2009, 04:04 PM   #1
bloodsugar
Member
 
Registered: May 2009
Posts: 36

Rep: Reputation: 18
New monitor and eye strain


Hi,

I just upgraded (although it doesnt feel that way) from a CRT to an LCD, but its absolutely killing my eyes. I think its the anti-aliasing because of the variation in depth of black text, my eyes cant seem to get a hold of the words. Although Im not sure. I know that when I was using the old CRT, I prefered fonts that were jagged.

This font anti-aliasing seems to be system wide (firefox, file manager, other programs etc). Can I switch this off somehow or is it a LCD thing?

Last edited by bloodsugar; 07-31-2009 at 04:18 PM.
 
Old 07-31-2009, 04:19 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
http://webplaza.pt.lu/uselpa/beautiful.html is a little old, but I think these should still apply.

This comes from the release notes for Slack 11 - again, it should apply
Quote:
There have been quite a few reports that fonts are 'ugly' after
upgrading; one way to fix it is to remove /etc/fonts/local.conf if it
exists. If it doesn't exist, or that doesn't work, go into KControl's
font settings, uncheck the box for antialiasing, and apply the changes.
Then, recheck the box and apply the changes. This should create a
$HOME/.fonts.conf file. You might consider copying the contents of this
newly created file to /etc/fonts/local.conf if you want to fix it for
all users on the system. Thanks to Pat for the initial suggestion with
KControl, and thanks to ananke for working out exactly what changes are
necessary to fix it.
Old again, but should apply: http://humanreadable.nfshost.com/how...ng_ttfonts.htm

Have you checked that your TTFs are in the directory referenced for anti-aliasing? Maybe the problem is that the "good" fonts aren't being loaded.
 
Old 07-31-2009, 04:25 PM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
There is a lot of font information in this thread.
 
Old 07-31-2009, 04:43 PM   #4
bloodsugar
Member
 
Registered: May 2009
Posts: 36

Original Poster
Rep: Reputation: 18
Thanks for the info guys,

so its possible to get sharp and jagged fonts again on this LCD the same way as the CRT? The reason I ask is because I havent changed any font settings since switching from the CRT to the LCD.

I'll try the suggestions in the links.
 
Old 07-31-2009, 04:55 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Are you running the LCD at its native resolution? (Hint: ALWAYS do that)
 
Old 07-31-2009, 05:16 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Run xrandr to make sure you are running at a good resolution. Mine, for example says
Code:
$ xrandr
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1400 x 1200
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1400x1050      60.0*+
   1280x800       60.0
   1280x768       60.0
   1024x768       60.0
   800x600        60.3
   640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)
The first line shows that I could run at a higher resolution (even though I choose not to).
 
Old 07-31-2009, 05:30 PM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
XavierP, you probably have that higher resolution available because of LVDS.

What monitor/card are you running?
 
Old 07-31-2009, 05:31 PM   #8
bloodsugar
Member
 
Registered: May 2009
Posts: 36

Original Poster
Rep: Reputation: 18
yep its running at the native resolution of 1680x1050.
 
Old 07-31-2009, 05:39 PM   #9
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Hi Bruce - it's a Radeon RV250 (as fitted in the Latitude D600). The resolution is set to the setting I had when it ran XP, I find it comfortable and gives me plenty of room on the screen.
 
Old 08-06-2009, 10:48 AM   #10
bloodsugar
Member
 
Registered: May 2009
Posts: 36

Original Poster
Rep: Reputation: 18
Just to update, I followed the guide from http://webplaza.pt.lu/uselpa/beautiful.html and it worked, all the heavy antialiasing around charactors has gone, and now my fonts are well defined and readable.

the important thing is to find or compile a freetype package with bytecode interpreter enabled.

my options in /etc/fonts/local.conf differ slightly with the guide,
Quote:
antialias=true
hinting=true
autohinting=false
Also, you dont need to install the windows fonts, I transferred them over from xp, but then went back to sans-serif because I think that looks better.

Thanks

Last edited by bloodsugar; 08-06-2009 at 11:45 AM.
 
Old 08-06-2009, 11:13 AM   #11
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Thanks for the update Bloodsugar.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reducing eye-strain on LCD monitor.(reading text) ErV General 15 12-16-2008 03:00 PM
How can i put some strain on my linux box? Steve_T Linux - Server 9 07-21-2008 12:48 PM
Eye strain and head aches. 180 Linux - Hardware 9 03-27-2006 10:08 AM
LXer: Browser developers meet, see eye to eye on security LXer Syndicated Linux News 0 12-26-2005 02:31 PM


All times are GMT -5. The time now is 07:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration