LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   New monitor and eye strain (http://www.linuxquestions.org/questions/slackware-14/new-monitor-and-eye-strain-744238/)

bloodsugar 07-31-2009 04:04 PM

New monitor and eye strain
 
Hi,

I just upgraded (although it doesnt feel that way) from a CRT to an LCD, but its absolutely killing my eyes. I think its the anti-aliasing because of the variation in depth of black text, my eyes cant seem to get a hold of the words. Although Im not sure. I know that when I was using the old CRT, I prefered fonts that were jagged.

This font anti-aliasing seems to be system wide (firefox, file manager, other programs etc). Can I switch this off somehow or is it a LCD thing?

XavierP 07-31-2009 04:19 PM

http://webplaza.pt.lu/uselpa/beautiful.html is a little old, but I think these should still apply.

This comes from the release notes for Slack 11 - again, it should apply
Quote:

There have been quite a few reports that fonts are 'ugly' after
upgrading; one way to fix it is to remove /etc/fonts/local.conf if it
exists. If it doesn't exist, or that doesn't work, go into KControl's
font settings, uncheck the box for antialiasing, and apply the changes.
Then, recheck the box and apply the changes. This should create a
$HOME/.fonts.conf file. You might consider copying the contents of this
newly created file to /etc/fonts/local.conf if you want to fix it for
all users on the system. Thanks to Pat for the initial suggestion with
KControl, and thanks to ananke for working out exactly what changes are
necessary to fix it.
Old again, but should apply: http://humanreadable.nfshost.com/how...ng_ttfonts.htm

Have you checked that your TTFs are in the directory referenced for anti-aliasing? Maybe the problem is that the "good" fonts aren't being loaded.

Bruce Hill 07-31-2009 04:25 PM

There is a lot of font information in this thread.

bloodsugar 07-31-2009 04:43 PM

Thanks for the info guys,

so its possible to get sharp and jagged fonts again on this LCD the same way as the CRT? The reason I ask is because I havent changed any font settings since switching from the CRT to the LCD.

I'll try the suggestions in the links.

pixellany 07-31-2009 04:55 PM

Are you running the LCD at its native resolution? (Hint: ALWAYS do that)

XavierP 07-31-2009 05:16 PM

Run xrandr to make sure you are running at a good resolution. Mine, for example says
Code:

$ xrandr
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1400 x 1200
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
  1400x1050      60.0*+
  1280x800      60.0
  1280x768      60.0
  1024x768      60.0
  800x600        60.3
  640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)

The first line shows that I could run at a higher resolution (even though I choose not to).

Bruce Hill 07-31-2009 05:30 PM

XavierP, you probably have that higher resolution available because of LVDS.

What monitor/card are you running?

bloodsugar 07-31-2009 05:31 PM

yep its running at the native resolution of 1680x1050.

XavierP 07-31-2009 05:39 PM

Hi Bruce - it's a Radeon RV250 (as fitted in the Latitude D600). The resolution is set to the setting I had when it ran XP, I find it comfortable and gives me plenty of room on the screen.

bloodsugar 08-06-2009 10:48 AM

Just to update, I followed the guide from http://webplaza.pt.lu/uselpa/beautiful.html and it worked, all the heavy antialiasing around charactors has gone, and now my fonts are well defined and readable.

the important thing is to find or compile a freetype package with bytecode interpreter enabled.

my options in /etc/fonts/local.conf differ slightly with the guide,
Quote:

antialias=true
hinting=true
autohinting=false
Also, you dont need to install the windows fonts, I transferred them over from xp, but then went back to sans-serif because I think that looks better.

Thanks :)

XavierP 08-06-2009 11:13 AM

Thanks for the update Bloodsugar.


All times are GMT -5. The time now is 08:02 PM.