LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-25-2006, 02:27 PM   #1
gian2oo1
Member
 
Registered: Oct 2004
Location: Rhode Island, USA
Distribution: Slackware... Simplicity is bliss.
Posts: 62

Rep: Reputation: 15
Exclamation New kernel: local net ok, can't connect to internet.


Hello. I configured a new kernel on my server. My local PCs (192.168.1.X) can access the server and the server can access the PCs but the server cannot access the internet. I can ping remote hosts but http/ftp doesn't connect. HTTP states: Request sent, waiting for reply. And FTP won't connect. There is no firewall enabled.

My kernel (v2.4.32) config is located at:

http://www.gsent.org/config

Are there any options in the kernel I missed that explicitly allow remote connections?

Thank you for any help,

Gian G. Spicuzza

Code:
dummy0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth0      Link encap:Ethernet  HWaddr 00:0B:6A:66:95:A2
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:185 errors:0 dropped:0 overruns:0 frame:0
          TX packets:114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:18333 (17.9 Kb)  TX bytes:15791 (15.4 Kb)
          Interrupt:12 Base address:0xdc00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Last edited by gian2oo1; 01-25-2006 at 02:29 PM.
 
Old 01-25-2006, 02:55 PM   #2
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Try issuing the 'route' command as the root user in your favorite xterm or console. Is there a 'default' route for all of the packets to go to the outside world? Usually the "Flags" column will have a "UG" (G stands for gateway). If you don't have a corresponding line in your routing table, you will have to manually add one.
 
Old 01-25-2006, 03:09 PM   #3
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Yes,it does sound like a default route is not set, but that doesn't make sense considering all you did was change the kernel.
 
Old 01-25-2006, 06:34 PM   #4
gian2oo1
Member
 
Registered: Oct 2004
Location: Rhode Island, USA
Distribution: Slackware... Simplicity is bliss.
Posts: 62

Original Poster
Rep: Reputation: 15
Yes, there is a default route. Pinging yahoo.com works, but "links yahoo.com" times out

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default 192.168.1.1 0.0.0.0 UG 1 0 0 eth0
 
Old 01-25-2006, 06:37 PM   #5
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Have you tried using the actual IP address of a website instead of the DNS name?
 
Old 01-25-2006, 06:39 PM   #6
gian2oo1
Member
 
Registered: Oct 2004
Location: Rhode Island, USA
Distribution: Slackware... Simplicity is bliss.
Posts: 62

Original Poster
Rep: Reputation: 15
Yes I have tried that. It still does not connect.
 
Old 01-26-2006, 11:08 AM   #7
gian2oo1
Member
 
Registered: Oct 2004
Location: Rhode Island, USA
Distribution: Slackware... Simplicity is bliss.
Posts: 62

Original Poster
Rep: Reputation: 15
Hello. I solved the problem by disabling CONFIG_INET_ECN in my kernel config.

I enabled ECN for the obvious benefits, but I was unaware that if a router receives an ECN-enabled packet it drops it instead of ignoring the ECN tag and treating it as a normal packet. (That is if the router is not patched for ECN)

For more information, visit http://www.opalsoft.net/qos/TCP-60.htm

--Gian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to Internet after kernel update! lonelyghost317 Linux - Newbie 4 07-04-2005 09:52 PM
Can't connect to the net after Red hat 9.0 installtion with internet config wizard Linux2excel Linux - Hardware 5 04-11-2005 04:44 PM
Samba: can't connect to my local linux machine but can connect to windows. Royle Linux - Networking 3 01-18-2005 05:32 PM
Unable to connect to internet after installing kernel 2.6.3 abefroman Mandriva 5 03-03-2004 04:31 PM
internet connect app and net monitor for m9.2? elhuecu Mandriva 2 02-21-2004 01:45 AM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration