LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-19-2006, 06:01 AM   #1
Pier
Member
 
Registered: Oct 2005
Location: Italy
Distribution: Gentoo
Posts: 83

Rep: Reputation: 17
New kernel blank screen


Hi everybody.
I've just compiled the new 2.6.15.1 smoothly. Yet when I reboot the new kernel the screen goes blank. After some humming from the hd I type in the login name and password (with a blank screen). Startx blam the xwindow manager with no problem and everything seems to work fine and faster then with 2.4.31. Dmesg | less from a terminal returns a blank terminal as well i.e. no echo.... Exiting from the kde desktop gives back the blank screen but halt stops the pc with no problems. I included support for usb webcam which turns on at boot and ATI radeon 128Mb. Perhaps I messed a bit with the fb configuration in menu gconfig? How could I get this sorted out? If not which option should I be aware of in the config process in kernel compiling to avoid this weird behaviour?

Thanks for any help,
Pier

Last edited by Pier; 01-19-2006 at 06:07 AM.
 
Old 01-19-2006, 06:05 AM   #2
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
sound like lilo is set for the frame buffer
that you forgot to compile into the kernel
 
Old 01-19-2006, 06:12 AM   #3
Pier
Member
 
Registered: Oct 2005
Location: Italy
Distribution: Gentoo
Posts: 83

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by kodon
sound like lilo is set for the frame buffer
that you forgot to compile into the kernel
... does that mean that I am supposed to compile the kernel again ticking some framebuffer option? If so, would I be able to get the correct setting from the working .config file referred to as from the working 2.4.31 kernel?
Thanks.
 
Old 01-19-2006, 06:20 AM   #4
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
you can either:

a) recompile the kernel with fb support

or

b) use standard vga (if the kernel has that support already)
 
Old 01-20-2006, 03:54 AM   #5
Pier
Member
 
Registered: Oct 2005
Location: Italy
Distribution: Gentoo
Posts: 83

Original Poster
Rep: Reputation: 17
Hi
recompiling kernel with fb support solved the problem as well as using standard vga in lilo.conf. Thanks a lot for the help.

Now I am puzzled with sound behaviour. I haven't understood how to cope with sound. OSS or ALSA? I compiled as modules both of them along with es1371 and es1370. Everything seems to work fine but Noatun doesn't want to play any sound wheras xine, gxine, xmms and realplayer have no problems. I can even play two different sound and hear them at the same time, which I wasn't able to do beforehand (perhaps some sw uses OSS and others ALSA). Play sound from the control panel doesn't play any sound. Furthermore kmix doesn't give the option to switch the 20db gain on for mic (in the old kernel ver it reported "ensoniq ES1371" at the foot of the kmix window).

I would be grateful to anyone who could lighten this darknes.

Pier
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank Screen after Kernel Compile Clojster Slackware 6 10-10-2004 04:04 AM
Blank screen after the kernel compiling imrel Slackware 1 10-04-2004 09:28 PM
Kernel 2.6.6 boots to blank screen sharpie Linux - General 4 06-19-2004 08:54 AM
Blank Screen after installing Kernel 2.6 sminons Linux - Software 2 11-26-2003 11:05 AM
StartX causes blank screen, new kernel Eyecannon Linux - Newbie 6 09-14-2002 03:19 PM


All times are GMT -5. The time now is 12:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration