LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   new and strange printer problems (http://www.linuxquestions.org/questions/slackware-14/new-and-strange-printer-problems-868533/)

patostevens 03-14-2011 01:36 PM

new and strange printer problems
 
I'm running a standard 13.1 32 bit install with an HP deskjet 990C, run off of USB. Until today everything has printed properly. Now nothing prints. Nothing has been installed unless it came through slackpkg, and yes it is still on the correct setting for arch and revision. CUPS shows printer as installed, accepting jobs an idle. No error messages are appearing but nothing is reaching the printer. The info I can glean is from the error logs in CUPS:

E [14/Mar/2011:10:56:30 -0700] Filter "/usr/lib/cups/filter/rastertogutenprint.5.2" for printer "HP_DeskJet_990C" has insecure permissions (0100757)
E [14/Mar/2011:10:56:47 -0700] Filter "/usr/lib/cups/filter/rastertogutenprint.5.2" for printer "HP_DeskJet_990C" has insecure permissions (0100757)
E [14/Mar/2011:10:56:59 -0700] Unable to execute /usr/lib/cups/filter/pstoraster: insecure file permissions (0100757)
E [14/Mar/2011:10:56:59 -0700] [Job 29] Unable to start filter "pstoraster" - Operation not permitted.
E [14/Mar/2011:10:56:59 -0700] [Job 29] Stopping job because the scheduler could not execute a filter.
E [14/Mar/2011:10:57:20 -0700] Unable to execute /usr/lib/cups/filter/pstoraster: insecure file permissions (0100757)
E [14/Mar/2011:10:57:20 -0700] [Job 29] Unable to start filter "pstoraster" - Operation not permitted.
E [14/Mar/2011:10:57:20 -0700] [Job 29] Stopping job because the scheduler could not execute a filter.
E [14/Mar/2011:10:58:29 -0700] Unable to execute /usr/lib/cups/filter/pstoraster: insecure file permissions (0100757)
E [14/Mar/2011:10:58:29 -0700] [Job 30] Unable to start filter "pstoraster" - Operation not permitted.
E [14/Mar/2011:10:58:29 -0700] [Job 30] Stopping job because the scheduler could not execute a filter.
E [14/Mar/2011:10:59:56 -0700] [cups-deviced] PID 12155 (hpfax) stopped with status 13!
E [14/Mar/2011:11:00:13 -0700] Unable to execute /usr/lib/cups/filter/pstoraster: insecure file permissions (0100757)
E [14/Mar/2011:11:00:13 -0700] [Job 29] Unable to start filter "pstoraster" - Operation not permitted.
E [14/Mar/2011:11:00:13 -0700] [Job 29] Stopping job because the scheduler could not execute a filter.
E [14/Mar/2011:11:10:26 -0700] Unable to execute /usr/lib/cups/filter/pstoraster: insecure file permissions (0100757)
E [14/Mar/2011:11:10:26 -0700] [Job 31] Unable to start filter "pstoraster" - Operation not permitted.
E [14/Mar/2011:11:10:26 -0700] [Job 31] Stopping job because the scheduler could not execute a filter.
E [14/Mar/2011:11:15:06 -0700] Unable to execute /usr/lib/cups/filter/pstoraster: insecure file permissions (0100757)
E [14/Mar/2011:11:15:06 -0700] [Job 32] Unable to start filter "pstoraster" - Operation not permitted.
E [14/Mar/2011:11:15:06 -0700] [Job 32] Stopping job because the scheduler could not execute a filter.


The general permissions for these files (which I have not touched) do NOT include execute even for root. Since I don't know anything about these, thought I would leave it to wiser minds than mine. Do I just change permission in the relevant directories or should something else be done.

business_kid 03-14-2011 02:03 PM

Have you tried removing the printer, restarting cups, and reinstalling it?

patostevens 03-14-2011 07:41 PM

I did remove the printer, etc. I also removed and reinstalled CUPS. Neither made any difference to the problem.

allend 03-14-2011 09:31 PM

Quote:

E [14/Mar/2011:10:56:30 -0700] Filter "/usr/lib/cups/filter/rastertogutenprint.5.2" for printer "HP_DeskJet_990C" has insecure permissions (0100757)
On my 13.1 stock install 'ls -l /usr/lib/cups/filter/rastertogutenprint.5.2' shows:
Quote:

-rwxr-xr-x 1 root root 38208 2010-02-23 10:49 /usr/lib/cups/filter/rastertogutenprint.5.2
The log entry suggests you have -rwxr-xrwx as permissions.

PS- What is the ouput of 'ls -l /usr/lib/cups' ?
I see:
Quote:

total 1
drwxr-xr-x 2 root root 416 2011-01-22 23:11 backend
drwxr-xr-x 2 root root 192 2010-12-15 10:14 cgi-bin
drwxr-xr-x 2 root root 168 2010-12-15 10:14 daemon
drwxr-xr-x 2 root root 80 2010-12-15 10:13 driver
drwxr-xr-x 2 root root 952 2011-01-22 23:11 filter
drwxr-xr-x 2 root root 96 2010-12-15 10:14 monitor
drwxr-xr-x 2 root root 120 2010-12-15 10:14 notifier

patostevens 03-14-2011 11:34 PM

It seems to be my mission in life to ask for help and then have magical cures appear. I removed and re-installed the printer one more time and that seems to have cured things. Personally, I think that there are M$ bugs floating in the nearby air. (My wife is a follower of the evil empire.) Thanks for the suggestions. I guess something got corrupted somewhere.

nomasteryoda 11-15-2012 09:01 PM

Solution - cups permissions
 
Long time user of LQ - know Jeremy...

... sorry to say I seldom post.

I followed the post mostly to the letter, and had been researching this on the ArchLinux forums.

I followed the python symbolic link change in this post:
https://bbs.archlinux.org/viewtopic.php?pid=851700

This did nothing that I could tell... HPLIP was already installed from months ago. I just settled for printing from a Fedora desktop.

Finally your post got me to thinking about the directory permissions. How?

I opened one terminal and tailed the error log:

Code:

# tail -f /var/log/cups/error.log
while using the kde printer configuration gui. The errors keep coming...

Here are some of the messages:

Code:

HP_LaserJet_Professional_P1102w: Directory "/usr/lib/cups/filter" has insecure permissions (040775/uid=0/gid=0).                                       
E [15/Nov/2012:21:42:38 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm"!

I see permissions change all the time during pacman -Syu updates and don't think much of them. I change permissions for files when needed every day.

I thought hey, that's insecure like the message says, and tried changing permissions to 744. That was a mistake because the enable button suddenly became uncheckable in the kde printer configuration dialog.

I solved this by using the following:
Code:

chmod 755 /usr/lib/cups/*
This mystery is now solved in my opinion... I clicked print test page and it just worked!!!

Very sweet indeed!!

Now I can kick Fedora and Ubuntu and go full Arch!! - Happily using ArchLinux since January 2012 - Rolling release is the only way - once you try, you never go back.


All times are GMT -5. The time now is 06:39 AM.