LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-29-2013, 02:34 AM   #1
amandus
LQ Newbie
 
Registered: Nov 2011
Posts: 11

Rep: Reputation: Disabled
Networkprinting?


I have always trouble installing a network printer in Linux, now I have slackware installed and everything just fine except for the printer. I have a printer attached to my Imac and it is shared, other computers can print from it but not my slackware, I have installed avahi and started the daemon and I have installed nss-mdns but no sign of the printer in cups add printer. Any clue????
 
Old 09-29-2013, 03:06 AM   #2
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 263

Rep: Reputation: 62
Are you sure cups is running?
Code:
nmap 127.0.0.1
you should see "631/tcp open ipp" in the output.
If not, do
Code:
chmod +x /etc/rc.d/rc.cups
then
Code:
/etc/rc.d/rc.cups start
Acquaint yourself with CUPS. Put this in your web browser:
http://localhost:631/

Neither avahi nor nss-mdns are required for printing in a normal
Slackware install. Everything you need is present, unless your printer's
required firmware just isn't in the kernel.
 
Old 09-29-2013, 04:02 AM   #3
amandus
LQ Newbie
 
Registered: Nov 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by STDOUBT View Post
Are you sure cups is running?
Code:
nmap 127.0.0.1
you should see "631/tcp open ipp" in the output.
If not, do
Code:
chmod +x /etc/rc.d/rc.cups
then
Code:
/etc/rc.d/rc.cups start
Acquaint yourself with CUPS. Put this in your web browser:
http://localhost:631/

Neither avahi nor nss-mdns are required for printing in a normal
Slackware install. Everything you need is present, unless your printer's
required firmware just isn't in the kernel.
Yes it is running.
 
Old 09-29-2013, 12:11 PM   #4
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 263

Rep: Reputation: 62
This should help:

http://localhost:631/help/network.html
 
Old 09-29-2013, 01:31 PM   #5
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Try to set these parameters in /etc/cups/cupsd.conf and restart cups:

BrowseRemoteProtocols CUPS
BrowseLocalProtocols
DefaultEncryption Never
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 09:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration