LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   NetworkManager doesn't work: just on slackware (http://www.linuxquestions.org/questions/slackware-14/networkmanager-doesnt-work-just-on-slackware-4175500460/)

epimenidecretese 04-03-2014 10:01 AM

NetworkManager doesn't work: just on slackware
 
Hi dear all,

I am experiencing some strange thing with NetworkManager.

I need to connect to the university wired network but I can't. I get ip address, dns properly set up but the proxy page doesn't open. I was running slackware 14.0 and had the same problem. Now I updated to slackware 14.1 and it still persists. I run a debian-live and it worked perfectly (with NetworkManager).

Do you have any idea about things I could try?

onebuck 04-03-2014 02:20 PM

Member Response
 
Hi,

What does the kernel route table show? Do from the 'cli' as root: route -n to show the table.

Drakeo 04-03-2014 03:03 PM

well if you have both /etc/rc.inet1 enabled and networkmanager enabled your going to get some problems.
http://www.linuxquestions.org/questi...ll-4175499589/

epimenidecretese 04-04-2014 02:09 AM

This is the output of route -n
Code:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
0.0.0.0        172.26.0.1      0.0.0.0        UG    0      0        0 eth0
172.26.0.0      0.0.0.0        255.255.0.0    U    1      0        0 eth0
172.26.0.97    127.0.0.1      255.255.255.255 UGH  202    0        0 lo

I tried to chmod 664 rc.inet1 but it didn't work.

I don't know if it's releated to this, but I am experiencing another problem with NetworkManager: before this, I could connect to the eduroam wifi (wpa2e) network at university without the need to open NetworkManager(it was just executed at boot time).

Now I can still connect but I need to open it.

Anyway, that's another problem, but I don't know if it can be related to this one or not.

allend 04-04-2014 03:31 AM

There are a few possible problem areas to consider here.
Quote:

I was running slackware 14.0 and had the same problem. Now I updated to slackware 14.1 and it still persists
Was this an upgrade or a fresh install? If an upgrade, then it is possible that there are stale config files.

Quote:

I tried to chmod 664 rc.inet1 but it didn't work.
If you want to use NetworkManager in Slackware, then you need a clean /etc/rc.d/rc.inet1.conf as well as making /etc/rc.d/rc.networkmanager executable.
From the email to root titled "Welcome to Linux (Slackware 14.1)!"
Quote:

If you will be using wireless (or even a wired interface), you might
want to let NetworkManager handle your network connections. This is
a choice during the initial installation, but may also be selected
later by rerunning netconfig, or by setting the startup script
to executable (chmod 755 /etc/rc.d/rc.networkmanager). When Network
Manager is used to handle connections, a nice interface is provided
to scan for wireless access points and make changes to the network
configuration. This interface runs automatically with KDE or Xfce.
In fluxbox, the nm-applet program will need to be launched. Other
window managers lack a system tray to display nm-applet, so for those
you might want to look at wicd in /extra, which also provides a nice
GUI tool for connecting to wireless (or wired) networks. For window
managers that do not provide a tray for running programs, start
"wicd-client" to make changes. With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.

Quote:

before this, I could connect to the eduroam wifi (wpa2e) network at university without the need to open NetworkManager(it was just executed at boot time).
Perhaps you had setup wpa_supplicant to do this?

This thread has some information on using 'wicd' to connect to an eduroam wifi network. http://www.linuxquestions.org/questi...cd-4175479700/

fsauer 04-04-2014 05:29 AM

in rc.M either rc.wicd or rc.networkmanager are called alternatively. If you have both of them installed and executable, trouble is there.

I ran into that problem once. If you enable rc.networkmanager uninstall or chmod -x rc.wicd. Maybe this is old stuff and not relevant any more....

Good luck
Franz

epimenidecretese 04-05-2014 04:23 AM

So, mine is a fresh install and I don't have wicd.

I tried to set first loopback and NetworkManager with netconfig (so to clean rc.inet1) but it didn't work.

As far as I remember I didn't set wpa_supplicant and I could connect to my eduroam without having NetworkManager to start(I use openbox so I just launch applets when I need them, since have no tray panel).

Continues to get stranger and stranger. Do you guys have some other ideas? I really don't know what else to do.

allend 04-05-2014 06:27 AM

I would suggest setting up wpa_supplicant so you can connect from the command line. This looks like a good guide that you should be able to adapt to suit. https://www.eduroam.no/klient/linuxwpa.html
You could also look at this http://www.wireless.bris.ac.uk/eduro...ons/go-wpasup/

As to OpenBox and a system tray, http://urukrama.wordpress.com/openbo...e/#systemtrays
All the options there are available to be built using SlackBuilds from http://slackbuilds.org

beder 04-05-2014 07:10 AM

I had a similar problem, and checking dmesg the issue was that even though I was offered an IP by DHCP, it was timing out for some reason. In that same dmesg log I was able to actually see the IP that the server was trying to send me, and I set this IP as static in that wireless connection. Worked like a charm

I just don't know why this happens, and it's not the first time.. Unfortunately I'm not at my personal machine at this moment and can't paste the content of the dmesg, but I was offered the same IP 3 times in a row by the server before it gave up

epimenidecretese 04-09-2014 03:44 PM

So, I solved the problem. I stopped iptables and now I can reach the proxy login page. I had generated the rules with alienbob automatic generator: but now I don't know what to do in order to make the firewall AND the connection work. Do you have any advice? I am going to mark this question as solved anyway.

allend 04-10-2014 11:53 AM

If the problem is in your firewall rules, then you will need to make appropriate modifications. Check your logs from when the problem was occurring. Some traffic was being blocked that needs to be passed.


All times are GMT -5. The time now is 02:04 PM.