LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-03-2014, 10:01 AM   #1
epimenidecretese
LQ Newbie
 
Registered: Dec 2013
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
NetworkManager doesn't work: just on slackware


Hi dear all,

I am experiencing some strange thing with NetworkManager.

I need to connect to the university wired network but I can't. I get ip address, dns properly set up but the proxy page doesn't open. I was running slackware 14.0 and had the same problem. Now I updated to slackware 14.1 and it still persists. I run a debian-live and it worked perfectly (with NetworkManager).

Do you have any idea about things I could try?
 
Old 04-03-2014, 02:20 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,221
Blog Entries: 3

Rep: Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437
Member Response

Hi,

What does the kernel route table show? Do from the 'cli' as root: route -n to show the table.
 
Old 04-03-2014, 03:03 PM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,580
Blog Entries: 3

Rep: Reputation: 218Reputation: 218Reputation: 218
well if you have both /etc/rc.inet1 enabled and networkmanager enabled your going to get some problems.
http://www.linuxquestions.org/questi...ll-4175499589/
 
Old 04-04-2014, 02:09 AM   #4
epimenidecretese
LQ Newbie
 
Registered: Dec 2013
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
This is the output of route -n
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.26.0.1      0.0.0.0         UG    0      0        0 eth0
172.26.0.0      0.0.0.0         255.255.0.0     U     1      0        0 eth0
172.26.0.97     127.0.0.1       255.255.255.255 UGH   202    0        0 lo
I tried to chmod 664 rc.inet1 but it didn't work.

I don't know if it's releated to this, but I am experiencing another problem with NetworkManager: before this, I could connect to the eduroam wifi (wpa2e) network at university without the need to open NetworkManager(it was just executed at boot time).

Now I can still connect but I need to open it.

Anyway, that's another problem, but I don't know if it can be related to this one or not.
 
Old 04-04-2014, 03:31 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,443

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
There are a few possible problem areas to consider here.
Quote:
I was running slackware 14.0 and had the same problem. Now I updated to slackware 14.1 and it still persists
Was this an upgrade or a fresh install? If an upgrade, then it is possible that there are stale config files.

Quote:
I tried to chmod 664 rc.inet1 but it didn't work.
If you want to use NetworkManager in Slackware, then you need a clean /etc/rc.d/rc.inet1.conf as well as making /etc/rc.d/rc.networkmanager executable.
From the email to root titled "Welcome to Linux (Slackware 14.1)!"
Quote:
If you will be using wireless (or even a wired interface), you might
want to let NetworkManager handle your network connections. This is
a choice during the initial installation, but may also be selected
later by rerunning netconfig, or by setting the startup script
to executable (chmod 755 /etc/rc.d/rc.networkmanager). When Network
Manager is used to handle connections, a nice interface is provided
to scan for wireless access points and make changes to the network
configuration. This interface runs automatically with KDE or Xfce.
In fluxbox, the nm-applet program will need to be launched. Other
window managers lack a system tray to display nm-applet, so for those
you might want to look at wicd in /extra, which also provides a nice
GUI tool for connecting to wireless (or wired) networks. For window
managers that do not provide a tray for running programs, start
"wicd-client" to make changes. With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.
Quote:
before this, I could connect to the eduroam wifi (wpa2e) network at university without the need to open NetworkManager(it was just executed at boot time).
Perhaps you had setup wpa_supplicant to do this?

This thread has some information on using 'wicd' to connect to an eduroam wifi network. http://www.linuxquestions.org/questi...cd-4175479700/
 
1 members found this post helpful.
Old 04-04-2014, 05:29 AM   #6
fsauer
Member
 
Registered: Jul 2012
Posts: 38

Rep: Reputation: Disabled
in rc.M either rc.wicd or rc.networkmanager are called alternatively. If you have both of them installed and executable, trouble is there.

I ran into that problem once. If you enable rc.networkmanager uninstall or chmod -x rc.wicd. Maybe this is old stuff and not relevant any more....

Good luck
Franz
 
Old 04-05-2014, 04:23 AM   #7
epimenidecretese
LQ Newbie
 
Registered: Dec 2013
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
So, mine is a fresh install and I don't have wicd.

I tried to set first loopback and NetworkManager with netconfig (so to clean rc.inet1) but it didn't work.

As far as I remember I didn't set wpa_supplicant and I could connect to my eduroam without having NetworkManager to start(I use openbox so I just launch applets when I need them, since have no tray panel).

Continues to get stranger and stranger. Do you guys have some other ideas? I really don't know what else to do.
 
Old 04-05-2014, 06:27 AM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,443

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
I would suggest setting up wpa_supplicant so you can connect from the command line. This looks like a good guide that you should be able to adapt to suit. https://www.eduroam.no/klient/linuxwpa.html
You could also look at this http://www.wireless.bris.ac.uk/eduro...ons/go-wpasup/

As to OpenBox and a system tray, http://urukrama.wordpress.com/openbo...e/#systemtrays
All the options there are available to be built using SlackBuilds from http://slackbuilds.org
 
Old 04-05-2014, 07:10 AM   #9
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
I had a similar problem, and checking dmesg the issue was that even though I was offered an IP by DHCP, it was timing out for some reason. In that same dmesg log I was able to actually see the IP that the server was trying to send me, and I set this IP as static in that wireless connection. Worked like a charm

I just don't know why this happens, and it's not the first time.. Unfortunately I'm not at my personal machine at this moment and can't paste the content of the dmesg, but I was offered the same IP 3 times in a row by the server before it gave up
 
Old 04-09-2014, 03:44 PM   #10
epimenidecretese
LQ Newbie
 
Registered: Dec 2013
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
So, I solved the problem. I stopped iptables and now I can reach the proxy login page. I had generated the rules with alienbob automatic generator: but now I don't know what to do in order to make the firewall AND the connection work. Do you have any advice? I am going to mark this question as solved anyway.
 
Old 04-10-2014, 11:53 AM   #11
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,443

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
If the problem is in your firewall rules, then you will need to make appropriate modifications. Check your logs from when the problem was occurring. Some traffic was being blocked that needs to be passed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
beloved XV doesn't work right on Slackware 14 wevl Slackware 4 05-30-2013 07:43 PM
[SOLVED] wicd doesn't work on Slackware 13.37 ? wubai Linux - Wireless Networking 5 11-12-2012 08:56 PM
wicd 1.7.x doesn't work in slackware 13.0 gapan Slackware 4 07-07-2012 06:18 PM
NetworkManager & gprs/ppp DNS: after using wlan/eth0, DNS for ppp doesn't work mtess Linux - Networking 3 03-12-2008 03:31 PM
ZAxisMapping under Slackware 10.0 doesn't work KingofBLASH Slackware 7 09-21-2004 10:01 PM


All times are GMT -5. The time now is 12:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration