LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-04-2011, 09:41 AM   #1
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Rep: Reputation: Disabled
NetworkManager


Hi all,
I've been using wvdial with my mobile broadband connection but decided to try NetworkManager out and I've come across an error. I've installed all the deps (as far as i know) from Slackbuilds and added plugdev,netdev to users group.

bash-4.1$ nm-applet &
[1] 30090
bash-4.1$
** (nm-applet:30090): WARNING **: <WARN> request_name(): Could not acquire the NetworkManagerUserSettings service.
Error: (9) Connection ":1.23" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file

Any help would be appreciated, thanks.
 
Old 09-04-2011, 10:08 AM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
You are having a PolicyKit permissions problem.

Try this:

Quote:
To grant permissions to users in the plugdev group (for example), the system administrator must create the file /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla with the following contents:
Code:
[nm-applet]
Identity=unix-group:plugdev
Action=org.freedesktop.NetworkManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes

[nm-applet-userSettings]
Identity=unix-group:plugdev
Action=org.freedesktop.NetworkManagerUserSettings
ResultAny=yes
ResultInactive=no
ResultActive=yes
 
Old 09-04-2011, 10:28 AM   #3
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Thanks for the reply, I've added that file and rebooted, now I'm getting this when entering nm-applet from console.

bash-4.1$ nm-applet
** Message: applet now removed from the notification area

** (nm-applet:2374): WARNING **: get_all_cb: couldn't retrieve system settings properties: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.
** Message: applet now embedded in the notification area
** Message: applet now removed from the notification area

** (nm-applet:2374): WARNING **: fetch_connections_done: error fetching system connections: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.



bash-4.1$ groups
users wheel audio video cdrom plugdev netdev
 
Old 09-04-2011, 10:40 AM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
You do have an /etc/rc.d/rc.networkmanager file, no?

Have you tried to start NetworkManager at boot?

Add

Code:
# To disable networkmanager, chmod rc.networkmanager to 644
if [ -x /etc/rc.d/rc.networkmanager ]; then
  . /etc/rc.d/rc.networkmanager start
fi
to /etc/rc.d/rc.local

and add this to rc.local_shutdown (create if necessary) and chmod +x /etc/rc.d/rc.local_shutdown
Code:
#!/bin/sh

# To disable networkmanager shutdown, chmod rc.networkmanager to 644
if [ -x /etc/rc.d/rc.networkmanager ]; then
  . /etc/rc.d/rc.networkmanager stop
fi
Then reboot and see if your errors persist.

EDIT: You could also try to run:

Code:
# nm-connection-editor
and check "Available to all users" and apply the settings.

You probably also need a valid consolekit session.

x should be launched with ck-launch-session.

You can check with:

Code:
ck-list-sessions
as a user, not root.

You should have an active and local session.


Quote:
lxde@asus-gentoo ~ $ ck-list-sessions
Session1:
unix-user = '1003'
realname = '(null)'
seat = 'Seat1'
session-type = ''
active = TRUE
x11-display = ':0'
x11-display-device = '/dev/tty7'
display-device = ''
remote-host-name = ''
is-local = TRUE
on-since = '2011-09-04T13:50:45.492311Z'
login-session-id = '7'

Last edited by andrewthomas; 09-04-2011 at 10:58 AM.
 
Old 09-04-2011, 11:29 AM   #5
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
My mistake I didn't start /etc/rc.d/rc.networkmanager after reboot, thanks for help andrewthomas it's working fine now. Although when i create a mobile broadband connection with setup it doesn't show up when i left click, only shows the eth0 device..and won't let me edit that connection.
 
Old 09-04-2011, 11:51 AM   #6
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Did you try this:

Quote:
Originally Posted by andrewthomas View Post

Code:
# nm-connection-editor
and check "Available to all users" and apply the settings.
 
Old 09-04-2011, 11:56 AM   #7
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Yeah, I went through the nm-connection-editor to set it up, "Available to all users" is grey and unable to click on it. Don't know if that could be the problem?
 
Old 09-04-2011, 12:49 PM   #8
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
To grant permissions to users in the plugdev group (for example), the system administrator must create the file /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla with the following contents:
Code:
[nm-applet]
Identity=unix-group:plugdev
Action=org.freedesktop.NetworkManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes

[nm-applet-userSettings]
Identity=unix-group:plugdev
Action=org.freedesktop.NetworkManagerUserSettings
ResultAny=yes
ResultInactive=no
ResultActive=yes
try adding this to the above file


Code:
[org.freedesktop.network-manager-settings.system.modify]
Identity=unix-group:plugdev
Action=org.freedesktop.network-manager-settings.system.modify
ResultAny=no
ResultInactive=no
ResultActive=yes
You may have to re-boot after making changes.
 
Old 09-04-2011, 01:03 PM   #9
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
I added that to the file but still the same after reboot, I've tried the command 'ck-list-sessions' which doesn't give me any output. I killed X and tried starting it with
ck-launch-session startfluxbox but wouldn't start up with that command.
 
Old 09-04-2011, 01:12 PM   #10
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
What I did was:

start rc.networkmanager
Run nm-applet as root and edit the connections (didn't know there was a connection editor)
Made my wifi connection a permanent one available for all users.
Kill nm-applet
Start nm-applet as user

Added this to rc.local:

nmcli con up uuid 0b1486b8-4a7b-4bea-ae6d-10390d898619 1>/dev/null 2>&1 &

After finding the uuid so it connects on boot.
 
1 members found this post helpful.
Old 09-04-2011, 01:31 PM   #11
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Thanks for that dive, it works on my ethernet device but for some reason it doesn't work on my mobile broadband modem. Maybe I'm not editing it right, it just doesn't save it, this is what i get from the console (running at root) nm-applet

http://pastebin.com/xneGf8f8
 
Old 09-04-2011, 01:50 PM   #12
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Hmm does the connection show when you rightclick on the systray icon and edit connections? Mine tend to show up with 'Auto $IFACE'

I've not had to set up a mobile broadband connection yet so can't really help in that area.

Last edited by dive; 09-04-2011 at 01:52 PM.
 
Old 09-04-2011, 01:57 PM   #13
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
I might have worded that wrong, it shows up when you right click to check or add a connection after saving it but doesn't show on left click on the networkmanager icon. Probably a bash script for stopping and starting wvdial for my fluxbox menu might have been easier, but would like solve this problem.
 
Old 09-04-2011, 02:00 PM   #14
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
One of the things I had to do was edit out the 'Auto' in the name so it would be permanent.
 
Old 09-04-2011, 02:18 PM   #15
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Don't understand it dive, both config files are there /etc/NetworkManager/system-connections/ (eth0 and my mobile broadband) but only ethernet device showing when I left click on the icon. I commented out the 'Auto' in the file too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] NetworkManager Ipozya Arch 9 01-20-2011 10:22 AM
NetworkManager dbswifty Linux - Newbie 6 08-23-2010 06:05 PM
networkmanager giraf Ubuntu 7 05-05-2010 05:22 PM
Besides NetworkManager, shreks Fedora 1 01-18-2006 03:26 AM
NetworkManager baparekh Linux - Networking 1 07-28-2005 05:05 AM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration