Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 07-15-2003, 11:29 AM   #1
LQ Newbie
Registered: Jun 2003
Location: Brooklyn, NY
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
Network question

I have recently completed an install of Slackware 9.0 and I am noticing a few error messages I wanted to ask about. Any help is appreciated.

The first message comes when Slackware is booting up. It detects my network card and then insmod gives a few errors. At the end it says that it failed but the weird part is that I can still access the internet. Here is the error message:

8139cp:10/100 PCI Ethernet driver v0.3.0
insmod: /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz
init_module: No such device

insmod: /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or the output from dmesg

insmod: /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz: insmod: /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz failed

insmod: /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz:
insmod 8139cp failed

I would like to know if there is a solution to this error message, because my internet seems to be working fine. I have not checked it for speed yet but the card and connection seem to be working. Any help is appreciated. Thanks

Last edited by Scythe; 07-15-2003 at 11:32 AM.
Old 07-15-2003, 11:45 AM   #2
LQ Guru
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
That's your ethernet card. If you don't have a local area network, disable bringing up eth0 on startup and the errors should dissappear.
Old 07-15-2003, 12:21 PM   #3
LQ Guru
Registered: Jan 2001
Posts: 24,147

Rep: Reputation: 229Reputation: 229Reputation: 229
Make sure you don't have these modules trying to load from /etc/rc.d/rc.modules
Old 07-15-2003, 12:38 PM   #4
LQ Newbie
Registered: Jun 2003
Posts: 11

Rep: Reputation: 0
Add the module 8139cp to /etc/hotplug/blacklist and the error message goes away.
I got the same error when i first installed 9.0 and its because hotplug cant see if its the 8139cp or 3189to module that should be loaded for the network card.
Old 07-15-2003, 12:39 PM   #5
LQ Guru
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Apparently, that card doesn't identify itsself completely and there are two modules, 8139cp and 8139too available for it.

If you are using the card and it is working, apparently it has the correct module loaded.

su - and do


Look through the list and you will see the modules you have loaded.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
network question monohouse Linux - Software 6 12-18-2004 12:10 AM
Question 1 Firewall Log Question 2 Network Monitor Soulful93 Linux - Networking 4 08-05-2004 12:05 AM
network question pkuer Debian 14 07-15-2004 11:20 PM
Network Question Russy Linux - Networking 7 07-10-2003 11:36 PM
Network question o0k|ey Slackware 3 07-10-2003 05:16 AM

All times are GMT -5. The time now is 09:13 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration