LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-01-2014, 01:01 PM   #1
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Rep: Reputation: 1
Network Manager Failing Periodically


All,

I have a home server that I use for automated trading so it needs to be up and running 24/7.

A couple of months ago I bought a Belkin N300 for my wireless access point/router. Heh, and there is no other way to descript it, it's been a true piece of crap. At first none of the Linux/Windows/Android devices in my house could stay connected to it for very long. So I've fiddled and poked at it for a while until it's pretty stable with everything except my Slackware server.

Currently on my Slackware server, the Belkin will screw up somehow and I'll lose the connection to it on my server/Windows/Android devices, BUT the Windows/Android devices will reconnect within a few seconds and all will be well, but my Slackware server will not. In fact I have to reboot the server to get it to reconnect -- sometimes I have to reboot the Belkin also.

I've tried restarting network manager by running as root . . .

/etc/rc.d/rc.networkmanager restart

But that does not fix the problem.

I run trading tests that can last 3 to 4 hours, plus it's trading live 24/7 (well, not when it's lost its network connection obviously), so if I'm in the middle of a test I can't just restart it all the time.

One last thing, I've noticed that when I hit the server from one of my Windows machines (through samba) it can sometimes fail then, but most of the time it's good. Also, the software from my brokerage is written for Windows, so that is running in Wine, so I wonder if the Wine/Windows thing might be causing some problems to.

I don't know, anyway, any ideas? Like I said, I really need this server to be working 24/7.

Thanks,

Bob
 
Old 05-01-2014, 07:00 PM   #2
Nh3xus
Member
 
Registered: Jan 2013
Location: France
Distribution: Slackware 14.1 32 bits
Posts: 190

Rep: Reputation: 56
Hi,

Is your server connected through the 802.11 wireless network ?

Or do you use a standard RJ45 Ethernet cable ?

If you only use an Ethernet cable, you can ditch Network Manager and use the dhcpd daemon enabled by default on a fresh Slackware install.

Regarding to Network Manager, this tool needs various daemons like consolekit and the gnome-keyring ones to store and manage your wireless encryption key.

If you are not sure of the actual configuration of the said daemons, your best bet is to run the command

Code:
 # netconfig
as root again and choose NM.

This will reconfigure the permissions on the startup scripts involved by the whole NM thingy.

On a side note, NM appears to prompt you for the so called "keyring password" when you want to connect to a wireless network protected by a "high end" encryption method like WPA2-Enterprise. When you use a "standard" WPA encryption key, NM run just fine as a daemon.

This is a known bug, sadly.

The "problem" encountered by some other folks on this forum, is that the password prompt is only displayed to the user if the X server is running, which is a pointless service on a server most of the time...

That's the kind of problem I have too. My Slack box connects just fine on my WPA protected wireless, which can be tested by a simple ping command in a TTY without Xorg running, but fails at connecting an "Enterprise" network during a standard runlevel 3 boot.
 
Old 05-03-2014, 07:27 PM   #3
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
Nh3xus,

Wow, sorry I have not replied sooner. I've been unable to get to a computer and reply for two days, although I read your reply on my way to work yesterday, since that time I haven't had a spare minute. So again, sorry.

To Answer your questions . . .
Is your server connected through the 802.11 wireless network ? Yes
Or do you use a standard RJ45 Ethernet cable ? No

I tried running netconfig, but alas that did not work.


BUT . . .

If I run

cat /proc/net/wireless (to show if the module has been loaded in memeory) it shows nothing. Same thing as when I run
cat /proc/net/ipv6_route
The latter will show information about the loop back device, but no wireless. When the system is healthy both of those command will
show good data.

So for some reason the wireless module is being unloaded from memory. Trying to find out why . . .
 
Old 05-03-2014, 07:57 PM   #4
Nh3xus
Member
 
Registered: Jan 2013
Location: France
Distribution: Slackware 14.1 32 bits
Posts: 190

Rep: Reputation: 56
You can try to replace NM by the plain and simple, but reliable, wpa_supplicant.

You can find some templates config files for it on the Internet.

It's not that hard to write such a config file.

FYI : NM is "just" a wrapper that generates a wpa_supplicant conf file for you.

The other part of the NM job is the management of all your saved wireless passwords. (And that's where the "fun" is at)

Last edited by Nh3xus; 05-03-2014 at 07:59 PM.
 
Old 05-04-2014, 02:52 PM   #5
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
Nh3xus,

I think that is a good idea and what I'll try. I've been wondering about that too, and now that you've told me that NM is just a wrapper around wpa_supplicant it sounds like an even better idea to me.

Give me a day or so to get down to my server and try it out and I'll let you know how it goes.

Thanks again for all your help.

Bob
 
Old 05-11-2014, 01:35 AM   #6
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
Nh3xus,

Well, I've been working on this during the week, with no luck. The module not loading has bother me so I did some searching on the Kernel.org site and low and behold on May 1 a bug was entered about the module I use dropping intermittently. So this may be a problem with my actual Kernel Module. I'll keep you posted.

Thanks,

Bob
 
Old 05-17-2014, 05:18 PM   #7
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
Nh3xus and All,

First off Nh3xus, thanks for your initial help. I tried configuring my network manually, but I didn't seen to get it working quite right.

This week I upgraded to a new kernel (3.14.3). Alas, the connection is still dropping all the time. Sooo, I thought, maybe the problem isn't Linux or Slackware, exactly. Maybe it's more basic, like HOW I'm using wireless. After all, I'm don't know anyone, first hand, who uses wireless for a production server. Maybe I should treat it more like a server -- no dhcp, etc.

So this week I'll try setting a specific wireless channel, static IPs, etc. Currently, I'm trying setting permanent IP address, rather than using dhcp.

So far (no long enough to tell really) is seems to be working good.

By the way, I use this server for trading, so during the week I can't really tweak it at all. If I loose a connection, I have to get back on quickly and continue, else I loose trades. So that is why I'm only showing up here on weekends to post my results/questions.

I'll let the forum know how things turn out.

Bob
 
Old 05-17-2014, 06:21 PM   #8
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
Sorry, I have not read in detail

From what I have read I would say the wifi router is suspect.

Been there myself

wicd seemed to do better, reconnecting when 'problems'
but not perfect, just less of a problem

My advice ..
Wire... if you can use wire
failing that
New wifi nic and/or router

a little while back I replaced a netgear with a tp-link n900, (openwrt firmware)

Been very happy with it, wifi just 'works' wcid, netmanager.. androids
Not had to do any power cycles, unlike the netgear, which was a weekly thing

But still, wire if you can !
Even my buggy netgear worked fine on wire
 
Old 05-20-2014, 12:37 PM   #9
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
Firerat,

Thanks for the reply. And I'm afraid that you are right, the ultimate solution is going to be to go wired. I've dragged my feet on drilling some holes in my house, but I think it will come to that eventually.

As I said in previous posts, I mostly work on fixing this during the weekends because during the week, by hook or crook, I'm pretty much commited to doing whatever I can to keep the server going because the Currency Markets are open then. So Saturdays and Sundays turn out to be my trouble shooting days.

I am still fiddling with my wireless though, just to make sure I've tried everthing. Dumping dhcp seems to have helped, but not solved my problem. Also, upgrading the kernel to 3.14.4 seems to have help, but again not solved my problem. Currently, I'm trying a hard channel setting on the router. So far so good, but we'll have to give it several more days to make sure.

Again, I'm thinking I will eventually have to go wired on this thing. But I'll let the forum know this weekend how the wireless is going.

Thanks again for your advice.

Bob
 
Old 05-20-2014, 02:17 PM   #10
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: slackware
Posts: 303

Rep: Reputation: 41
Quote:
Originally Posted by BobTheSlackUser View Post
Firerat,

Thanks for the reply. And I'm afraid that you are right, the ultimate solution is going to be to go wired. I've dragged my feet on drilling some holes in my house, but I think it will come to that eventually.

[...]

Bob
You could always get a couple of those power line connectors and plug in on a wire that way, save you drilling holes everywhere.
 
Old 05-21-2014, 05:01 PM   #11
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
Quote:
Originally Posted by rkfb View Post
You could always get a couple of those power line connectors and plug in on a wire that way, save you drilling holes everywhere.
I was just about to post that

relatively cheap as well

Although I've no personal experience with them yet
 
Old 05-21-2014, 06:08 PM   #12
Nh3xus
Member
 
Registered: Jan 2013
Location: France
Distribution: Slackware 14.1 32 bits
Posts: 190

Rep: Reputation: 56
Well, I do have a personal experience with power line connector :

Even when you buy some "good" brand, they tend to overheat badly and thus disconnecting your end device.

I'm close to put a DIY cooling system on one of them because of that...

But aside from that particular annoyance, they works just fine and in a transparent way.

Regardless the OS, of course.

Keep in mind that some of them provides an optional encryption feature that can only be managed through MS Windows.

I don't use it because I'm in a house and not in a flat, so my network is isolated from everyone else.

Technically, your main power breaker acts as an power line signal jammer.

Another very important note :

If you OR one of your neighbors is doing some "amateur radio transmission", its incompatible with the power line technology since these two technologies act as jammers for each other.
 
Old 05-21-2014, 11:20 PM   #13
ryanpcmcquen
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 74

Rep: Reputation: Disabled
Let me speak from personal experience, that I went through every solution in the book trying to get my Belkin router to be stable (I even put open source firmware on it!).

It was NEVER reliable with Linux. Period.

So I bought a better Belkin, or so I thought! Turns out it was just as crappy as the first one, despite being a more 'premium' model.

I then read tons of reviews (spending weeks researching the best options) and subsequently bought the Buffalo N600, that ships with DD-WRT out of the box (open source firmware).

The day I got the Buffalo is the day I stopped having wireless issues. I wish I had bought it 6 months sooner. Whatever you buy, at the very least research the chip inside of it. Most of them are made by either: Atheros, Broadcom or Realtek. In my experience, the routers with Atheros chips are FAR and AWAY the best for Linux (or anything for that matter).

Hope that helps. NEVER BUY A BELKIN!
 
Old 05-23-2014, 10:21 PM   #14
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
All,

Well, it's the weekend, so it's time for me to report. Short answer, wireless has just kicked my butt for another week -- I've switched channels, new kernel, gotten rid of dhcp, etc. everything.

I'm afraid that, as far as I can tell the Belkin router seems to be the main problem like ryanpcmcquen says. So I've pretty much given up on wireless.

So today I went over to my brother - in - law's and borrowed a couple of his Powerline modules like some of you have suggested. I plugged them in this afternoon. So far it's working pretty good. The network has only been up for about 8 hours, so time will tell. But so far, it's looking good.

ryanpcmcquen, I'll take definitely take your advice on open firmware, etc. the next time I try wireless.

I'll post me results on the Powerline after a day or two.

BUT, thanks to all of you for your advice and experience.

Bob
 
Old 05-27-2014, 12:27 PM   #15
BobTheSlackUser
Member
 
Registered: Feb 2007
Distribution: Slackware, Linux From Scratch
Posts: 47

Original Poster
Rep: Reputation: 1
All,

Well the move to hard wired (PowerLine type connections) connecttions has solved the problem. I'll try a Buffolo router next time. But for now, I'm just not sure that wireless technology is quite "there" yet. Even Windows and Mac machines don't seem real solid using wireless technology.

Anyway, thank you to everyone for helping me with this issue.

Bob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Manager failing to connect wirelessly fakie_flip Linux - Software 2 12-21-2013 03:53 PM
virt-manager failing console connection eco Linux - Server 2 06-21-2010 09:11 AM
[SOLVED] How do I switch the network manager from YAST back to the default network manager? skykooler Suse/Novell 7 03-09-2010 07:28 PM
Failing to get Profile Manager using do_GetService(NS_PROFILE_CONTRACTID, &rv) vikashsonar Linux - General 1 03-20-2008 06:11 AM
Network Address Periodically Changes Without Warning kaplan71 Fedora 2 04-30-2007 10:21 AM


All times are GMT -5. The time now is 11:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration