LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Network issue in Slackware 10 (http://www.linuxquestions.org/questions/slackware-14/network-issue-in-slackware-10-a-310460/)

diaphugo 04-06-2005 03:15 PM

Network issue in Slackware 10
 
I have installed Slackware 10 on my system, however I can't seem to get the integrated NIC to work with Slackware 10... The board is a K7S8XE with an onboard NIC and works fine under Debian(Net installer, too), and Mandrake 10. The device eth0 shows up under ifconfig, but it has no IP assigned to it, and if I manually assign (I would prefer it to use dhcp) the IP's it shows them in ifconfig, but I get no ping from the router, so I'm pretty sure it's something with Slackware 10 not seeing this NIC correctly. I have read posts concerning the K78SXE motherboard in Slackware but didn't see any problems with the NIC. Any suggestions?

DaHammer 04-06-2005 03:48 PM

Is the sis900 module for the nic loaded? Use "lsmod" to check. If not, then load it with "modprobe sis900". Did you configure the network? If not use "netconfig" to do so.

diaphugo 04-06-2005 05:04 PM

lsmod
 
I am at work at the moment so I can't check with lsmod, however I did try to manually load it with insmod sis900 and it didn't return any errors, and after it still was not working, I recompiled the kernel and compiled sis900 into the kernel instead of as a module... When I get home I will run netconfig and see if that works out. Thanks for the response, I'll let you know how it goes.

subekk0 04-06-2005 09:17 PM

Are you using DHCP? If so you will need to configure the network card to use DHCP. Check your /etc/rc.d/rc.inet1.conf file and make sure that your DHCP="yes" is set. Also after you do that you should check your /etc/resolve.conf file and make sure the info is correct.

If you can do an ifconfig and it shows the card with no IP then chance are the above will fix it. However, I could be wrong. It is just something else to check.

-sub

diaphugo 04-07-2005 08:58 AM

Setting the DHCP to "yes" fixed the problem.. I didn't think to check that as I assumed it would be set to that default... Guess that means I shouldn't assume anything. :) Thanks for the help.

davatar 04-07-2005 02:52 PM

For future reference, if you didn't already know, entering

# dhcpcd

will attempt to retrieve info via dhcp, and

# dhcpcd -k

will clear it. (So basically ipconfig /renew and /release if you were on Windows)

I find this handy when I need the IP to renew (or my main windows server goes offline and clears the dhcp cache).

~Dav

diaphugo 04-07-2005 03:35 PM

Thanks for the tip. That will come in handy.


All times are GMT -5. The time now is 06:23 AM.