LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   network install with cross othercable (http://www.linuxquestions.org/questions/slackware-14/network-install-with-cross-othercable-4175503817/)

shoshia 05-03-2014 12:29 PM

network install with cross othercable
 
PXE and cross overcable.
I have 3 computers O,A,B,C
O—gateway computer 10.1.1.1 serves my
LAN conputers
A,B,C computers are part of LAN
A—has 1 NIC 10.1.1.41
B--- has 2 nics eth0 10.1.1.42
C—has 2 nics 10.1.1.43

On A I have setup linux(Slackware) and pxe/nfs dnsmasq.
When A-s eth0 is connected to switch and B-s eth0 , or C-s eth0
B and C can see linux pxe loader. I have installed such way system on A.
I have set B-s eth0 and C-s eth0 MAC adresses on A-s dnsmasq.conf
As static ones /later I need to run whis machines as computing claster/
B-s eth0 MACADRESS 10.1.1.42
C-s eth1 MACADRESS 10.1.1.43

Now:
A-s eth0 is connected to LAN switch
B-s eth0 is coonected to LAN switch
B-s eth1 is connected to C-s eth0
Have activated IP forwarding on B
Problem:
When I start C machine whith such setup it can not see/load PXE from A

when I have A and C (or A and B)connected directly
to switch of course i can install from A to B.
But when C is connected directly to B not.

any suggestions?
p.s.
1.of course i can install through switch, but why can not install way i described above?
2. do i need to add MACADRESS-IP_ADRESS pairs for
eth1 of B and C machines?

Alien Bob 05-05-2014 02:54 AM

You are mixing up two concepts.
If you want to use ip_forwarding, then you're talking about a computer that is configured as a router/gateway and knows all the other computers in the LAN because they are directly connected. In this case youll also have to configure computer "B" as a NAT firewall/router.

If you want to route network packets from one network segment to another in a LAN where you have more than one router (in your case, "O" and "B" are both routing packets) then you have to enable the routing daemon on both.

In order to enable routing you have to edit /etc/rc.d/rc.inet2 on computer "B" (the one with the two NICs) and enable the routing daemon by removing the comment characters from these lines:
Code:

# # Start the network routing daemon:
# if [ -x /usr/sbin/routed ]; then
#  echo "Starting network routing daemon:  /usr/sbin/routed"
#  /usr/sbin/routed -g -s
# fi

You'll need to enable routing because otherwise the default gateway in your network setup (computer "O") does not know that there is another computer behind "B".

In all these cases, computer "C" and the eth1 of "B" will have to get an address in a different subnet as O, A and the eth0 of B.

If you want to use the same LAN segment for all four computers (10.1.1/24) then you will have to configure a bridge instead of routing or forwarding on computer "B". You can find comments about how to configure a bridge in /etc/rc.d/rc.inet1.conf .

Eric

jefro 05-05-2014 09:54 PM

Unless you have all very old computers, new nics (and you only need one side new) all auto correct for the cable type. May have to boot with the cable in as some older ones won't change booted.

shoshia 05-06-2014 10:54 AM

Quote:

Originally Posted by jefro (Post 5165386)
jefro

No cabling was not problem


Quote:

Originally Posted by Alien Bob;
Alien Bob

I solved it using bridging.

In case someone has same problem:

Here is my network setup:
Bridged B machine.
C is crossovered to B's eth1

B's eth0 is connected to switch.
B's default gateway is O machine.
no dnsmasq/router is runing on B.

A(has 1 nic) is connected to switch.
A's default gateway is O machine.
nfs,tftpd are running on A with Slackware install directory

plus added "default router is not on same machine as tftpd" in dnsmasq option file on machine A. pointed router
O (10.1.1.1)
(I have configured built in DHCP in dnsmasq with MACADRESS--static IP pair setup to find client machines for nework install )

In case some needs configs can post, but everything is in http://alien.slackbook.org/dokuwiki/...=slackware:pxe :)

Thanks a lot.

jefro 05-06-2014 08:30 PM

Sorry, I didn't read the issue properly and gave a dumb answer.


All times are GMT -5. The time now is 08:57 AM.