LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-02-2007, 04:01 PM   #1
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Rep: Reputation: 30
Network in Slackware 11


Hello,

I recently bought a new computer and decided to put Slackware 11 on it. The problem I am having is that I cannot seem to get my network established on it. I am running a DSL modem which acts as a router and runs DHCP. When I had Slackware 10.2 on my old computer, I had to use the bareacpi.i kernel because the bare.i kernel wasn't handling the network interface properly.

My new computer has a nVidia integrated network interface. I used the standard sata.i kernel and could not get the network to read. It was strange because the KDE control panel indicated that it had an IP address assigned to it. I then tried the bare.i kernel, but it couldn't read my SATA hard drive. I then tried the bareacpi.i kernel, but it couldn't read the network - it showed the network up, but no IP address was assigned. I then tried the huge26.s kernel, thinking that maybe it would have better luck with my newer equipment. But it doesn't even acknowledge my NIC. When I tried ifconfig eth0 (which works with the other kernels) it told me that eth0: device doesn't exist. I don't know what else to try. Any advice?
 
Old 03-02-2007, 10:15 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
I'm no expert, but I will suggest a few things which I discovered during the process of getting my LAN to work with Slack-11 and a 2.6 Kernel, which I did NOT have to do with the stock 2.4.33.3 kernel:
(BTW I am using a home-made 2.6.20 kernel and have an onboard Intel Pro 10/100 ethernet)

1.. Try to avoid using the KDE network configurator, especially after you finally get the network to work. It is good to play with to determine what addresses you should be using for the IP, Broadcast address, Gateway etc.. But afterwards, try to avoid it because it just screws up your rc.inet1 & 2 files.
2.. If/when you DO use the KDE configurator, select your distro as SuSE 7.0.. I can't explain this because I don't know enough about it, but you will see that Slack 11 is NOT in the list of compatible OS's, but SuSE 7 works for me.
3... Do you have a static IP? Prolly not if you are directly connected to the net, but if you DO, then don't use DHCPD or BootP. If at all possible, set your IP's and stuff hardcoded into the rc.inet file.
4... Do you have a /etc/resolv.conf file? (yes it is spelled correctly) in your /etc directory? Along with this file you need a nsswitch.conf file
Slack-11 requires these files for many LAN/Ethernet functions to work. As an example, mine contains the following(resolv.conf):
nameserver 142.177.129.11
nameserver 142.177.1.2
domain mshome.net

All that's there is the IP's of the nameservers that My ISP uses, and the name of my LAN network here at home.

and nsswitch.conf (yours may end up vastly different, or similar; dropline gnome changes these files too, keep it in mind):
hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

With the stock distro set up originally, it did not come with one of these files, and I went through heck figuring out what was missing..
Check the Docs for the HOW-TO department which should be somewhere within your distro; Verify that your HOSTNAME and HOSTS and HOSTS.CONF are all there and correct.
Finally, while I again can't say for sure, there's a chance that the kernels you are using do NOT have the module compiled or available for the ethernet card on your motherboard (the nvidia one). Personally, I havent heard much about nvidia interfaces, though I have been spending the last 2 days setting up my nVidia AGP card for dual-screens :P what a chore.. Check thru the rc.modules file and see if there is a module there for your NIC; if there is, try modprobing it into the kernel and see if that helps; if there is not a module, you may want to look into recompiling the kernel with the support needed, providing the support exists; the kernel config menu will let you know if it has a module for that NIC..
PS- Finally again, check the Hardware Compatibility list on this site for info.
Best of Luck
Sasha

Last edited by GrapefruiTgirl; 03-02-2007 at 10:24 PM.
 
Old 03-02-2007, 11:50 PM   #3
j0rd4n
LQ Newbie
 
Registered: Jan 2007
Location: Redlands, CA
Distribution: Slackware 11
Posts: 21

Rep: Reputation: 15
Quote:
Originally Posted by JMJ_coder
I then tried the huge26.s kernel, thinking that maybe it would have better luck with my newer equipment. But it doesn't even acknowledge my NIC. When I tried ifconfig eth0 (which works with the other kernels) it told me that eth0: device doesn't exist. I don't know what else to try. Any advice?
You should also double check to make sure you have the appropriate kernel module loaded for your network interface. Check the listings in /etc/rc.d/rc.modules and uncomment the line that matches your NIC.

j0rd4n
 
Old 03-03-2007, 12:34 AM   #4
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Should add also: look through your dmesg output and 'messages' files to see if during boot the kernel even sees the NIC (I know you wrote that it 'doesn't' exist, but does it not exist all the time, or just after the system is up and running) and based on what you see, you can tell if the kernel is even seeing the NIC at any time.
(I kinda wrote my first post in the wrong order) THEN, check as stated above, in rc.modules, for a module to run that NIC.
 
Old 03-03-2007, 06:20 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,233

Rep: Reputation: Disabled
Quote:
Originally Posted by JMJ_coder
I then tried the huge26.s kernel, thinking that maybe it would have better luck with my newer equipment. But it doesn't even acknowledge my NIC. When I tried ifconfig eth0 (which works with the other kernels) it told me that eth0: device doesn't exist.
When you install and use the huge26.s kernel, be sure to also install the kernel-modules package from the /extra/linux-2.6.17.13 directory. The huge26.s kernel does not have network support built-in and the modules are not automatically installed when you install Slackware 11.0. This is intentional, since the huge26.s kernel in the installer is primarily used because it allows you to install Slackware 11 on machines where a 2.4 kernel would not recognize all of the hardware.

Eric
 
Old 03-03-2007, 07:38 AM   #6
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

Thanks for the hints. I'll try to install the modules, which I didn't do when I used kernel 2.6.

I went back to kernel sata.i and tried to get the network going. It now tells me that in the rc.inet1 file that in lines 1,2, and 256 the command eth_up: command not found. What command should it be or why can't it be found.
 
Old 03-03-2007, 07:53 AM   #7
slash
LQ Newbie
 
Registered: Feb 2007
Location: Serbia\Novi Sad
Distribution: Slackware 11
Posts: 4

Rep: Reputation: 0
Hi,
I had troubles with my router, too. As GrapefruiTgirl said, try not using KDE config. You should check (if you already didn't) is your ethernet card supported in ethernet HOWTO. I have used old 2.4.33 kerenel and sata.i. I have found a lot usefull info about configuring network in http://www.faqs.org/docs/Linux-mini/...ewall+DSL.html
If this doesn't help, I have another links that could help you. Post if this helped.
 
Old 03-03-2007, 10:04 AM   #8
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
The errant 'eth_up" commands are plunked into the file by KDE's network settings 'wizard', hence the recommendation to NOT use it once you have atleast gotten your IP addresses/gateway addresses sorted out.
It seems from my experience with the same issue, that the proper command is:
if_up eth0
Which you will likely see very near where you deleted the eth0_up command in rc.inet1.
The eth0_up commands are put there when you click the button for "Start this device automatically" in KDE wizard.
Once you have your IP's set up right, and the correct module for your NIC, the ethernet will come up all by itself during boot, and you won't have to do anything special to make it activate.
Infact, mine tends to seem to stay active even during reboots, perhaps disconnecting for less than a second if even that much.
 
Old 03-03-2007, 10:18 AM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,233

Rep: Reputation: Disabled
Quote:
Originally Posted by JMJ_coder
It now tells me that in the rc.inet1 file that in lines 1,2, and 256 the command eth_up: command not found. What command should it be or why can't it be found.
As GrapefruiTgirl already said, your rc.inet1 file was damaged by a program that thinks it knows better.
You can get the original file from the Slackware CD, and I also put them online for several recent versions of Slackware so you can grab the file you need easily. See http://www.slackware.com/~alien/rc_s...lackware-11.0/ for the rc files of Slackware 11.0

Eric
 
Old 03-03-2007, 01:08 PM   #10
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

Well, I added the modules for the 2.6 kernel and presto! the network is connected. It also solved the problem of there being no mouse in X. The mouse must be a module, too.

With the 2.4 sata.i kernel, I tried manually configuring the rc.inet.conf file but it still does not work. But, unless I get a good reason, I think I will just stick with the 2.6 kernel, which is currently working.

Thanks for all the advice.
 
  


Reply

Tags
dsl, ethernet, nic, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 06:48 AM
how to configure my network on slackware 10.0 so i can access a windows network salviadud Linux - Newbie 2 02-11-2005 01:19 PM
Slackware Network Jampthlon Linux - Wireless Networking 1 12-12-2004 02:53 PM
Network time-out Slackware 10 kern 2.6.7 Network everwhere NIC EdwardA Linux - Hardware 2 06-26-2004 08:16 AM
slackware 9.1 and network tuxandme Linux - Hardware 2 10-18-2003 10:02 AM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration