LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-13-2003, 02:16 PM   #1
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
NetConfig


I had my modem working and I could browse the Internet perfectly but I changed the NetConfig and everything went wrong. When Slackware boots up, I have to wait like five minutes because of some Mail Daemon and also I am no longer root@darkstar, I am root@127. Why? How do I set up my network if I have a modem. What do I need to set it up?
 
Old 07-13-2003, 07:40 PM   #2
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 49
If it ain't broke, don't fix it. If you're looking to fix your hostname (darkstar/127/whatever you want), you can change it in netconfig, with the "hostname" command, or by editing /etc/hosts and /etc/HOSTNAME (caps on purpose)
 
Old 07-13-2003, 08:08 PM   #3
Pres
Member
 
Registered: Jun 2002
Location: Australia
Distribution: Slack 9.1
Posts: 232

Rep: Reputation: 30
The "127" probably is coming from 127.0.0.1, your loopback IP address. How that ended up in your /etc/HOSTNAME I don't know. You can out and out delete /etc/HOSTNAME and next time you boot you will be darkstar again, if you like, with a new /etc/HOSTNAME created for you. There's a lazy fix for you not the best fix though because if there is a conflict with /etc/hosts, there might be some whinging from some scripts complaining "hostname cannot be found".

Last edited by Pres; 07-13-2003 at 08:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'netconfig' won't l0rddarkf0rce Slackware 3 07-28-2005 05:30 PM
netconfig Zero1 Slackware 3 08-24-2004 05:35 PM
Where is Netconfig? Mega Man X Slackware 3 12-03-2003 07:28 PM
netconfig knoxville Linux - Newbie 6 11-30-2003 01:56 PM
NetConfig XPediTioN Linux - Software 1 07-13-2003 03:50 PM


All times are GMT -5. The time now is 03:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration