LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2010, 03:28 PM   #1
tallship
Member
 
Registered: Jul 2003
Location: On the Beaches of Super Sunny Southern San Clemente, California USA
Distribution: Slackware - duh!
Posts: 520
Blog Entries: 3

Rep: Reputation: 112Reputation: 112
NetBeans 6.8 on Slackware 13.0...


I was preparing to install the NetBeans 6.7.1 package via the SlackBuild when I came across an issue.

The link to the source downloaded a different file than the one specified in the SlackBuild script, and although I can probably just go ahead and modify to change the filename, I wasn't originally happy with being limited to creating a Slack Package for version 6.7.1 anyway, considering that 6.8 has been released.

I'm posting here to gather consensus on first, whether anyone has built a package for 6.8 (and if they had any issues with building the 6.8 package), and secondly , what the community thinks in general about my considering just modifying the SlackBuild script to build the newer 6.7.1 package verses modifying the script to build a package for the new 6.8 release.

Your thoughts?
 
Old 02-25-2010, 06:07 AM   #2
tallship
Member
 
Registered: Jul 2003
Location: On the Beaches of Super Sunny Southern San Clemente, California USA
Distribution: Slackware - duh!
Posts: 520
Blog Entries: 3

Original Poster
Rep: Reputation: 112Reputation: 112
Cool The NetBeans 6.8 Slackware package has been created...

Okay, I checked the link on SlackBuilds.org for the NetBeans source verses the links to download NetBeans 6.8 from NetBeans.org and they're different.

So what I did was modify the link from SlackBuilds.org to the following and edited the SlackBuild script to reflect the correct version and date info:

Here's the source to download from NetBeans.org:

http://services.netbeans.org/bouncer...-6.8-ml&os=zip

And you can just use the existing SlackBuild for NetBeans 6.7.1 from SlackBuild.org (Don't forget to change the version in the script to 6.8 and the date to 200912041610 or whatever is tagged on the file you get from NetBeans.org) before building.

I also now have prebuilt Slackware packages for NetBeans 6.7.1 and NetBeans 6.8 if you would rather just install the Slackware package.

msg me if that's the case, and I'll prolly put it up at http://Slacky.eu so anyone who wants it can just d/l and install the package.

All is good

Last edited by tallship; 02-25-2010 at 06:22 AM.
 
  


Reply

Tags
netbeans


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Netbeans 6.7.1 in Slackware 13 gdb helper application failed to launch cstrieder Slackware 2 10-05-2009 08:21 PM
netbeans for C++ iqbala Ubuntu 3 10-05-2009 11:35 AM
Netbeans 6.7 sniff Suse/Novell 0 07-25-2009 03:59 PM
netbeans 6 minhajhussan Linux - Software 2 04-26-2008 04:35 AM
LXer: Sun Announces the Latest in Open Source Tools with the Availability of NetBeans Visual Web Pack and NetBeans C/C++ Development Pack LXer Syndicated Linux News 1 12-31-2006 07:37 AM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration