LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-10-2006, 12:16 PM   #1
mago
Member
 
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with 2.6.16.18 (still off the hook)
Posts: 284

Rep: Reputation: 33
Need to force Proftp in passive mode by default


Hello again,

I have a problem with proftpd (1.3.0), I need to start it in passive mode but the PassivePorts directive in the proftpd.conf doesn't do the trick.

Ok here is the scenario, I set up a ring of 42 servers with several sites on each server, the apache is generating independent logs for each server and we bought a dynamic software that will retrive the logs and analize them by prefix(site), now the darn software connects through ftp but doesn't handle active mode transfer and I cannot force it to send the passive command so I need to set the proftp as passive by default. I google quite a bit and I read all the directives for the proftpd.conf and I found nothing.

Any idas, hits, suggestions are more than welcome.


Thanks in advanced.


By the way, there is not a port problem. I'm pretty sure that security/port issue has been looked upon carefully, even doe all suggestions welcome.
 
Old 05-10-2006, 07:28 PM   #2
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Hmm.. that's a tough one since the PASV command is sent by the FTP client to the server and the server responds accordingly.

Have you tried asking this on the ProFTPd mailing list? I think the developers monitor that list.

Peace...
 
Old 05-11-2006, 11:05 AM   #3
mago
Member
 
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with 2.6.16.18 (still off the hook)
Posts: 284

Original Poster
Rep: Reputation: 33
Hmm, that is actually a great suggestion.
Thanks, kind of slow these days.
 
Old 05-11-2006, 12:06 PM   #4
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Quote:
Originally Posted by mago
Hmm, that is actually a great suggestion.
Yeah, when I have a problem with a particular app, I tend to read the mailing list and forums for that app before coming to a generic forum, like this one.

I've posted on the ProFTPd list in the past and got my issues addressed. I can't guarantee someone will tell you how to do what you need but you should be able to get more pertinent info regarding the feasibility of what you're wanting to do.

Good luck!

Peace...
 
Old 05-11-2006, 06:38 PM   #5
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Looks like a possible solution was posted to you on the ProFTPd mailing list.

Peace...
 
Old 05-11-2006, 06:42 PM   #6
mago
Member
 
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with 2.6.16.18 (still off the hook)
Posts: 284

Original Poster
Rep: Reputation: 33
Yes thanks, I got the mail.
 
Old 05-11-2006, 06:43 PM   #7
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
if the suggestion works, please share it with us!!!
 
Old 05-11-2006, 08:27 PM   #8
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Quote:
Originally Posted by mago
Yes thanks, I got the mail.
Great! Be sure to report back on the list.

Quote:
Originally Posted by win32sux
if the suggestion works, please share it with us!!!
Be sure to read the thread on the ProFTPd mailing list archive.

Since the solution hasn't been posted to the archive yet, I'll post it here:

Quote:
Originally Posted by ProFTPd mailing list
> I need to set the passive mode on the proftpd server as default, but as
> > far as I have been able to read on the internet and the docs on the
> > www.proftpd.org there is not such an option. I wonder if there is some
> > sort of work around that can do the trick.
> >
> > I'm currently running 1.3.0 and the problem is that certain automated
> > ftp client that I do not have control can access the server in passive
> > mode but I cannot force it to send the command.

Unfortunately there is no way to set a default for this. Whether the data
transfer is to be active or passive is, by RFC, left to the client to
specify.

At most, you can configure proftpd to use active data transfers only by
denying the PASV commands from clients, e.g.:

<Limit EPSV PASV>
DenyAll
</Limit>

Alternatively, you can cause proftpd to use passive data transfers only:

<Limit EPRT PORT>
DenyAll
</Limit>

However, I'm not sure that either of these configurations will help in
your situation.

TJ
There might be follow-on discussion in that mailing list thread, which is why you should either subscribe to the mailing list or monitor the archives.

Peace...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Glftpd + Iptables + Passive Mode supreme2k Linux - Networking 10 01-27-2004 07:56 AM
ftp passive mode ? lenlutz Linux - Networking 1 11-05-2003 01:11 PM
How to have passive mode off by default in wu-ftpd alisajjad Linux - Networking 0 07-30-2003 06:34 AM
wuftp passive mode and ipchains bart Linux - Networking 5 03-10-2003 07:36 AM
kermit in passive mode? bbeers Linux - Software 1 08-23-2002 07:53 AM


All times are GMT -5. The time now is 11:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration