LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2007, 09:27 PM   #1
M$ISBS
Member
 
Registered: Aug 2003
Posts: 820

Rep: Reputation: 30
Need help with Printer


Samsung ML-1210, Slack 11, KDE 3.5
Was working before I updated slack to 11.
I tried to setup the printer using localhost:631 in a browser, it seemed like it worked but when I try a test page the printer starts up but nothing prints but cups history shows that both test pages printed.
It will only try to print as root.
When I try to enter my username and password at the cups dialog box in a browser to add or modify the printer, the dialog box just flashes and reappears with both fields blank.
How do I check to make sure the users have permisssions to print?

Thanks.

Last edited by M$ISBS; 04-29-2007 at 09:35 PM.
 
Old 04-30-2007, 02:37 PM   #2
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
I couldn't print with cups until I'd specified my printer as default, even though it's the only printer I have. I don't know if that helps.
 
Old 04-30-2007, 02:58 PM   #3
north49er
Member
 
Registered: Apr 2003
Location: 60.47'N lat
Distribution: fedora 15 x86_64
Posts: 156

Rep: Reputation: 18
"Was working before I updated slack to 11." I'm assuming you compiled slack 11 against your earlier version, and you're using cups. As root, try "chmod a+x /etc/rc.d/rc.cups", then "cupsd". Then try your localhost routine.
 
Old 05-01-2007, 11:02 PM   #4
M$ISBS
Member
 
Registered: Aug 2003
Posts: 820

Original Poster
Rep: Reputation: 30
I got it to work by DLing the driver and then screwing around until it worked...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Printer Problem: Brother Laser Printer drops the first one or two centimeters merlinsenger Linux - Newbie 2 05-24-2008 07:13 AM
CUPS Network Printer/ server indicator blinks no printer output wine Linux - Networking 8 03-18-2006 11:20 PM
keeping printer on at bootup keeps printer from printing (some printer modules loaded TheOneAndOnlySM Slackware 1 10-17-2003 08:39 PM
setup printer on client machine(slackware 8) to server (slackware7) network printer changwoo Slackware 9 05-02-2003 06:37 PM


All times are GMT -5. The time now is 06:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration