LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-04-2003, 09:20 AM   #1
SynnerST
LQ Newbie
 
Registered: Sep 2003
Location: United States - North Carolina
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
Need help rebooting


Greetings,

I am still fairly new to linux so this is probably a very newbie-ish question, I have searched the forums, but can't find an answer to my question =/

I installed Slackware 9.1 and everything works great as root.
I then made a new regular user. When I try to log out of X I do not get the "Reboot" option and when at the prompt neither reboot nor shutdown -r now will work. I have to su back to root to shut the system down.

And guidance on how to enable shutdown / reboot for a normal user?

Thanks in advance,
SynnerST
 
Old 10-04-2003, 10:38 AM   #2
WingNut
Member
 
Registered: Jun 2002
Location: Texas
Distribution: Slackware 10.1
Posts: 105

Rep: Reputation: 15
I hope this will be at least a little help. I'm away from Slack box so I can't poke around to give detailed steps. Look at the forums for graphical logon with slackware, or using kdm with slack. Using kdm as a logon manager gives you those options by default. however this means you will boot straight into gui mode. to avoid it simply type the name of your kernel followed by a 3 at the lilo prompt. For me it looks like this:

phobos 3

Or as root you can simply add permissions to your user. I beleive you will need to add your user to the operator group or change permisisons on shutdown.

search the slackware forum for the phrase "user shutdown" and you should get a good bit of help. I hope I, at the very least, pointed you in the right direction.
 
Old 10-04-2003, 10:47 AM   #3
SynnerST
LQ Newbie
 
Registered: Sep 2003
Location: United States - North Carolina
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
I changed initdefault in /etc/inittab from a 3 to a 4 an now X boots automaticaly. The Window Manager that I chose was Gnome.

I will do some more looking around on these boards and see if I can come up with a way to change the permisions then.

Thanks for your help =)
 
Old 10-04-2003, 11:15 AM   #4
SynnerST
LQ Newbie
 
Registered: Sep 2003
Location: United States - North Carolina
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
Problem Solved (sort of)

In Gnome:
>Applications
>System Tools
>Login Screen Setup

On the fourth tab "Security" click the "Show Actions Menu" button. This will enable a button on the log in screen which will allow any user to shutdown / reboot the machine =)

I figured I would post my solution should anyone later search the forums for the same problem.

SynnerST
 
Old 10-29-2003, 09:43 AM   #5
acjt
Member
 
Registered: Dec 2002
Location: Australia
Distribution: Gentoo
Posts: 161

Rep: Reputation: 30
Thanks, I hope your solution works because I'm going to try it when I get home.
My Gentoo installed GDM had the menuitems, but slack don't, so hope this work.
 
Old 10-29-2003, 10:21 AM   #6
Noryungi
Member
 
Registered: Jul 2003
Location: --> X <-- You are here.
Distribution: Slackware
Posts: 262

Rep: Reputation: 30
Also, try putting your "normal" user in /etc/sudoers and give him the right to use "/sbin/halt" or "/sbin/reboot".

Hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebooting spuppett Linux - Newbie 3 04-11-2004 04:21 PM
rebooting into a different OS apberzerk Linux - General 2 02-04-2004 07:42 AM
Self Rebooting System hubergeek Linux - General 2 06-11-2003 08:36 PM
Shutdown -h Rebooting shusseina Linux - Software 5 05-25-2003 05:13 AM
rebooting to a cd lot2learn Linux - Software 6 07-19-2001 09:29 AM


All times are GMT -5. The time now is 01:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration