LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-24-2003, 11:19 AM   #1
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Rep: Reputation: 30
need help real bad getting my cdrom and floppy to work


I need to know the exact line that needs to be in my fstab for both cdrom and floppy.
I am running mandrake 7.2 and want both floppy and my cdrom to be acessed by anyone logged on to the computor.
Also do I need to change anything in my mtab or anywhere else.
 
Old 09-24-2003, 12:26 PM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
/dev/fd0 /mnt/floppy auto user 0 0
#This is for Secondary Master
/dev/hdc /mnt/cdrom iso9660 user,ro 0 0
#This is for Secondary Slave
/dev/hdd /mnt/cdrom iso9660 user,ro 0 0
 
Old 09-24-2003, 09:56 PM   #3
lyle_s
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 52
No, don't change anything in /etc/mtab (under normal circumstances).

Lyle
 
Old 09-25-2003, 12:54 AM   #4
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
No did not help.
But I am getting this message now.

checking base configeration
checking kernals modules
mounting local volumes
?/dev/hdd is not mounted
Executing /bin/mount -t iso9660 -o noexec,nodev,nousid,rw,/dev/hdd/mnt/cdrom
mount wrong fs type,bad option,bad superblock on /dev/hdd
or too many file systems
return 32
?/dev/fdo is not mounted
Executing /bin/mount -t auto -o noexec,nodev,nousid,rw/dev/fdo/mnt/floppy
mount /dev/fdo is not a valid block device
return 32

when I check bin mount there is one word Elf


Does help anyone find out whats going on.
I am going to rearange my drives and reload
When I first loaded they where mounting so I need to get them back to that point and try something else.
Please somebody explain this to me.
 
Old 09-25-2003, 01:46 AM   #5
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
Ok! I am back to having no acess to the mounted cdrom. It says i don't have prmissions to that drive.
Since i was not able to do this right before what should I do now.
 
Old 09-25-2003, 09:32 AM   #6
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Add a "noauto" option next to "user" and "user,ro". This keeps them from mounting on startup. Removable drives shouldn't mount on startup, since there usually isn't anything in them then. Either comment out one of the cdrom lines (using #), or change the /mnt/cdrom on one of them to something else (such as /mnt/cdrom1). When you change this, make sure the folder exists (for the previous example, make sure /mnt/cdrom1 exists). Then test all three using these commands:

mount /dev/fd0
ls /mnt/floppy
mount /dev/hdc
ls /mnt/cdrom
mount /dev/hdd
ls /mnt/cdrom1
 
Old 09-25-2003, 11:39 AM   #7
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
Ok I am making progress. heres what my fstab looks like.
/dev/hda1 / ext2 defaults 1 1
/dev/hda6 /home ext2 defaults 1 2
/dev/hda5 swap swap defaults 0 0
/dev/hdc /mnt/cdrom iso9660 user,owner,exec,dev,suid,rw,noauto 0 0
/dev/fdo /mnt/floppy noauto,user,rw 0 0

I can read my boot disk in my floppy drive. So my floppy is at least mounting and I can finaly access it. I have not tried a dos disk yet.

when I click on my cd drive it goes to /mnt/cdrom but does not show any files. I am using the install disk from the boxed mandrake set so it should read it set at iso9660, Right?
any other suggestion on the cdrom.
would it be better to mount it with the -a option
 
Old 09-25-2003, 02:27 PM   #8
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
nothing I seem to do gets me into my cdrom. If I change anything in the cdrom section it quits mounting both the cdrom and the floppy. heres how it is set to read the floppy.

/dev/hda1 /ext2 defaults 1 1
none/dev/pts devpts mode=0620 0 0
mnt/cdrom /mnt/cdrom supermount fs=iso9660,dev=dev/cdrom 0 0
/dev/fd0 /mnt/floppy auto user,noexec,nodev,nosuid,rw 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

When I wrote the line for my floppy I wrote

/dev/fd0 /mnt/floppy auto,user 0 0

after I booted it it changed to what you see.

Does anybody out there understand whats going on.
 
Old 09-26-2003, 10:55 PM   #9
matt3333
Member
 
Registered: Dec 2002
Location: Winnipeg, Manitoba, Canada
Distribution: Slackware
Posts: 371

Rep: Reputation: 30
Ya i think u probably need to save the file and u need to be root in order to save.........

Matt3333
 
Old 09-27-2003, 12:33 AM   #10
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
I do logon as root when I make the changes and I do save the changes If I check right then I can see The changes I made but when I reboot it goes back to what it was.
 
Old 09-27-2003, 01:04 AM   #11
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,839

Rep: Reputation: 48
Welcome to Linux dvdljns,
Understanding mount and editing system files is a basic hurdle for new users.
With Mandrake you could also be having a problem with the Supermount program.
http://homepage.ntlworld.com/alex.ba...ke-faq.html#4e
 
Old 09-30-2003, 01:22 AM   #12
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
Thumbs up

Thank you for the information. I may still need it I solved my problam a diferant way although your info may still apply. I had disc 1 and disc 4 of suse 8.2 so I wiped the hardrive and loaded suse. I had never tried that because I thought I needed all the discs. It actaully did a pretty good install of suse. It sort of solved the cd problam it put two icons on my desktop one says cdrom the other says cdrw. if I click the cdrom icon I get an error, but if I click the cdrw it shows everything in my cdrom.I am not sure why I need two but if the os sets it up that way untill I understand it better I want to keep it that way. It is strange. each version of linux has something I like better. I did not have xwindows with slackware but it was the easiest to get around in using command line and the only version that setup my cdrom right.mandrake setup xwindows better an gave me better options from the desktop if I could of got the cd working I would have stopped there.If I ever get yast working right on this I may actaully have a good system. Of course the goal here is learning lynux enough to take the things I like from each distro and combining them to make the costum machine that I want. So I will be loading mandrake again at some point and the article you turned me on to is just the stuff I need to read. Thanks!
 
Old 09-30-2003, 04:43 AM   #13
The_DoubleU
LQ Newbie
 
Registered: Sep 2003
Location: Dublin
Distribution: Slackware 9.1
Posts: 11

Rep: Reputation: 0
Maybe good to know for the next time.
If you make a change to fstab and have saved the changes
you have to unmount and mount the drive/cdrom again
Then the changes take affect.

Hope this helps for the next time.
 
Old 09-30-2003, 08:39 PM   #14
dvdljns
Member
 
Registered: Sep 2003
Posts: 208

Original Poster
Rep: Reputation: 30
Remember I have been a windows user since win 1.02 every single time I make a system change I reboot. It's not evan worth the efort to learn to break that habit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 12:37 PM
I messed up real bad. gayxdanny Fedora 7 02-25-2006 04:08 PM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
mount: wrong fs type, bad option, bad superblock...(cdrom,dvd and floppy) SpItoS Mandriva 14 11-12-2004 03:27 PM
wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file sy TheCyberDude Linux - Software 1 02-11-2002 01:44 PM


All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration