LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-02-2006, 04:07 AM   #1
netsoft2005
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Rep: Reputation: 0
Need Help for FreeNX installation on Slacware 10.2


I have installed Slackware 10.2. I want to view its desktop on Windows Xp system. I have download FreeNX pkg from slackware website. Can someone guide me how to install this pkg.
Thanks in advance
 
Old 03-02-2006, 05:26 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
su -

installpkg </path/to/package/packagename.tgz>


do you need some help to configure or just install?
 
Old 03-02-2006, 06:35 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,191

Rep: Reputation: Disabled
I am assuming you're referring to my FreeNX packages?
When you install the nx and freenx Slackware packages using installpkg your NX server is already functional. You could check the file
Code:
/etc/nxserver/node.conf.sample
and rename it to
Code:
/etc/nxserver/node.conf
if you need to change any of the default values.
There is no startup script or anything else to start for the FreeNX server to work. Just run a NX-client on your workstation and connect it to your new FreeNX server's IP address.

By the way, even though the packages are stored in a directory called "pkg/10.1/" because they were built on Slackware 10.1, they should work on Slackware 10.2 as well.

You do need of course to download a client for NX from the NoMachine website - there's not much you can do with only a server :-)

Eric
 
Old 03-02-2006, 08:11 AM   #4
slackamp
Member
 
Registered: Dec 2005
Distribution: slackware-current
Posts: 86

Rep: Reputation: 16
Hey Alien Bob, i just installed your packages, for some reason it doesn't want to work for me. here is the log

NX> 203 NXSSH running with pid: 3372
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 192.168.7.3 on port: 22
NX> 202 Authenticating user: nx
NX> 204 Authentication failed.


/var/log/messages
Mar 2 09:05:47 slack sshd[7898]: Failed none for invalid user nx from 192.168.7.25 port 1402 ssh2


Not really sure what the authentication process is but it seems that any user i use in nxclient it passes the user nx to login anyway.

# nxsetup --gid 2000 --install --clean --purge
# passwd -u nx
# nxserver --adduser localuser

if you can shed some light, that would be great.
 
Old 03-02-2006, 08:17 AM   #5
netsoft2005
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
thanks Eric
I downloaded your build pkgs and installed nx pkg first and then freenx
but freenx didn't and prints a warning message
Freenx need "netcat" to install
Freenx need "expect" to install

What should i do to solve this ?
 
Old 03-02-2006, 08:58 AM   #6
netsoft2005
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Now after installing the netcat and expect, I connect my winxp machine having nxclient for win. After authorizing, i get message "Server not installed or NX access disabled" In detail tab:
NX> 148 Server capacity: not reached for user: nx
NX> 105 startsession --session="nomachine" --type="unix-kde" --cache="8M" --images="32M" --cookie="******" --link="lan" --kbtype="pc102/en_US" --nodelay="1" --backingstore="when_requested" --geometry="fullscreen" --media="0" --agent_server="" --agent_user="" agent_password="******"" --screeninfo="800x600x32+render"

Permission denied (publickey,password,keyboard-interactive).
Killed by signal 15.

What should i do ?

Last edited by netsoft2005; 03-02-2006 at 09:01 AM.
 
Old 03-02-2006, 10:33 AM   #7
netsoft2005
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
thanks Eric i have successfully installed and running it
Nice Work!
 
Old 03-02-2006, 11:01 AM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,191

Rep: Reputation: Disabled
So, could you please tell us all what initially went wrong and what you had to fix or configure? Or was it something missing in the package?

Cheers, Eric
 
Old 03-03-2006, 01:07 AM   #9
netsoft2005
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Solution

netcat (nc 1.5??.tgz)
execpt (expect 1.???.tgz)

all are in Slackware
I installed it first and then freenx
then i connect from winxp machine it get the above error
i add another user (group: wheel) then connect with it.
Problem Solved

Last edited by netsoft2005; 03-06-2006 at 08:00 AM.
 
Old 03-06-2006, 09:23 AM   #10
netsoft2005
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
default user nx problem

Eric nx user doesn't login
message

Server not installed or NX access disabled

detail:

NX> 203 NXSSH running with pid: 2456
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 192.168.100.2 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: nx
NX> 102 Password:
NX> 103 Welcome to: stxbox user: nx
NX> 105 listsession --user="nx" --status="suspended,running" --geometry="800x600x32+render" --type="unix-default"
NX> 127 Sessions list of user 'nx' for reconnect:

Display Type Session ID Options Depth Screen Status Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: nx
NX> 105 startsession --session="STX" --type="unix-default" --cache="8M" --images="32M" --cookie="******" --link="lan" --virtualdesktop="1" --kbtype="pc102/en_US" --nodelay="1" --backingstore="never" --geometry="fullscreen" --media="0" --agent_server="" --agent_user="" agent_password="******"" --screeninfo="800x566x32+render"

Permission denied (publickey,password,keyboard-interactive).
Killed by signal 15.


but working for any other user except nx
What you think about this ?
 
Old 03-09-2006, 04:16 AM   #11
wootletootle
Member
 
Registered: Jul 2002
Location: New Zealand
Distribution: slackware
Posts: 81

Rep: Reputation: 15
I had a similar error: "authentication failed" when trying to access the
NX server from a remote client. The fix was to edit the sshd_config file
in /etc/ssh/ and ensure that the line

PubkeyAuthentication yes

is uncommented. Then everything works.
 
Old 06-23-2006, 06:16 AM   #12
DynamiteD
LQ Newbie
 
Registered: Oct 2004
Location: 127.0.0.1
Distribution: Slackware baby!
Posts: 6

Rep: Reputation: 0
Hey guys,

Didn't really want to create a completely new FreeNX thread on here as I'm sure that this one is okay Sorry to the OP though if I'm hijacking

@Alien Bob: I've used your slackware packages and everything works correctly up until the point that it says "establishing X server...." at which point nothing else happens. The little window eventually closes but the connection stays open.

I've tail'd /var/log/messages as well as /var/log/nxserver.log (which I've set in /etc/nxserver/node.conf to level 6 logging (debugging)) to see what is going on, but nowt

Could you give me some advice please?

Cheers
Dino
 
Old 08-29-2006, 03:20 PM   #13
H@MBONE
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
@DynamiteD

Same problem here.

From an url I'm not allowed to post:

Solutions for NX Clients versions 2.0.0 and FreeNX 0.4.x and 0.5.0.

If you have problem connecting with new NX Client ver. 2.0.0, there are 2 patch, which working for me with NX Client ver. 2.0.0-93:

'fake cookie authentication problem':

Some new clients uses 1.4.0 as proto version. You have to make sure that 'fake cookie authentication' is working on the server. Look at nxnode and search for that string in 'node_startsession()' function and edit it.

For freenx 0.4.x nxnode in function 'node_startsession()'

if [ "$ENABLE_1_5_0_BACKEND" = "1" -a "$clientproto" = "1.5.0" ] || [ "$ENABLE_1_5_0_BACKEND" = "1" -a "$clientproto" = "1.4.0" ]
then
# enable fake cookie authentication
cookie=$proxy_cookie
fi

For freenx 0.5.0 nxnode in function 'node_startsession()'

if [ "$clientproto" = "1.5.0" ] || [ "$clientproto" = "1.4.0" ]
then
# enable fake cookie authentication
cookie=$proxy_cookie
fi

Pre 1.5 clients will face trouble in this case, though - but works for me (no users with old clients). As I see in comunnication with client ver. 2.0.0-93, it use 1.5.0 proto version, so this is for older 2.0.0 clients.


NOTE: nxnode is in /usr/bin

--h@mbone

Last edited by H@MBONE; 08-29-2006 at 03:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slacware 9.0 problems... Schizo265 Slackware 14 11-05-2007 11:11 PM
Plesk for Slacware 9.1 Dakkar Linux - Software 1 06-08-2004 01:48 PM
Slacware installation for newbie pcellvis Slackware - Installation 3 05-13-2004 11:09 PM
slacware install CrazyTux Slackware 3 03-25-2003 10:10 PM
Slacware 8 and DSL rayflynn Linux - Software 5 05-02-2002 06:58 PM


All times are GMT -5. The time now is 08:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration