LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-05-2006, 10:04 AM   #1
dgeenens
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Rep: Reputation: 0
need help changing my keyboard layout


I've installed slackware 10.2 not so long ago. I've got a belgian keyboard. I can type everything in azerty, as it is supposed to be, but the keys that require combinations with the "alt" key don't work. I've tried modifying my keyboard layout in xorg.conf, but even if i put it on "us", it stayed azerty. I'm using xfce as my window manager. I think xfce uses the keyboard layout from the system instead of the one defined in xorg.conf. I would appreciate it if someone could help me with this.
 
Old 01-05-2006, 10:42 AM   #2
piete
Member
 
Registered: Apr 2005
Location: Havant, Hampshire, UK
Distribution: Slamd64, Slackware, PS2Linux
Posts: 465

Rep: Reputation: 44
I'm fairly sure xfce doesn't use the system keyboard layout, since it is an X app. I last gave this advice to a friend, so replace "uk" with your desired locale.

As borrowed from this thread: http://www.linuxquestions.org/questions/history/331612

"To load the UK keys by default in the console, edit /etc/rc.d/rc.keymap and change the keymap from *us.map* to *uk.map*."

From the same thread as above:

To change the keyboard map in X, you need to edit the file /etc/X11/xorg.conf

[code snippet from xorg.conf]
#
# Option "XkbOptions" "ctrl:swapcaps"


# These are the default XKB settings for X.Org
#
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc101"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

Option "XkbLayout" "uk" # <-- this is the important bit
[/code]

You may want to look at /var/log/xorg.0.log to make sure that you're passing the correct value to XkbLayout. You might find that although X starts (since an incorrect or invalid XkbLayout isn't a fatal error) you're giving it an unrecognised option or similar.

Good luck!
- Piete.
 
Old 01-05-2006, 12:17 PM   #3
dgeenens
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Original Poster
Rep: Reputation: 0
When I use the command

setxkbmap -layout be

my keyboard get set correctly. The strangest thing is that I can set my keyboard on a completely different layout eg us, which I thought was qwerty, and still get an azerty keyboard.

My xorg.conf settings:

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
Option "XkbVariant" "be"
 
Old 01-05-2006, 12:22 PM   #4
dgeenens
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Original Poster
Rep: Reputation: 0
Another snippet from /var/log/Xorg.0.log

(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard1: XkbModel: "pc105"
(**) Option "XkbLayout" "be"
(**) Keyboard1: XkbLayout: "be"
(**) Option "XkbVariant" "be"
(**) Keyboard1: XkbVariant: "be"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(--) Mouse1: PnP-detected protocol: "ImPS/2"
(II) Mouse1: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!

For me, everything seems allright, but since I'm new to slackware and have got only one year experience with Fedora Core it could be that there is something wrong with it
 
Old 01-05-2006, 01:28 PM   #5
dgeenens
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Original Poster
Rep: Reputation: 0
I changed this:

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
Option "XkbVariant" "be"

to this:

Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"

in /etc/X11/xorg.conf and everything is working fine, so I am glad to be able to say that this topic is closed.

Thanks for all the help.

Didier
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the keyboard Layout from UK to US (Debian) critical Linux - Hardware 7 02-16-2005 04:35 PM
Changing keyboard layout SAC82 Linux - Software 5 10-18-2004 02:39 AM
crash when changing language(keyboard layout) atkbd.c cuk Mandriva 0 06-20-2004 05:16 AM
Changing my keyboard layout (language) globally by command (shell) Santorres Linux - Newbie 1 05-17-2004 03:04 PM
Changing keyboard layout? Eits0 Linux - General 2 08-13-2002 07:57 PM


All times are GMT -5. The time now is 06:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration