LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   NDISwrapper works for Slackware 13.0 x86 but not Slackware 13.0 x64 - Belkin F5D8053 (http://www.linuxquestions.org/questions/slackware-14/ndiswrapper-works-for-slackware-13-0-x86-but-not-slackware-13-0-x64-belkin-f5d8053-782155/)

thewizkid 01-14-2010 06:18 AM

NDISwrapper works for Slackware 13.0 x86 but not Slackware 13.0 x64 - Belkin F5D8053
 
I have tried using NDISwrapper for slackware64 but it just doesn't seem to work ( I have tried with both the 32 and 64 bit drivers ). I am using Belkin F5D8053 v3.

The odd part is...it works perfectly fine with Slackware 13.0 x86 (I am currently using it).

I want to use the x86_64 version of Slack 13 but if I can't set up my wireless...

With the 32 bit Slack I can install the driver and use "#ndiswrapper -l" to view the status of the driver and hardware. Install/present. lsusb shows my Belkin adapter and lsmod shows the ndiswrapper module ( obviously ). After installing the driver and loading the module, I can immediately use iwconfig to view and configure my wireless adapter.

With Slackware64, everything seems to work find. I install the 64 bit driver that comes with Belkin. ndiswrapper -l shows that the driver and hardware are in place. I can load the ndiswrapper module without a problem and it shows up in lsmod. The difference is that the wlan0 interface does not make an appearance at this point, as it does with Slack 13 x32.

wlan0 is simply not there so I can't configure my wireless interface. What is even stranger...I once installed Slackware 13 x86_64 in VMware and connected my wireless adapter to it directly. It worked fine within VMware.

How can I make the wlan0 interface show up in Slack 13 x86_64, since the driver is installed, device connected, and module is loaded?

BTW: there were no make errors with NDIS, I am sure it is working fine on both installs.


All times are GMT -5. The time now is 02:14 PM.