LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ndiswrapper; or specifically dwa142 *without* multilib, for 64bit slack (http://www.linuxquestions.org/questions/slackware-14/ndiswrapper%3B-or-specifically-dwa142-%2Awithout%2A-multilib-for-64bit-slack-4175466637/)

mrclisdue 06-19-2013 12:45 PM

ndiswrapper; or specifically dwa142 *without* multilib, for 64bit slack
 
hi all,

Subject pretty well sums it up: I can't find or build ndiswrapper for slack64, nor am I having any success building using linuxant's driver loader, the latest error being:

Code:

/usr/lib/driverloader/modules/GPL/oscompat.h:121:24: fatal error: asm/system.h:
This was just the latest of several errors, which I've been eliminating one-by-one....

As an aside, I've never used lxc, but this looks like an ideal situation. Any hints?

cheers,

ml4711 06-19-2013 01:49 PM

You find it on http://slackbuilds.org

ndiswrapper-kernel
ndiswrapper-utils

mrclisdue 06-19-2013 02:18 PM

I've tried sbopkg in the past, and re-tried on 2 boxes, here's where I get the farthest:

Quote:

In file included from /tmp/SBo/ndiswrapper-1.58rc1/driver/crt.c:16:0:
/tmp/SBo/ndiswrapper-1.58rc1/driver/ntoskernel.h: In function 'INIT_WORK':
/tmp/SBo/ndiswrapper-1.58rc1/driver/ntoskernel.h:215:48: error: macro "INIT_WORK" passed 3 arguments, but takes just 2
/tmp/SBo/ndiswrapper-1.58rc1/driver/ntoskernel.h:215:2: warning: statement with no effect [-Wunused-value]
make[2]: *** [/tmp/SBo/ndiswrapper-1.58rc1/driver/crt.o] Error 1
make[1]: *** [_module_/tmp/SBo/ndiswrapper-1.58rc1/driver] Error 2
make[1]: Leaving directory `/usr/src/linux-3.7.1'
make: *** [modules] Error 2
make: Leaving directory `/tmp/SBo/ndiswrapper-1.58rc1/driver'
cheers,

mike_booth76 06-19-2013 05:34 PM

THats a problem with ndiswrapper.

There are patches around.. If you can't fix it let me know and I'll send you my working copy



Mike

mrclisdue 06-19-2013 05:52 PM

Quote:

Originally Posted by mike_booth76 (Post 4975040)
THats a problem with ndiswrapper.

There are patches around.. If you can't fix it let me know and I'll send you my working copy



Mike

Whilst I'd *like* to play around forever, I'd really rather have a working copy - the kernel I'd like it compiled against is -current's 3.9.5, so if that's possible, could you drop it somewhere and pm me or post here...or, if you'd prefer, my nic at gmail.com would be kewl.

Thanks in advance, and virtual beers all round.

cheers,

mrclisdue 06-20-2013 06:15 AM

I received a tarball from Mike Booth76, compiled and worked like a charm.

I love this forum.

cheers,


All times are GMT -5. The time now is 09:21 AM.