LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Nagios CGI not executing (http://www.linuxquestions.org/questions/slackware-14/nagios-cgi-not-executing-4175471337/)

metalaarif 07-29-2013 10:47 AM

Nagios CGI not executing
 
Hi guys,

I have installed nagios in slackware using slackbuilds. I have done everythings as the README file states. I installed nagios-plugins and checked if my HTTP was running or not using following commad
Quote:

bash-4.2# /usr/libexec/nagios/check_http -H localhost
HTTP OK: HTTP/1.1 200 OK - 299 bytes in 0.016 second response time |time=0.016028s;;;0.000000 size=299B;;;0
My problem is that whenever I log in to my browser http://localhost/nagios And if I try to access "Tactical Overview or Map", it prompts me to download and I know that the CGI script doesn't seem to be executing.

I checked my file which is located in "/etc/httpd/extra/nagios.conf", it looks like this
Quote:

ScriptAlias /nagios/cgi-bin "/usr/sbin/nagios"
<Directory "/usr/sbin/nagios">
Options ExecCGI
AllowOverride AuthConfig
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /etc/nagios/htpasswd.users
Require valid-user
</Directory>
Alias /nagios "/srv/httpd/htdocs/nagios"
<Directory "/srv/httpd/htdocs/nagios">
Options FollowSymLinks
AllowOverride AuthConfig
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /etc/nagios/htpasswd.users
Require valid-user
</Directory>
I have done "Include /etc/httpd/extra/nagios.conf" "/etc/httpd/httpd.conf" but doesn't seem to work.

I even gave 777 to "/usr/sbin/nagios" directory where .cgi scripts are located but no matter what i do, it doesn't work

Any Idea Guys??

kikinovak 07-29-2013 01:11 PM

Check your /etc/httpd/httpd.conf if mod_cgi is uncommented.

Code:

LoadModule cgi_module lib/httpd/modules/mod_cgi.so
Cheers,

Niki

metalaarif 07-30-2013 03:00 AM

Thanks so much for your help, I have been trying to solve this problem to no avail but finally, I have managed to cheers.

This thread is SOLVED now.


All times are GMT -5. The time now is 06:44 AM.