LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-04-2003, 02:23 PM   #61
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31

Well this is one long thread for what would have seemed not that tough a question to begin with, but apparently there is more here than meets the eye. It has been a bit difficult to follow through from the beginning, but let me see if I have it straight.

Your /etc/fstab file is as follows:

/dev/hda3 swap swap defaults 0 0
/dev/hda2 / ext3 defaults 1 1
/dev/hda1 /mnt/win ntfs ro,umask=0222 0 0
/dev/scd0 /mnt/cdrw iso9660 noauto,owner,ro,user 0 0
/dev/hdc /mnt/cdrom iso9660 noauto,owner,ro,user 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

In lilo.conf, you have this:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="hdd=ide-scsi"
boot = /dev/hda
#compact # faster, but won't work on all systems.
prompt

Your DVD-ROM is set up as the master device on your second IDE channel, making it /dev/hdc and your CD-RW is set up as the slave device on the same channel making it /dev/hdd.

Currently when you give the command

mount /mnt/cdrom

with a known good disk in your DVD-ROM, it doesn't mount correctly. What message does it give?

Also, When you give the command

mount /mnt/cdrw

with a known good disk in your CD-RW, it doesn't mount correctly. I would also like to know what message you get on that attempt.

I also would not mind seeing the result of

cdrecord -scanbus

as root with neither device mounted. You should also be aware that you should not have your CD-RW drive mounted while you are trying to burn to it.

Do you run Windows as well and are the drives recognized correctly in it? If not, have you checked to make sure the cabling is secure for both drives? I am looking here for a reason your results would continue to change during times when you are apparently changing nothing about your configuration.
 
Old 07-04-2003, 09:08 PM   #62
0oBelialo0
LQ Newbie
 
Registered: Jul 2003
Location: Canberra, Australia
Distribution: Slack 9.0 & Debian 3.0
Posts: 14

Rep: Reputation: 0
Hey, something just ocurred to me. If it's not already, try putting the CDRW on it's own IDE channel. I couldn't get scsi emulation working when I was sharing the channel with an IDE HDD (which is a shit, because it means I can only have 3 IDE devides connected at the one time)

Ben
 
Old 07-04-2003, 10:56 PM   #63
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
I only have 2 slots. One for HDDs and one for CDs. Also, all that stuff posted by the guy on top is irrelevent. Also, I am dual booting with XP Pro, everything works great there.

When Slackware boots up I see this

HDCVD ROM (and name of my DVD rom drive)
HDD:CDRW (name of my CDRW drive)

So I know it detects them.
 
Old 07-04-2003, 11:00 PM   #64
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
I've never tried to get one device on an IDE channel to be a SCSI device and not the other, so I as far as I know this could be the problem. The easiest solution in this case would be to add an option to lilo to boot so that both of your optical devices are recognized as SCSI. I do that with all of my optical drives anyway, whether they are recorders or not.

If you decide to try this change your append line in lilo.conf like so:

append="hdc=ide-scsi hdd=ide-scsi"

Also change your fstab file to match this:

Code:
/dev/hda3    swap        swap     defaults             0  0
/dev/hda2    /           ext3     defaults             1  1
/dev/hda1    /mnt/win    ntfs     ro,umask=0222        0  0
/dev/scd0    /mnt/cdrom  iso9660  noauto,owner,ro,user 0  0
/dev/scd1    /mnt/cdrw   iso9660  noauto,owner,ro,user 0  0
/dev/fd0     /mnt/floppy auto     noauto,owner         0  0
devpts       /dev/pts    devpts   gid=5,mode=620       0  0
proc         /proc       proc     defaults             0  0
since your DVD-ROM would become /dev/scd0 and your CD-RW would then become /dev/scd1.
 
Old 07-04-2003, 11:03 PM   #65
0oBelialo0
LQ Newbie
 
Registered: Jul 2003
Location: Canberra, Australia
Distribution: Slack 9.0 & Debian 3.0
Posts: 14

Rep: Reputation: 0
Well, you're obviously not going to try that, so why don't you try setting your DVD up with scsi emulation too? I think slack has a problem with there being a scsi (emulated) and IDE device on the same ide channel.

Ben
 
Old 07-04-2003, 11:32 PM   #66
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
My DVD drive works now... Its just the CDRW. Also, I think that is an out of date fstab your posting. My current file is:

/dev/hda3 swap swap defaults 0 0
/dev/hda2 / ext3 defaults 1 1
/dev/hda1 /mnt/win ntfs ro,umask=0222 0 0
/dev/sr0 /mnt/cdrw iso9660 noauto,owner,ro,user 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro,user 0
0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
 
Old 07-05-2003, 01:28 PM   #67
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
Well, the only differences in the fstab you have now from what you had the last time you posted it are that /dev/hdc has been changed to /dev/cdrom, and /dev/scd0 has been changed to /dev/sr0. Since /dev/cdrom is almost certainly a symbolic link to /dev/hdc, that change should not make any difference. Also, either /dev/scd0 or /dev/sr0 really should work for your SCSI emulated IDE device, so that should not matter either (although if you find that one doesn't work, it doesn't hurt to try the other, but you have already done this).

OoBelialoO could be correct about Slackware not handling one device that is native IDE and one device that is IDE-SCSI on the same channel. What he suggested in his last post and what I suggested are the exact same thing. I just detailed the changes you would have to make; they are not very big. If you want to try it, and you want it to be more in line with what you have changed your fstab file to look like, then just change, in your fstab file, the /dev/sr0 to /dev/sr1 and leave the /dev/cdrom line alone, but change, in your device directory, the symbolic link /dev/cdrom to point to /dev/sr0 instead of /dev/hdc (if you try this, you should make this change to the symbolic link in any case). You would also, of course, still need to make the change I posted to your lilo.conf file and run lilo again.

If you are afraid that these changes will just cause more problems, then just save copies your current fstab file and lilo.conf file before you try it and copy them back if things don't work out. Personally I think it makes things easier to deal with if you just consistently make all of your optical drives IDE-SCSI instead of trying to mix and match.
 
Old 07-05-2003, 10:15 PM   #68
0oBelialo0
LQ Newbie
 
Registered: Jul 2003
Location: Canberra, Australia
Distribution: Slack 9.0 & Debian 3.0
Posts: 14

Rep: Reputation: 0
Out of interest, can you set up scsi emulation for a hard drive? I (used to) run 3 HDDs and one CDRW.. but as I mentioned before I can't get the RW to work when it's on the same channel as a "real" IDE devide.

(oh, if you look at the times for our last posts, they're 3 minutes apart. I was composing mine when youposted yours... so I wasn't just repeating what you said )

Ben
 
Old 07-22-2003, 10:08 PM   #69
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
Sorry I didn't reply to this last question sooner, but here is my best guess. I am fairly certain that you cannot set up SCSI emulation for a hard drive with ide-scsi. The control protocols for IDE hard drives and IDE CD-ROMS are really quite different. IDE CD-ROMS are ATAPI devices rather than regular ATA devices. ATAPI stands for AT Attachment Packet Interface. The packet interface that these devices use is based on simulating a SCSI interface over an ATA interface, so using them to emulate a SCSI device is not much of a stretch. Hard drives, however, are not ATAPI devices but ATA devices. I believe the ide-scsi module is based on ATAPI protocols and won't work with a regular ATA device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
n00b boot problem Joe Giliberti Slackware 5 07-10-2005 02:02 PM
n00b shutdown problem TomalakBORG Slackware 4 02-06-2005 12:30 PM
n00b with a boot problem Matty2Jay Linux - Hardware 1 12-28-2004 06:28 AM
n00b problem cdols Red Hat 3 03-31-2004 02:14 PM
RedHat n00b problem ixion Red Hat 1 01-16-2004 01:57 PM


All times are GMT -5. The time now is 07:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration