LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2003, 02:59 PM   #16
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30

/dev/scd0 refers to a SCSI device. You have to force SCSI emulation (hence that append statement in the lilo.conf) to get the burner to work, that is why you need the CR-RW drive pointing to scd0.
 
Old 07-03-2003, 03:00 PM   #17
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
Forget it. I just fixed it. I changed the location of my cdrw from /dev/cdrom to /dev/hdd, and I can mount it. Now to test writing capabilities.
 
Old 07-03-2003, 03:03 PM   #18
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
OK, cdrecorder (in dropline gnome) doesnt see my cdrw as being a cdrw drive. My only choices when burning is to burn to a .iso.
 
Old 07-03-2003, 03:05 PM   #19
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
See my post at the top of this page.
 
Old 07-03-2003, 03:07 PM   #20
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
Ahhhhhhhhhhhhhhhhhhhhhhhhhhhh
 
Old 07-03-2003, 03:11 PM   #21
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
But what do I change my DVD drive to? I changed to hdc but I get an error.
 
Old 07-03-2003, 03:12 PM   #22
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
Are you sure that the DVD drive is your secondary master? And you did use /dev/hdc, not just hdc, right? (just wanted to clarify)
 
Old 07-03-2003, 03:13 PM   #23
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
woops never mind didnt see that? Sorry.
 
Old 07-03-2003, 03:15 PM   #24
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
So you did use just hdc then? That would most definitely be an error
 
Old 07-03-2003, 03:16 PM   #25
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
Now I get the followin error when trying to mount my cdrom:

mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

And I get this error when I am trying to mount my cdrw:

mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems
 
Old 07-03-2003, 03:16 PM   #26
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
no, I used /dev/hdc. I forgot to link it to /dev/cdrom
 
Old 07-03-2003, 03:53 PM   #27
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
link it to /dev/cdrom and reference THAT in the fstab. Make sure it is a SYMBOLIC link (ln -s, the -s is important) And check again to make sure that in your lilo.conf you have an entry similar to this:

image = /boot/vmlinuz
root = /dev/hda5 <---- whatever partition is mounted at "/"
label = Linux
append = "hdd=ide-scsi" <---- must be your cdrw drive, if secondary slave then hdd, if master hdc
read-only

Run lilo -v as root and reboot. It looks like you still have SCSI emulation set up for the wrong device. Either that or you have the master and slave mixed up. When the computer first boots up, you should see it checking for IDE drives, look closely to make sure that the CDRW is listed as secondary slave and not master.
 
Old 07-03-2003, 03:54 PM   #28
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
When linux boots up? Or do I have to go into my bios config?
 
Old 07-03-2003, 03:55 PM   #29
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
Also, in my lilo file this is what I have:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="hdd=ide-scsi"
boot = /dev/hda
#compact # faster, but won't work on all systems.
prompt
 
Old 07-03-2003, 04:00 PM   #30
Anti-Gates
Member
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 47

Original Poster
Rep: Reputation: 15
OK, DVD works but not CDRW.

Also, the stuff in the linux boot up was too fast to read. It was only on screen for about .75 seconds.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
n00b boot problem Joe Giliberti Slackware 5 07-10-2005 01:02 PM
n00b shutdown problem TomalakBORG Slackware 4 02-06-2005 11:30 AM
n00b with a boot problem Matty2Jay Linux - Hardware 1 12-28-2004 05:28 AM
n00b problem cdols Red Hat 3 03-31-2004 01:14 PM
RedHat n00b problem ixion Red Hat 1 01-16-2004 12:57 PM


All times are GMT -5. The time now is 11:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration