LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-12-2005, 08:42 PM   #1
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Rep: Reputation: 30
mysqld error : 'mysql ended'


I am getting this error at the time of booting of my machine and even if I want to run my mysql server by command prompt,

Error : Starting mysqld daemon with databases from /var/lib/mysql
STOPPING server from pid file /var/run/mysql/mysql.pid
mysql ended

Why this error?

Regards
Anindyanuri
 
Old 07-12-2005, 09:11 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Did you created the databases as stated in /etc/rc.d/rc.mysqld ?
 
Old 07-13-2005, 03:05 AM   #3
cyberhawk
Member
 
Registered: May 2003
Distribution: Slackware 10
Posts: 34

Rep: Reputation: 15
first of all ii'm guesing you installed slackware and enabled mysql server.

what needs to be done after that is to run $>mysql_install_db from the prompt
this will create the required user databases and put them in the right places.

after that you need to edit the /etc/rc.d/rc.mysqld file and look for the command that runs mysqld and add --user=root to it.

it won't allow the mysql server to start unless a valid user is starting it. root always works and if you create other administrators they can also start up the server.

hope this helps
 
Old 07-13-2005, 03:33 AM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
cyberhawk, it's not good to run mysql daemon with root privileges. That's why there's a user called mysql and the daemon defaults to run with it.
If you read the instructions on /etc/rc.d/rc.mysqld it will instruct you on how to create the databases with the correct privlege (owned by mysql user).
 
Old 07-13-2005, 09:11 AM   #5
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by gbonvehi
Did you created the databases as stated in /etc/rc.d/rc.mysqld ?
Nope, I could not.
I am not able to enter into the environment.
/etc/rc.d/rc.mysqld also gives the same error, so I am not able to enter into mysql to make any database.
Just reinstalled Slackware but strange...........a complete reinstall also giving the same problem.

Seeking your help.

Regards
Anindyanuri
 
Old 07-13-2005, 09:15 AM   #6
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by cyberhawk
first of all ii'm guesing you installed slackware and enabled mysql server.

what needs to be done after that is to run $>mysql_install_db from the prompt
this will create the required user databases and put them in the right places.

after that you need to edit the /etc/rc.d/rc.mysqld file and look for the command that runs mysqld and add --user=root to it.

it won't allow the mysql server to start unless a valid user is starting it. root always works and if you create other administrators they can also start up the server.

hope this helps
The problem is that I am not able to enable mysql server.

/etc/rc.d/rc.mysqld is producing an error which is same as my thread and quitting.

How to proceed?

Regards
Anindyanuri
 
Old 07-13-2005, 10:05 AM   #7
piete
Member
 
Registered: Apr 2005
Location: Havant, Hampshire, UK
Distribution: Slamd64, Slackware, PS2Linux
Posts: 465

Rep: Reputation: 44
You misunderstand.

Go back and read the MySQL manual (for your convience, it is located here: http://dev.mysql.com/doc/mysql/en/index.html ) or, as gbonvehi suggested, read the contents of /etc/rc.d/rc.mysqld (~$ less /etc/rc.d/rc.mysqld).

To paraphrase:

You must run a script *BEFORE* starting MySQL for the first time to instantiate some fixed databases (the mysql database itself, for example).

Once that script has been run (and run correctly), then AND ONLY THEN, will you be able to type: ~$ /etc/rc.d/rc.mysqld start

Please read the documentation provided with MySQL, all the information is in there.

- Piete.
 
Old 07-13-2005, 12:22 PM   #8
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Thank you for this wonderful clear picture. I am right now following your thread.

Tell you the result later.

Thank you once again my friend.

Regards
Anindyanuri
 
Old 11-25-2005, 11:14 PM   #9
tweter
LQ Newbie
 
Registered: Nov 2005
Location: MInnesota
Posts: 1

Rep: Reputation: 0
Big Thanks to the replys in here gave me direction on where to start looking to get mysql working

made the mistake of running mysql_install_db as root and needed to 'chown -R mysql.mysql /var/lib/mysql' that seemed to be the only thing stopping me

good thing it told me that in the comments of /etc/rc.d/rc.mysql

Tweter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL Error [mysqld: unknown variable 'old_passwords=1'] after 'apt-get upgrade' jme Debian 10 10-05-2005 07:55 AM
Fedora Core 3, MySql Server, mysql started mysql ended OkiTek Fedora 30 01-28-2005 09:15 AM
"mysqld ended" when trying to start mysql daemon guarriman Linux - General 1 01-19-2005 07:35 AM
mysqld ended message on Slack... Vincent_Vega Slackware 1 12-20-2003 04:04 AM
mysqld ended.. xdrainox Slackware 9 10-02-2003 04:26 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration