LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-02-2003, 01:58 AM   #1
xdrainox
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Rep: Reputation: 1
mysqld ended..


I'm sure lots of you are probably experiencing this.. I googled around and found this, tried it out and it works perfect.. looks like the owner is incorrect on some of the files in /var/lib/mysql/mysql
They should be owned my the mysql user, not root.

just do this..

chown -R mysql /var/lib/mysql

then either chmod +x /etc/rc.d/rc.mysqld ( if its not already )

reboot.

or, to test it.. run: /usr/bin/mysqld_safe &

voila.


also --- you might have to run mysql_install_db .. not sure if I had to do that first..
 
Old 10-02-2003, 03:21 AM   #2
w3edr5t
Member
 
Registered: Jul 2003
Location: Oslo/Norway
Distribution: Slackware
Posts: 33

Rep: Reputation: 16
It's also explained in /etc/rc.d/rc.mysqld script which say:

# Before you can run MySQL, you must have a database. To install an initial
# database, do this as root:
#
# su - mysql
# mysql_install_db
#
# Note that step one is becoming the mysql user. It's important to do this
# before making any changes to the database, or mysqld won't be able to write
# to it later (this can be fixed with 'chown -R mysql.mysql /var/lib/mysql').

Last edited by w3edr5t; 10-02-2003 at 03:24 AM.
 
Old 10-02-2003, 03:32 AM   #3
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Quote:
Originally posted by xdrainox
reboot.
This is not needed. Just restart the service not the whole computer!
 
Old 10-02-2003, 10:24 AM   #4
xdrainox
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Original Poster
Rep: Reputation: 1
Well, those instructions are a little late.. I think if the install gives you the option of starting it automatically when you boot up, this should be done for you during the install. If someone is bright enough to edit the rc.mysqld script and read the instructions, then I think they are bright enough to chmod +x the script. I don't think it should be a startup option on the install if it's not going to work automatically. That's just my opinion.

and micxz, apparently you didn't read..

Quote:
or, to test it.. run: /usr/bin/mysqld_safe &
 
Old 10-02-2003, 02:48 PM   #5
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
We're too late? You posted at " Today 05:58 AM" and we answered just two hours later.

or, to test it.. run: /usr/bin/mysqld_safe &

Is what you want and not rebooting.
 
Old 10-02-2003, 03:00 PM   #6
xdrainox
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Original Poster
Rep: Reputation: 1
Quote:
We're too late? You posted at " Today 05:58 AM" and we answered just two hours later
[Moderator Edit: Please refrain from using abusive language].

What I meant by those instructions being late is.. after you tell Slackware ( in the install ) to start mysqld on boot up, but no tables have been created and it fails to start on bootup.. THAT is too late. Not his or your instructions..

The reason I said reboot is so that people can see that it will startup correctly from the init scripts at bootup. I *also* noted the option of just running /usr/bin/mysqld_safe & to show that it works that way as well. I personally, after adding new services to my system like to reboot and make sure everything starts like it should.


Last edited by Aussie; 10-02-2003 at 05:06 PM.
 
Old 10-02-2003, 03:11 PM   #7
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
To bad your having such a hard time. You explain yourself much better in the last post I see what you mean now, no need to call names;

I thought we were pretty fast with trying to help.
I will not try to help you anymore.
 
Old 10-02-2003, 04:31 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
xdrainox, I recommend you to re-read the rules you agreed when you signed to this forum: http://www.linuxquestions.org/rules.php
 
Old 10-02-2003, 05:11 PM   #9
xdrainox
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Original Poster
Rep: Reputation: 1
Mara,

poop.

micxz,

I apologize for calling you retarded. I was frustrated.
 
Old 10-02-2003, 05:26 PM   #10
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
No harm done;
I apologize for my quick and stout post;
I understand how these things can be hard to explain;

Click my buddie Icon below? I will do the same;
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mysqld error : 'mysql ended' anindyanuri Slackware 8 11-26-2005 12:14 AM
"mysqld ended" when trying to start mysql daemon guarriman Linux - General 1 01-19-2005 08:35 AM
"mysqld ended" flamesrock Linux - Software 10 03-07-2004 11:00 PM
mysqld ended message on Slack... Vincent_Vega Slackware 1 12-20-2003 05:04 AM
Mysql ended BlackRabbit Linux - Software 2 10-25-2003 10:35 AM


All times are GMT -5. The time now is 11:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration