LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-20-2003, 06:02 PM   #1
linuxx01
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Rep: Reputation: 0
My mouse Does not work


(slakware 8.1)

Hey people i have a Logitech USB LASER MOUSE with scroll. Now before this i had the mouse core problem but fixed it with Mousecongif. I don't know what the hell to do any more my mouse will not move in KDE and there are no USB deiveces been read. SO if you can take me step by step setting this up i would be super greatfull.
 
Old 02-20-2003, 06:51 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,985
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
first of all you shouldn't be cross-posting :P

Then, show us your lsmod output, and we'll
try to tackle it from there ...

Cheers,
Tink
 
Old 02-20-2003, 07:07 PM   #3
linuxx01
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
i dont know

i have no idea what the Ismod is. Also i dont know how to make my XF86Config.new = to XF86Config man this sucks.. if i can get my mouse to work i will be so happy. I dont know if my USB is booting but i had Adaptec.s Kernal installed should i change it to something else?
 
Old 02-20-2003, 07:33 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,985
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
open a terminal window
su -
lsmod

I don't think that SCSI or IDE would make
a difference for the USB.

The output of dmesg might help, too.

And as I like to talk in parables:
"Buying a car doesn't make give you a license"

If you're new to Linux - read, read, read.

Cheers,
Tink
 
Old 02-20-2003, 09:28 PM   #5
linuxx01
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
thanks but screw it im ganna learn through redhat first
 
Old 02-21-2003, 02:32 AM   #6
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
<soapbox>Whoa...slow down there. How will you learn anything if everything is done for you? Seriously, let's work this out. Slackware is an OS that gives you total control. It will not do anything for you or guess what you want done. It makes you do everything yourself so you know what's going on with it. </soapbox>

Now, let's get your mouse situation sorted out. You need to get to a command line firstly. Then type:

su -
password: <enter your root password here>

Now, all you have to do to lsmod as suggested before is type lsmod. If you want to make XF86Config.new equal to XF86Config you can type:

mv -i /etc/XF86Config.new /etc/XF86Config

It will prompt you first before making any changes. If you decide to go ahead with the move, then your XF86Config.new will now be called XF86Config. I assume that your XF86Config.new is one that was created after running xf86config? Could you please post your copy of XF86Config.new for us so we can see how your mouse settings are currently? This would help us out alot.
 
Old 02-21-2003, 11:51 AM   #7
wass29
Member
 
Registered: Feb 2003
Distribution: Slack 9,10 Ubuntu 8.04-current RHEL4(sort of)
Posts: 63

Rep: Reputation: 15
Hey Linux01, I agree with Texicle and think you need to slow down and try to beat this. I also am fairly new to this stuff, but when I get stuck I come here start a new post and get all of the answers I need (except for when I asked about the lottery oh well I'll figure that one another day)

I think you are on the right track you are here asking questions all you need to do is slow down abit and we can help get this mouse prob of your fixed.

Try following Tinksters advice above this post and if you are still confused let us know we can be more specific if you want....
 
Old 02-21-2003, 08:01 PM   #8
linuxx01
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I dont know how to boot my USB modules i guess thats a big role in this
 
Old 02-22-2003, 01:51 AM   #9
trn
Member
 
Registered: Feb 2003
Distribution: freebsd/gentoo
Posts: 68

Rep: Reputation: 15
also it might have to do with what kernel you installed... i'm in the same boat as you, total newb. Anyways i was messing around with slack8.1 tonight and the first time i installed the mouse would freak out anytime it was moved etc. I couldn't fix the problem with the x86cfg or manualy trying to edit the config it always seemed to default back to the ps2 driver. anyways i resintalled because i thought i screwed up on the install and missed some usb option for the mouse. second time i tried the .usb.i or whatever kernel off the cd thinking it might help. Well.. this time the mouse was just totally dead, no movement.. an improvement.. but not the one i was hoping for. Anyways, i'll probably give it another try again tommrow.
 
Old 02-24-2003, 05:38 PM   #10
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Have you run modprobe yet? Also, if you want to add them at boot time add:

modprobe <modulename>

into your /etc/rc.d/rc.local file. If I'm wrong, someone please correct me.
 
Old 02-24-2003, 08:38 PM   #11
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
If the system is using one of the USB enabled kernels like usb.i then the USB mouse should be enabled and operational on /dev/input/mouse0 device.

If using bare.i kernel or a kernel that is not USB enabled, then try the following modules.

modprobe usb-uhci or modprobe usb-ohci depending on chipset. Use the command "lspci" to see what USB controller is available. It should load usbcore module as well. Then

modprobe hid or modprobe usbmouse
modprobe mousedev

The USB mouse should then be enabled and usable on the device /dev/input/mouse0.

Use "lsmod" to list the modules loaded. To see if it is working, try

cat /dev/input/mouse0

It should just wait for something, move the mouse and some garbage just come up on the screen. Type Ctrl-C to terminate. If you move it a great deal then the prompt may get garbaged as well, just type "reset" and press enter. It should then be back to normal. If it doesn't work or you get device not present then you will need to figure out why. Best to post back your steps and your results.

For your X system, if the /etc/X11/XF86Config file is set to the default of /dev/mouse. Edit XF86Config to change the device used or change the symlink as in:

ln -sf /dev/input/mouse0 /dev/mouse

You should then at least have basic mouse operation. More info is available here on LQ to search for in regard to the wheel, etc. for the modifications for the X config file.

Perhaps it will be able to help.

Last edited by Excalibur; 02-24-2003 at 08:40 PM.
 
Old 02-24-2003, 10:33 PM   #12
C++freak
Member
 
Registered: Apr 2002
Location: NB, Canada
Distribution: Gentoo
Posts: 180

Rep: Reputation: 30
Quote:
Originally posted by Texicle
Have you run modprobe yet? Also, if you want to add them at boot time add:

modprobe <modulename>

into your /etc/rc.d/rc.local file. If I'm wrong, someone please correct me.
wouldnt you just uncomment one of the lines in /etc/rc.d/rc.modules ?
 
Old 02-25-2003, 02:37 AM   #13
trn
Member
 
Registered: Feb 2003
Distribution: freebsd/gentoo
Posts: 68

Rep: Reputation: 15
Well, i got my mouse to work, prob was easy. Reinstalled with the right kernel, usb2 and then just tweaked the xf86config with the right settings for my intelli explorer.
 
Old 02-25-2003, 03:09 AM   #14
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by C++freak
wouldnt you just uncomment one of the lines in /etc/rc.d/rc.modules ?
You could, if the module came with the distro, if not, you'd have to either add it there or rc.local I would think. I guess both ways would work. I don't really know to be honest which way is better.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Scroll Button doesn't work with Logitech PS/2 MOuse. duffmckagan Slackware 10 12-02-2008 11:27 PM
No mouse pointer (cursor), mouse does work whizz Linux - Hardware 6 04-04-2006 09:00 PM
Mouse does not work in 2.6.3 beajedi Slackware 8 03-10-2004 02:28 AM
PS/2 mouse did not work after temp removal of USB mouse edwardp Linux - Hardware 1 09-06-2003 04:57 PM
new mouse won't work marlaina1 Linux - General 13 07-21-2001 09:43 PM


All times are GMT -5. The time now is 07:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration