LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-10-2003, 07:50 AM   #1
vapebait
LQ Newbie
 
Registered: May 2002
Location: UK
Distribution: Gentoo
Posts: 11

Rep: Reputation: 0
Music cds


Hello all. I'm having problems using/playing cds as a user (they work when i am root). Here is my fstab entry for the cdrom:
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0

please help, thanks.
 
Old 12-10-2003, 08:03 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
your fstab is not relevant as you do not mount audio cd's. please provide REAL error messages and such.
 
Old 12-10-2003, 10:07 AM   #3
vapebait
LQ Newbie
 
Registered: May 2002
Location: UK
Distribution: Gentoo
Posts: 11

Original Poster
Rep: Reputation: 0
when i try to add a cd to xmms with the cd audio player i get an error message saying "Failed to open device /dev/cdrom
Error: Permission denied

Directory /mnt/cdrom/ ok"

ive checked the perms on /dev/cdrom: "lrwxrwxrwx 1 root root 8 Dec 5 00:48 cdrom -> /dev/hdc"

ive also checked /dev/hdc: "brw-rw---- 1 root disk 22, 0 Jun 9 2002 hdc", could this be where the problem lies?

thanks.
 
Old 12-10-2003, 10:15 AM   #4
harrygraham
Member
 
Registered: Apr 2001
Location: Ottawa, Canada
Distribution: Ubuntu Gnome
Posts: 153

Rep: Reputation: 16
It's probably the link to /dev/cdrom that's causing the problem. I just installed Slack 9.1 and had to delete the /dev/cdrom file because it was linked to the wrong device.

I'm guessing you have a CD burner. If so the configuring is not automatic. To make a burner work properly you must first pass the option "append hdc=scsi-ide" to the kernel in lilo so the scsi generic driver gets loaded first. You next have to delete /dev/cdrom and then make a new /dev/cdrom linked to the correct device, (in my case it was scd0) using the command "ln -sf scd0 cdrom" Then chmod 666 /dev/cdrom. Then chgrp users /dev/cdrom. After this it worked perfectly.

If your cdrom is just a straight ide device you might want to see if it's being detected properly at boot time, then make sure the /dev/cdrom is pointing to the correct device. Of course it's just a guess that this will be your problem.



By the way, this new version of Slackware is awesome!

Hope this helps

Harry
 
Old 12-10-2003, 10:17 AM   #5
vapebait
LQ Newbie
 
Registered: May 2002
Location: UK
Distribution: Gentoo
Posts: 11

Original Poster
Rep: Reputation: 0
yeh its a cd burner but is ide. the thing is that i can read data cds just not music.
 
Old 12-10-2003, 10:23 AM   #6
mipia
Member
 
Registered: May 2003
Location: lake michigan
Distribution: Debian, Mint, Slackware
Posts: 457

Rep: Reputation: 35
permission problems only with music cd's? wierd.
What happens if you try to play it is something like XMMS? (and no, dont mount it)
Any problems burning CD's?
I had similar problems and fixed it by setting it up with scsi emulation

Last edited by mipia; 12-10-2003 at 10:26 AM.
 
Old 12-10-2003, 10:27 AM   #7
vapebait
LQ Newbie
 
Registered: May 2002
Location: UK
Distribution: Gentoo
Posts: 11

Original Poster
Rep: Reputation: 0
if, as a normal user, i try and play a cd with xmms it comes up with a permission denied error window. if i am root it works fine. i have also tried using grip, but again nothing happens if i am a user, but automatically loads the cd if i run grip as root.
 
Old 12-10-2003, 11:47 AM   #8
harrygraham
Member
 
Registered: Apr 2001
Location: Ottawa, Canada
Distribution: Ubuntu Gnome
Posts: 153

Rep: Reputation: 16
Cool SCSI and IDE

Even if your CD burner is an IDE, it won't work as a burner with the IDE driver. You must edit your lilo.conf file to pass the scsi option to the kernel. Here's what my /etc/lilo.conf file looks like:

boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
change-rules
reset
vga = normal
image = /boot/vmlinuz
root = /dev/hda1
label = Linux
append = "hdc=ide-scsi"
read-only


The append line tells the kernel to load the scsi driver first. When this file is edited you must run the "lilo" command so that it will change the boot loader. Then you will have to reboot your computer for the changes to take effect. This will change the burner from /dev/hdc to /dev/scd0. This means you will have to change your /dev/cdrom so that it points to the new device. as explained in my first post.

Good luck!
 
Old 12-10-2003, 01:36 PM   #9
cozye
Member
 
Registered: Nov 2003
Location: Louisville, KY
Distribution: Slackware
Posts: 46

Rep: Reputation: 15
>Even if your CD burner is an IDE, it won't work as a burner with the IDE driver.

This is not true. You can burn CD's with the IDE driver by using the atapi device option as described in the cdrecord man pages. There are several posts about this.
example
cdrecord -v speed=8 dev=ATAPI:0,0 cdimage.raw

The permissions problem sounds strage. I had some problems with my normal user account accessing the sound card etc.. I added my user account to the 'sys' group and that fixed that. What happens if you change the ownership and group on your cdrom to your user account ?
 
Old 12-10-2003, 05:01 PM   #10
Misel
Member
 
Registered: Mar 2003
Location: Berlin
Distribution: Slackware current
Posts: 310

Rep: Reputation: 30
the problem is that the permissions of links are generally ignored. A good friend of mine told me about that lately - I didn't know it before either.

So in this case
Quote:
"lrwxrwxrwx 1 root root 8 Dec 5 00:48 cdrom -> /dev/hdc"
check for the permissions on /dev/hdc which are probably
Quote:
brw-rw---- 1 root disk 22, 0 Jun 9 2002 hdc
your user is probably not in the group disk - so one solution is to add him to the group.

The other one (which is less secure) is doing a `chmod 666 /dev/hdc`.
 
Old 12-10-2003, 06:22 PM   #11
vapebait
LQ Newbie
 
Registered: May 2002
Location: UK
Distribution: Gentoo
Posts: 11

Original Poster
Rep: Reputation: 0
ok, i added my user to the disk group, and grip reads the disk, and when i try and add the disk in xmms it no longer complains about permissions, but im getting this error "Digital audio extraction test failed: Inappropiate ioctl for device". Any ideas?

thanks.
 
Old 12-10-2003, 09:14 PM   #12
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
...... change iso9660 to

auto

and make sure you've got permissions on /dev/cdrom or whatever the device is?
 
Old 12-10-2003, 09:44 PM   #13
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
Quote:
Originally posted by cozye
>Even if your CD burner is an IDE, it won't work as a burner with the IDE driver.

This is not true. You can burn CD's with the IDE driver by using the atapi device option as described in the cdrecord man pages. There are several posts about this.
example
cdrecord -v speed=8 dev=ATAPI:0,0 cdimage.raw

The permissions problem sounds strage. I had some problems with my normal user account accessing the sound card etc.. I added my user account to the 'sys' group and that fixed that. What happens if you change the ownership and group on your cdrom to your user account ?
Is there a way to burn CD's without using emulation if you want to use a gui burning program?
 
Old 12-11-2003, 08:50 AM   #14
cozye
Member
 
Registered: Nov 2003
Location: Louisville, KY
Distribution: Slackware
Posts: 46

Rep: Reputation: 15
Most of the GUI's I have seen just run the command in the background for you. I don't have a gui installed to look, but I am sure you can set it to use the ATAPI option somewhere. Why not just learn the command line ?

Make your iso image using mkisofs command, then burn it to disk using the cdrecord command. It is not difficult. Look at the man pages for extra options and syntax etc..
 
Old 12-11-2003, 06:03 PM   #15
vapebait
LQ Newbie
 
Registered: May 2002
Location: UK
Distribution: Gentoo
Posts: 11

Original Poster
Rep: Reputation: 0
ok i changed iso9660 to auto and now i get this error from xmms "Digital audio extraction test failed: Invalid argument"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No audio on music CDs maokc Linux - Newbie 1 09-11-2005 08:59 PM
music cds will not mount fatblueduck Linux - Hardware 4 07-13-2005 07:08 AM
Cannot play music CDs arubin Slackware 20 12-23-2004 12:55 PM
music cds... kurrupt Debian 2 08-11-2004 09:39 PM
Music CDs TX_metalhead Linux - General 6 05-02-2002 09:29 PM


All times are GMT -5. The time now is 06:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration