LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-10-2003, 08:26 PM   #1
geno976
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware.. what else ?
Posts: 24

Rep: Reputation: 15
multiple NICs using e1000 module.. eth[x] order


Hi All,

I have a system running slack 9-current.. it is a dell optiplex with an onboard intel pro/1000 MT nic. I just recently installed a dual port pro/1000 MT nic as well. Currently eth0 comes up as the first port of the dual nic, and eth1 is the 2nd port, and eth2 is the onboard nic. They all use the e1000 module and are all functioning correctly.

question: how can i make the onboard nic to be eth0?

I've tried adding the following to /etc/modules.conf :

alias eth0 e1000
alias eth1 e1000
alias eth2 e1000

options e1000 io=0xecc0,0xec80,0xec40

and also :

options e1000 irq=10,9,11

but on bootup i get an err saying e1000 does not support those parameters... not sure what else to try..

Thanks in advance..
-geno
 
Old 09-10-2003, 09:32 PM   #2
linuxJaver
Member
 
Registered: Jul 2003
Location: Jakartax, ID
Distribution: slack9.1+,9.1,rh9
Posts: 203

Rep: Reputation: 30
I got also that problem with my 2 nics (dlink 538-TX). And I come to the conclusion that the device (ethx) assignment is not related to IRQ,MAC nor to pci slot order, but maybe to the I/O address used by the NICs (I can be wrong).

The older ISA card need to be configured with irq,i/o but pci is plugNplay, that mean those irq,i/o will be assigned by the OS. I heard there are tool for that mii somethang (nope sure, maybe only for 538-tx card).

I quest on lilo there is a possibility to specify the irq,i/o for ethx, am nope sure whether this work, also don't have the time to probe n learnt to accept my eth1 to be the gateway to internet ..
 
Old 04-25-2008, 03:48 AM   #3
tdereggi
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
I share your pain- Multiple Nics

We have 2 onboard tx, 1 Dual port fiber, 1 quad port Copper TX.
They all GB cards using the Innel e1000 driver.
Whats odd is...
Onboard is Eth0,1
Dual Fiber is Eth 2,4
Quad port is Eth 5,3,7,6. (top to bottom on card)

On the QUAD port it isn't even contiguous or in order. ARG.

I read an arcticle about using udev scripting to rename, based on MAc, which sounded liek a good idea. But I'd like to know what enables the wierd assignments. On teh exampe above, why in the world is ETH3 in the middle of a card?
 
Old 04-25-2008, 04:44 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,333

Rep: Reputation: Disabled
Slackware 12.0 and up using UDEV will allow you to configure your network device assignments through the file /etc/udev/rules.d/75-network-devices.rules .

An example of that file shows how UDEV matches MAC addresses to device names:
Code:
KERNEL=="eth?", ATTR{address}=="00:11:09:8c:84:2e", NAME="eth0"
KERNEL=="eth?", ATTR{address}=="00:11:09:8c:84:7e", NAME="eth1"
If you swap the eth0 and eth1 in that file (which will be re-generated on boot if you delete it by the way), then your devices will be (re-)named exactly as defined there.

For non-UDEV systems you will have to pass the interface name on the kernel command line (e.g. in lilo.conf's "append" line) together with IO and IRQ addresses if possible, or else using modprobe options in /etc/modules.conf (2.4 kernels) or /etc/modprobe.conf (older Slackwares that do not have a /etc/modprobe.d/ directory).

Eric
 
Old 04-27-2008, 12:36 AM   #5
tdereggi
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
Thanks Eric. I have successfully renamed the ports using UDEV, so physical ports now match ETH names in logical sequential order!

However, still one more small issue. When I type IP ADDR, the ETH ports are listed out of order. This is rather ugly. Any way to make them list starting at ETh0 and sequentially down?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mepis 3.3 with 2.6.10 kernel e1000 nic module autoload bredfern Linux - Hardware 0 06-02-2005 05:49 PM
Intel D845GLLY + Multiple Intel Pro 100 NICs + kernel 2.6.x = NICs don't work egable Linux - Hardware 0 02-04-2005 03:30 PM
e1000 module issue on kernel 2.6.10 blizzardtweaker Slackware 23 01-05-2005 07:39 AM
Kernel issue for suse9 when tring to install module for e1000 feetyouwell Linux - Software 6 01-15-2004 04:35 PM
Cannot install e1000 module because of missing kernel source? schlagzeug Red Hat 5 11-07-2003 06:50 PM


All times are GMT -5. The time now is 08:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration