LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-20-2013, 07:21 PM   #1
val3xiv
Member
 
Registered: Jun 2007
Location: ita
Distribution: slackware
Posts: 35

Rep: Reputation: 15
Multilib issue: error upgrading glibc. System unusable. Slackware64 current


Hi all.
Slackware64 current installed from scratch. Tried to enable multilib following this http://docs.slackware.com/slackware:multilib
Code:
# SLACKVER=current
# mkdir multilib
# cd multilib
# lftp -c "open http://taper.alienbase.nl/mirrors/people/alien/multilib/ ; mirror ${SLACKVER}"
# cd ${SLACKVER}
# upgradepkg --reinstall --install-new *.t?z
After some succesful upgrade I got this error

Quote:
+==============================================================================
| Upgrading glibc-2.17_multilib-x86_64-3alien package using ./glibc-2.17_multilib-x86_64-3alien.txz
+==============================================================================

Pre-installing package glibc-2.17_multilib-x86_64-3alien...
/sbin/installpkg: line 567: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 38: sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
/sbin/installpkg: line 58: /sbin/ldconfig: cannot execute binary file
then I cannot use my slackware anymore

Code:
# ls
-bash: /bin/ls: No such file or directory
What am I missing?

Thanks in advance

val3xiv
 
Old 05-21-2013, 07:06 AM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Rep: Reputation: Disabled
Boot from Slack DVD,use wget to download glibc and glibc-solibs.Then mount your root partition.
Then run installpkg --root /mount_point_of_your_root_partition glibc-*
You should upgrade first glibc-solibs then glibc and again glibc-solibs
 
Old 05-21-2013, 08:20 AM   #3
val3xiv
Member
 
Registered: Jun 2007
Location: ita
Distribution: slackware
Posts: 35

Original Poster
Rep: Reputation: 15
No, the problem was me!
I thought I had installed the Slackware64 but there was a mistake and the installed installed one was the Slackware 32 bit.
Now I've installed the right version and multilib works like a charm.
Sorry for bothered anyone with this stupid neglect.

val3xiv
 
  


Reply

Tags
glibc, multilib, slack64


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64 -current (multilib) -- Wrong GCC version slaka Slackware 2 05-13-2013 11:39 AM
upgrading slackware64 13.1 multilib to slackware64 -current multilib Cultist Slackware 4 03-12-2011 10:04 AM
[SOLVED] Google Talk Plugin, Slackware64-Current, Google Chrome (Latest) and Multilib - Error Gavin Harper Slackware 3 01-04-2011 08:45 AM
Slackware64 current multilib, do the 32 bit packages need to be updated as well? damgar Slackware 11 02-01-2010 12:08 PM
[SOLVED] Slackware64-current multilib: Many improvements, few snags gargamel Slackware 7 11-15-2009 08:23 AM


All times are GMT -5. The time now is 09:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration