LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Multi-Lingual Keyboard Support for Slackware 14.0 (http://www.linuxquestions.org/questions/slackware-14/multi-lingual-keyboard-support-for-slackware-14-0-a-4175447228/)

Yaakov Ben-Avraham 01-25-2013 05:42 PM

Multi-Lingual Keyboard Support for Slackware 14.0
 
I have tried to get Multi-Linkgual keyboard support going in Slackware 14.0 - Some thing has changed from Slackware 13.37

In particular, after

# xorgsetup
# vi /etc/X11/xorg.conf

Section "ServerFlags"
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"
EndSection

Section "ServerLayout"
Identifier "Keyboard0"
Device "kbd"
Option "XkbRules" "Xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "us,ar,ru,il"
Option "grp:switch,grp:alt_shift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp"
EndSection

No longer works, i.e.

(left) [Alt]+[Shift] does not toggle

[English]->[Hebrew]->[Russian]->[Arabic]

and

(left) [Ctrl]+[Alt]+[Backspace]

does not terminate "X" immediately

What is the solution to my problem with Slackware 14.0 "X" ?

kikinovak 01-25-2013 11:59 PM

Quote:

Originally Posted by Yaakov Ben-Avraham (Post 4877658)
What is the solution to my problem with Slackware 14.0 "X" ?

Hi,

Take a look in /usr/share/X11/xorg.conf.d. You'll find a series of stub files, to be put in /etc/X11/xorg.conf.d according to your needs. Yours will be 90-keyboard-layout.conf. Copy it to /etc/X11/xorg.conf.d and edit it following the usual xorg.conf syntax as above.

Hope that helps.

Niki


All times are GMT -5. The time now is 10:14 AM.