LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-19-2012, 05:22 PM   #1
Fantastic
LQ Newbie
 
Registered: Nov 2010
Distribution: Archlinux
Posts: 18

Rep: Reputation: 0
Mplayer too slow


Hi

I installed mplayer from slackware official current mirror and when i play any playlist with song it takes 5 seconds for going to next song.

For example
When i play song A and i press ">" to go to the next song and it takes 4-5 seconds and in the end it plays song B

In archlinux there is not this problem

Also when i press space for pausing it is ok but when i hit CTRL+C it plays song 1-2 seconds after exiting

What's the problem with mplayer? Maybe any setting or recompilation with disabled any options?

Thanks.
 
Old 04-19-2012, 06:19 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled
No such problems here on slackware64-current and MPlayer.

Eric
 
Old 04-19-2012, 07:01 PM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,602

Rep: Reputation: 438Reputation: 438Reputation: 438Reputation: 438Reputation: 438
No such problem either here in slackware-current.
probably a slow disk? or is the file located in Windows partition maybe?
 
Old 04-19-2012, 11:38 PM   #4
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Rep: Reputation: 140Reputation: 140
mplayer runs fine here - Slackware64-13.37 multilib. Although I am not crazy about the default GUI so I use gnome-mplayer instead.
 
Old 04-20-2012, 03:59 AM   #5
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 648

Rep: Reputation: 92
Could be a problem with your default -vo or -ao device. Have you selected either by commandline or $HOME/.mplayer/config? Either of the following would give a guide to what can be used on your system:

Code:
mplayer -vo help
mplayer -ao help

Last edited by andrew.46; 04-20-2012 at 04:09 AM.
 
Old 04-20-2012, 09:01 AM   #6
Fantastic
LQ Newbie
 
Registered: Nov 2010
Distribution: Archlinux
Posts: 18

Original Poster
Rep: Reputation: 0
I am using slackware current and mplayer is slow with commands for incresing/decresing song speed, next/prev song etc....

This is my ~/.mplayer/config

Code:
# Write your default config options here!


nolirc=yes
i don't know what is problem.... In archlinux mplayer works fine and fast but in slackware it's not.... I am playing songs from ext3 partittion and it's not windows partittion
 
Old 04-20-2012, 09:29 AM   #7
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,049

Rep: Reputation: 170Reputation: 170
Could you post output from mplayer -v, perhaps when you enter the keystrokes?

Also, is .mplayer/config in Arch the same?

cheers,

Last edited by mrclisdue; 04-20-2012 at 09:35 AM. Reason: expand the question
 
Old 04-20-2012, 11:45 AM   #8
Fantastic
LQ Newbie
 
Registered: Nov 2010
Distribution: Archlinux
Posts: 18

Original Poster
Rep: Reputation: 0
Code:
bash-4.2$ mplayer -v /data/Music/50\ Cent/In\ Da\ Club.mp3 /data/Music/Adele/Chasing\ Pavements.mp3 
MPlayer 20101218-4.5.1 (C) 2000-2010 MPlayer Team
CPU vendor name: GenuineIntel  max cpuid level: 11
CPU: Intel(R) Pentium(R) CPU        P6100  @ 2.00GHz (Family: 6, Model: 37, Stepping: 5)
extended cpuid-level: 8
extended cache-info: 16801856
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled with runtime CPU detection.
get_path('codecs.conf') -> '/home/stefan/.mplayer/codecs.conf'
Reading /home/stefan/.mplayer/codecs.conf: Can't open '/home/stefan/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
get_path('fonts') -> '/home/stefan/.mplayer/fonts'
Configuration: --prefix=/usr --mandir=/usr/man --confdir=/etc/mplayer --enable-gui --enable-menu --enable-largefiles --disable-arts --codecsdir=/usr/lib64/codecs --language=en nl fr de es --enable-runtime-cpudetection --disable-libdvdcss-internal --disable-mp3lame --disable-mp3lame-lavc --disable-faac --disable-faac-lavc --disable-libopencore_amrnb --disable-libopencore_amrwb
CommandLine: '-v' '/data/Music/50 Cent/In Da Club.mp3' '/data/Music/Adele/Chasing Pavements.mp3'
Using nanosleep() timing
get_path('input.conf') -> '/home/stefan/.mplayer/input.conf'
Can't open input config file /home/stefan/.mplayer/input.conf: No such file or directory
Can't open input config file /etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('In Da Club.mp3.conf') -> '/home/stefan/.mplayer/In Da Club.mp3.conf'

Playing /data/Music/50 Cent/In Da Club.mp3.
get_path('sub/') -> '/home/stefan/.mplayer/sub/'
[file] File size is 3998357 bytes
STREAM: [file] /data/Music/50 Cent/In Da Club.mp3
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: MPEG audio layer 2/3
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /data/Music/50 Cent/In Da Club.mp3 ext: .mp3
Trying demuxer 17 based on filename extension
==> Found audio stream: 0
demux_audio: seeking from 0x3D0218 to start pos 0xA1
demux_audio: audio data 0xA1 - 0x3D0295  
Audio only file format detected.
get_path('sub/') -> '/home/stefan/.mplayer/sub/'
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using SSE optimized decore!
MP3lib: init layer2&3 finished, tables done
MPEG 1.0, Layer III, 44100 Hz 128 kbit Stereo, BPF: 417
Channels: 2, copyright: No, original: No, CRC: No, emphasis: 0
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy 
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Trying every known audio driver...
ao2: 44100 Hz  2 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags:  32/32  (16384 bytes/frag)  free: 524288
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
Increasing filtered audio buffer size from 0 to 65536
A:   2.2 (02.2) of 249.0 (04:09.0)  0.4% 
EOF code: 1  

Uninit audio filters...
[libaf] Removing filter dummy 
Uninit audio: mp3lib
get_path('Chasing Pavements.mp3.conf') -> '/home/stefan/.mplayer/Chasing Pavements.mp3.conf'

Playing /data/Music/Adele/Chasing Pavements.mp3.
get_path('sub/') -> '/home/stefan/.mplayer/sub/'
[file] File size is 3535678 bytes
STREAM: [file] /data/Music/Adele/Chasing Pavements.mp3
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: MPEG audio layer 2/3
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /data/Music/Adele/Chasing Pavements.mp3 ext: .mp3
Trying demuxer 17 based on filename extension
==> Found audio stream: 0
demux_audio: seeking from 0x35F2C1 to start pos 0xA3
demux_audio: audio data 0xA3 - 0x35F33E  
Audio only file format detected.
get_path('sub/') -> '/home/stefan/.mplayer/sub/'
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using SSE optimized decore!
MP3lib: init layer2&3 finished, tables done
MPEG 1.0, Layer III, 44100 Hz 128 kbit Stereo, BPF: 417
Channels: 2, copyright: No, original: No, CRC: No, emphasis: 0
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy 
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Trying every known audio driver...
ao2: 44100 Hz  2 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags:  32/32  (16384 bytes/frag)  free: 524288
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
Increasing filtered audio buffer size from 0 to 65536
A:   0.9 (00.9) of 220.0 (03:40.0)  0.4% 


MPlayer interrupted by signal 2 in module: play_audio
A:   1.1 (01.0) of 220.0 (03:40.0)  0.4% 
Uninit audio filters...
[libaf] Removing filter dummy 
Uninit audio: mp3lib
vo: x11 uninit called but X11 not initialized..

Exiting... (Quit)
 
Old 04-20-2012, 03:52 PM   #9
Fantastic
LQ Newbie
 
Registered: Nov 2010
Distribution: Archlinux
Posts: 18

Original Poster
Rep: Reputation: 0
i solved problem

i created file /etc/mplayer/input.conf and put in it this

Code:
##
## MPlayer input control file
##
## You are able to redefine default keyboard/joystick/mouse/LIRC bindings, or
## add new ones here.
## See DOCS/tech/slave.txt for possible commands that can be bound.
## Also see mplayer -input cmdlist for other possible options.
## The file should be placed in the $HOME/.mplayer directory.
##
## If you wish to unbind a key, use key ignore.
## e.g. ENTER ignore
##

RIGHT seek +10
LEFT seek -10
DOWN seek -60
UP seek +60
PGUP seek 600
PGDWN seek -600
m mute
# switch_audio          # switch audio streams
+ audio_delay 0.100
= audio_delay 0.100
- audio_delay -0.100
[ speed_mult 0.9091	# scale playback speed
] speed_mult 1.1
{ speed_mult 0.5
} speed_mult 2.0
BS speed_set 1.0	# reset speed to normal
q quit
ESC quit
ENTER pt_step 1 1       # skip to next file
p pause
. frame_step            # advance one frame and pause
SPACE pause
HOME pt_up_step 1
END pt_up_step -1
> pt_step 1             # skip to next file
< pt_step -1            #         previous
INS alt_src_step 1
DEL alt_src_step -1
o osd
I osd_show_property_text "${filename}"     # display filename in osd
P osd_show_progression
z sub_delay -0.1        # subtract 100 ms delay from subs
x sub_delay +0.1        # add
9 volume -1
/ volume -1
0 volume 1
* volume 1
1 contrast -1
2 contrast 1
3 brightness -1
4 brightness 1
5 hue -1
6 hue 1
7 saturation -1
8 saturation 1
( balance -0.1          # adjust audio balance in favor of left
) balance +0.1          #                                  right
d frame_drop
D step_property deinterlace  # toggle deinterlacer, requires -vf yadif or kerndeint
r sub_pos -1            # move subtitles up
t sub_pos +1            #                down
#? sub_step +1		# immediately display next subtitle
#? sub_step -1		#                     previous
#? sub_scale +0.1	# increase subtitle font size
#? sub_scale -0.1	# decrease subtitle font size
f vo_fullscreen
T vo_ontop              # toggle video window ontop of other windows
w panscan -0.1          # zoom out with -panscan 0 -fs
e panscan +0.1          #      in
c capturing             # save (and append) file/stream to stream.dump with -capture
s screenshot            # take a png screenshot with -vf screenshot
                        # S will take a png screenshot of every frame

h tv_step_channel 1
l tv_step_channel -1
n tv_step_norm
b tv_step_chanlist

##
## Joystick section
## WARNING: joystick support has to be explicitly enabled at
##          compiletime with --enable-joystick
##

JOY_RIGHT seek 10
JOY_LEFT seek -10
JOY_UP seek 60
JOY_DOWN seek -60
JOY_BTN0 pause
JOY_BTN1 osd
JOY_BTN2 volume 1
JOY_BTN3 volume -1
JOY_BTN4 set_menu main

##
## Apple Remote section
##
## To use OSD menu with Apple Remote, set key AR_MENU to any OSD menu command,
## or just comment out the 'AR_MENU osd' line and uncomment the line after it.
##

AR_PLAY pause
AR_PLAY_HOLD quit
AR_NEXT seek 30
AR_NEXT_HOLD seek 120
AR_PREV seek -10
AR_PREV_HOLD seek -120
AR_MENU menu up
#AR_MENU menu cancel
AR_MENU_HOLD mute
AR_VUP volume 1
AR_VDOWN volume -1

##
## OSD Menu movement keys
##
## If you are using only the keyboard it is enough to define one command (like
## "menu up"), because then that single key will display the menu, which can
## then be navigated with the cursor keys and ENTER (defined in menu.conf).
##
## LIRC users should bind each "menu" command to a button on their remote.
##
## The set_menu command directly displays the (sub)menu specified as
## its argument. Usage should be self-explanatory (although not likely
## to be needed), after reading input.conf.
##

#MOUSE_BTN0 menu up
#y menu down
#y menu ok
#y menu cancel
#y menu hide
#y set_menu general_pref

##
## DVDNAV
## Requires dvdnav://
##

UP    {dvdnav} dvdnav up          # DVDNav UP
DOWN  {dvdnav} dvdnav down        # DVDNav DOWN
LEFT  {dvdnav} dvdnav left        # DVDNav LEFT
RIGHT {dvdnav} dvdnav right       # DVDNav RIGHT
ESC   {dvdnav} dvdnav menu        # DVDNav MENU
ENTER {dvdnav} dvdnav select      # DVDNav SELECT (ok)
BS    {dvdnav} dvdnav prev        # DVDNav PREVIOUS menu (in the order chapter->title->root)

AR_VUP    {dvdnav} dvdnav up      # DVDNav UP
AR_VDOWN  {dvdnav} dvdnav down    # DVDNav DOWN
AR_PREV   {dvdnav} dvdnav left    # DVDNav LEFT
AR_NEXT   {dvdnav} dvdnav right   # DVDNav RIGHT
AR_MENU   {dvdnav} dvdnav menu    # DVDNav MENU
AR_PLAY   {dvdnav} dvdnav select  # DVDNav SELECT (ok)

#? seek_chapter -1      # skip to previous dvd chapter
#? seek_chapter +1      #         next

##
## Advanced seek
## Uncomment the following lines to be able to seek to n% of the media with
## the Fx keys.
##
#F1 seek 10 1
#F2 seek 20 1
#F3 seek 30 1
#F4 seek 40 1
#F5 seek 50 1
#F6 seek 60 1
#F7 seek 70 1
#F8 seek 80 1
#F9 seek 90 1
Thanks
 
Old 04-20-2012, 05:37 PM   #10
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 648

Rep: Reputation: 92
Perhaps the icing on the cake might be the following addition to ~/.mplayer/config:

Code:
[extension.mp3]
profile-desc="profile for .mp3 files"
ac=mpg123
Soon enough the built-in mp3lib will be removed and this will be the default, certainly works better on my system.
 
  


Reply

Tags
mplayer, slackware, slow


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer -vo gl too slow compu73rg33k Linux - Software 7 12-31-2008 08:42 AM
slow mplayer launching raphtor Linux - Newbie 2 12-16-2008 07:31 AM
mplayer: your cpu is too slow alpha_lin Linux - Hardware 3 12-28-2006 08:55 AM
mplayer says my computer is too slow... Its not! stellarmarine1 Linux - Software 5 12-29-2004 04:20 AM
Mplayer is slow on some video format ... ?? Elijah Linux - Software 2 04-17-2003 11:10 PM


All times are GMT -5. The time now is 10:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration