LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-06-2013, 04:15 PM   #1
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 35

Rep: Reputation: 2
mplayer problem with xv


I had no problem in 13.37, but since I upgraded to 14.0 X86_64, mplayer refuses to go full screen with default configuration.
I'm using vmlinuz-generic-3.2.29.

Code:
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
When I run xvinfo
Code:
#xvinfo                                                                                  
X-Video Extension version 2.2
screen #0
 no adaptors present
The dmesg part regarding video card is:

Code:
[   11.197612] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   11.197694] i915 0000:00:02.0: setting latency timer to 64
[   11.254588] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6
[   11.281081] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
[   11.281188] [drm] MTRR allocation failed.  Graphics performance may suffer.
[   11.281521] i915 0000:00:02.0: irq 46 for MSI/MSI-X
[   11.281526] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[   11.281602] [drm] Driver supports precise vblank timestamp query.
[   11.281715] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[   11.333750] fixme: max PWM is zero.
[   11.580118] fbcon: inteldrmfb (fb0) is primary device
[   11.654704] Console: switching to colour frame buffer device 160x50
[   11.657394] fb0: inteldrmfb frame buffer device
[   11.657415] drm: registered panic notifier
[   11.866038] ACPI Warning: _BQC returned an invalid level (20110623/video-472)
[   11.866407] acpi device:06: registered as cooling_device2
[   11.866544] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input7
[   11.866786] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[   11.866897] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
With -vo xv option, there is no image.
With -vo x11 option, no fullscreen, cpu utilization at around 18%.
With -vo gl option, fullscreen, but cpu is going through the roof! There's also a message saying:
Code:
Your system is too SLOW to play this!
With -vo gl2, the same as gl
With -vo gl_nosw, there's no image.
With -vo sdl, there's an image, but can't do it full screen, cpu at around 20%.

So, it seems that something is broken.
After reading /usr/doc/MPlayer-20110624/html/en/xv.html and taking into account the output of xvinfo

My /var/log/Xorg.0.log doesn't seem to show any EE error.

From lspci:
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
So, where should I go from here? Is the problem regarding screens not found? Xorg configuration? What to do?
 
Old 02-07-2013, 10:44 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,366

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Quote:
11.254588] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6
[ 11.281081] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
[ 11.281188] [drm] MTRR allocation failed. Graphics performance may suffer.
[ 11.281521] i915 0000:00:02.0: irq 46 for MSI/MSI-X
[ 11.281526] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 11.281602] [drm] Driver supports precise vblank timestamp query.
[ 11.281715] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem: owns=io+mem
[ 11.333750] fixme: max PWM is zero.
[ 11.580118] fbcon: inteldrmfb (fb0) is primary device
[ 11.654704] Console: switching to colour frame buffer device 160x50
[ 11.657394] fb0: inteldrmfb frame buffer device
[ 11.657415] drm: registered panic notifier
[ 11.866038] ACPI Warning: _BQC returned an invalid level (20110623/video-472
Mplayer problems come from many places. Everything in bold is a problem. I don't like that MTRR stuff at all. Where did it get the idea about 160x50?? Is your screen the size of a bus ticket?
This might helphttp://www.tikirobot.net/wp/2009/03/...trrs-on-linux/
 
Old 02-10-2013, 03:59 PM   #3
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 35

Original Poster
Rep: Reputation: 2
Thanks business_kid.
After reading your pointer, I went further and added some parameters to append line for the kernel in lilo.conf:
Code:
enable_mtrr_cleanup mtrr_spare_reg_nr=1
mplayer works fine now and MTRR error doesn't show up anymore.
 
Old 02-11-2013, 04:59 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,366

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Excellent - never knew about them. I've a good nose for b.s., that's all ;-).
 
  


Reply

Tags
mplayer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer problem qrange Linux - Software 1 08-15-2012 05:32 PM
MPlayer problem koricVI Linux - Newbie 5 11-30-2005 01:46 AM
problem with MPLayer parmenion Linux - Software 1 11-12-2005 02:12 AM
mplayer problem ramu_ak Linux - Software 5 06-11-2004 02:31 AM
Problem with MPlayer AskMe Linux - Newbie 3 09-28-2003 10:14 AM


All times are GMT -5. The time now is 11:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration